aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-11-16 05:41:00 +0800
committermiwi <miwi@FreeBSD.org>2008-11-16 05:41:00 +0800
commitd805dc96f577b5ad8b039a7355ef60ed5ec19ed5 (patch)
tree294f3d564ce57c94c2a264ee4c7f2f676b7a0f37 /devel
parentbfd81dfa42ddabd84c0dbca75303e865f549cc2c (diff)
downloadfreebsd-ports-gnome-d805dc96f577b5ad8b039a7355ef60ed5ec19ed5.tar.gz
freebsd-ports-gnome-d805dc96f577b5ad8b039a7355ef60ed5ec19ed5.tar.zst
freebsd-ports-gnome-d805dc96f577b5ad8b039a7355ef60ed5ec19ed5.zip
This is a short script you can run from within an existing git
repository to create a remote repo on Github using a previously created account. This does not create Github accounts (and that violates the terms of service). WWW: http://search.cpan.org/dist/github_creator/ PR: ports/128876 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-github_creator/Makefile28
-rw-r--r--devel/p5-github_creator/distinfo3
-rw-r--r--devel/p5-github_creator/pkg-descr6
-rw-r--r--devel/p5-github_creator/pkg-plist4
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 683b8c40282f..f7133c8ba939 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1884,6 +1884,7 @@
SUBDIR += p5-doxygenfilter
SUBDIR += p5-enum
SUBDIR += p5-forks
+ SUBDIR += p5-github_creator
SUBDIR += p5-iCal-Parser
SUBDIR += p5-mixin
SUBDIR += p5-mocked
diff --git a/devel/p5-github_creator/Makefile b/devel/p5-github_creator/Makefile
new file mode 100644
index 000000000000..bab1fd913249
--- /dev/null
+++ b/devel/p5-github_creator/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-github_creator
+# Date created: 2008-11-15
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= github_creator
+PORTVERSION= 0.13
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/B/BD/BDFOY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Create a Github repository for your Perl module
+
+RUN_DEPENDS= p5-Config-IniFiles>0:${PORTSDIR}/devel/p5-Config-IniFiles \
+ p5-File-Find-Closures>0:${PORTSDIR}/devel/p5-File-Find-Closures \
+ p5-Log-Log4perl>0:${PORTSDIR}/devel/p5-Log-Log4perl \
+ p5-WWW-Mechanize>0:${PORTSDIR}/www/p5-WWW-Mechanize \
+ p5-YAML>0:${PORTSDIR}/textproc/p5-YAML
+
+PERL_CONFIGURE= yes
+
+MAN1= github_creator.1
+
+.include <bsd.port.mk>
diff --git a/devel/p5-github_creator/distinfo b/devel/p5-github_creator/distinfo
new file mode 100644
index 000000000000..e4beb73de58b
--- /dev/null
+++ b/devel/p5-github_creator/distinfo
@@ -0,0 +1,3 @@
+MD5 (github_creator-0.13.tar.gz) = 26ee6220340222c8719f331d55a8df7a
+SHA256 (github_creator-0.13.tar.gz) = 7ecd58e898b20d743faca571f3354fce6238cb8d6e4a3f78e1f7d5a25bb62ea7
+SIZE (github_creator-0.13.tar.gz) = 4386
diff --git a/devel/p5-github_creator/pkg-descr b/devel/p5-github_creator/pkg-descr
new file mode 100644
index 000000000000..a6fe2e45c3d4
--- /dev/null
+++ b/devel/p5-github_creator/pkg-descr
@@ -0,0 +1,6 @@
+This is a short script you can run from within an existing git
+repository to create a remote repo on Github using a previously
+created account. This does not create Github accounts (and that
+violates the terms of service).
+
+WWW: http://search.cpan.org/dist/github_creator/
diff --git a/devel/p5-github_creator/pkg-plist b/devel/p5-github_creator/pkg-plist
new file mode 100644
index 000000000000..6dd271825e71
--- /dev/null
+++ b/devel/p5-github_creator/pkg-plist
@@ -0,0 +1,4 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/github_creator/.packlist
+bin/github_creator
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/github_creator