aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-09-23 23:02:29 +0800
committerstas <stas@FreeBSD.org>2009-09-23 23:02:29 +0800
commitdb0d4b9b86ef0040f4448b60ad83264f29dac17b (patch)
tree7afacc49c5f991d06cc09a4f50283b0ee09f3cc3 /devel
parent0effb0be52c5d5757607ebe253e0ea76c23a1347 (diff)
downloadfreebsd-ports-gnome-db0d4b9b86ef0040f4448b60ad83264f29dac17b.tar.gz
freebsd-ports-gnome-db0d4b9b86ef0040f4448b60ad83264f29dac17b.tar.zst
freebsd-ports-gnome-db0d4b9b86ef0040f4448b60ad83264f29dac17b.zip
- Add port for libdispatch, the userland implementation of Grand Central
Dispatch technology. WWW: http://libdispatch.macosforge.org/ Feature safe: yes (I believe that)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libdispatch/Makefile42
-rw-r--r--devel/libdispatch/distinfo3
-rw-r--r--devel/libdispatch/files/patch-src_Makefile.in11
-rw-r--r--devel/libdispatch/pkg-descr13
-rw-r--r--devel/libdispatch/pkg-plist12
6 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3a466ea9a1e2..9c32a9c9f231 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -640,6 +640,7 @@
SUBDIR += libdfui
SUBDIR += libdict
SUBDIR += libdisasm
+ SUBDIR += libdispatch
SUBDIR += libdlmalloc
SUBDIR += libdlna
SUBDIR += libdnsres
diff --git a/devel/libdispatch/Makefile b/devel/libdispatch/Makefile
new file mode 100644
index 000000000000..cb5a24eb8a7b
--- /dev/null
+++ b/devel/libdispatch/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libdispatch
+# Date created: 2009-09-23
+# Whom: stas
+#
+# $FreeBSD$
+#
+
+PORTNAME= libdispatch
+PORTVERSION= 38
+CATEGORIES= devel
+MASTER_SITES= http://www.SpringDaemons.com/stas/
+DISTNAME= ${PORTNAME}-r${PORTVERSION}
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Grand Central Dispatch API support library
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+
+#
+# Get rid of .la and static library files
+#
+post-configure:
+ @${REINPLACE_CMD} -E -e \
+ '/Install the pseudo-library/,/staticlibs=/s,^,#,' ${WRKSRC}/libtool
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900002
+IGNORE= is not supported on this OS version
+.endif
+
+#
+# We want the CPU to be at least i486 on i386 platform, so GCC builting atomics
+# will work.
+#
+.if ${ARCH} == "i386"
+CPUTYPE?= i486
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libdispatch/distinfo b/devel/libdispatch/distinfo
new file mode 100644
index 000000000000..b34067b72ff4
--- /dev/null
+++ b/devel/libdispatch/distinfo
@@ -0,0 +1,3 @@
+MD5 (libdispatch-r38.tar.bz2) = 94ecbd8b44d9d83e82665e0bdfdf850d
+SHA256 (libdispatch-r38.tar.bz2) = e1e009f57dabc5e7147b9a43b148d88fd8f45486677a28871621a8448c0f231a
+SIZE (libdispatch-r38.tar.bz2) = 293612
diff --git a/devel/libdispatch/files/patch-src_Makefile.in b/devel/libdispatch/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..038f48e10923
--- /dev/null
+++ b/devel/libdispatch/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig 2009-09-23 17:32:20.000000000 +0400
++++ src/Makefile.in 2009-09-23 17:32:40.000000000 +0400
+@@ -218,7 +218,7 @@
+ # define this optional argument? We need appropriate configure parts to make
+ # this conditional.
+ #
+-libdispatch_la_CFLAGS = -Wall -Werror -march=i686
++libdispatch_la_CFLAGS = ${CFLAGS}
+ INCLUDES = -I$(top_builddir) -I$(top_srcdir) \
+ @APPLE_LIBC_SOURCE_PATH@ @APPLE_XNU_SOURCE_PATH@
+
diff --git a/devel/libdispatch/pkg-descr b/devel/libdispatch/pkg-descr
new file mode 100644
index 000000000000..f5655609a575
--- /dev/null
+++ b/devel/libdispatch/pkg-descr
@@ -0,0 +1,13 @@
+This port contains the userland implementation of Grand Central Dispatch
+technology.
+
+The central insight of GCD is shifting the responsibility for managing threads
+and their execution from applications to the operating system. As a result,
+programmers can write less code to deal with concurrent operations in their
+applications, and the system can perform more efficiently on single-processor
+machines, large multiprocessor servers, and everything in between. Without a
+pervasive approach such as GCD, even the best-written application cannot
+deliver the best possible performance, because it doesn'tt have full insight
+into everything else happening in the system.
+
+WWW: http://libdispatch.macosforge.org/
diff --git a/devel/libdispatch/pkg-plist b/devel/libdispatch/pkg-plist
new file mode 100644
index 000000000000..532b0540689d
--- /dev/null
+++ b/devel/libdispatch/pkg-plist
@@ -0,0 +1,12 @@
+include/dispatch/base.h
+include/dispatch/dispatch.h
+include/dispatch/group.h
+include/dispatch/object.h
+include/dispatch/once.h
+include/dispatch/queue.h
+include/dispatch/semaphore.h
+include/dispatch/source.h
+include/dispatch/time.h
+lib/libdispatch.so
+lib/libdispatch.so.0
+@dirrm include/dispatch