aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsumikawa <sumikawa@FreeBSD.org>1999-09-29 00:23:03 +0800
committersumikawa <sumikawa@FreeBSD.org>1999-09-29 00:23:03 +0800
commitdcd1a2626961b8bd5d8318c93916f2e7d00dd0a9 (patch)
tree8deb83f9f0d7050fcffecf584da3b7d48f405636 /devel
parent9d3da981557f3b49de7090f0b74e704cf8dadd1d (diff)
downloadfreebsd-ports-gnome-dcd1a2626961b8bd5d8318c93916f2e7d00dd0a9.tar.gz
freebsd-ports-gnome-dcd1a2626961b8bd5d8318c93916f2e7d00dd0a9.tar.zst
freebsd-ports-gnome-dcd1a2626961b8bd5d8318c93916f2e7d00dd0a9.zip
added the following checking:
"in *_DEPENDS, ${PREFIX} must not be used. use ${LOCALBASE}/${X11BASE} instead of it." Commented by: asami Reviewed by: taoka
Diffstat (limited to 'devel')
-rw-r--r--devel/portlint/Makefile2
-rw-r--r--devel/portlint/src/portlint.pl8
2 files changed, 9 insertions, 1 deletions
diff --git a/devel/portlint/Makefile b/devel/portlint/Makefile
index 714903b95270..f9e23f5d4239 100644
--- a/devel/portlint/Makefile
+++ b/devel/portlint/Makefile
@@ -6,7 +6,7 @@
# $FreeBSD$
#
-DISTNAME= portlint-2.0
+DISTNAME= portlint-2.1
CATEGORIES= devel
DISTFILES= #empty
diff --git a/devel/portlint/src/portlint.pl b/devel/portlint/src/portlint.pl
index d88888a9c17d..7b5205f738cf 100644
--- a/devel/portlint/src/portlint.pl
+++ b/devel/portlint/src/portlint.pl
@@ -981,6 +981,14 @@ EOF
"$j is deprecated.");
}
+ # check for PREFIX
+ if ($m{'dep'} =~ /\${PREFIX}/) {
+ &perror("FATAL: \${PREFIX} must not be ".
+ "contained in *_DEPENDS. ".
+ "use \${LOCALBASE} or ".
+ "\${X11BASE} instead.");
+ }
+
# check port dir existence
$k = $m{'dir'};
$k =~ s/\${PORTSDIR}/$ENV{'PORTSDIR'}/;