aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormich <mich@FreeBSD.org>2003-05-15 20:40:46 +0800
committermich <mich@FreeBSD.org>2003-05-15 20:40:46 +0800
commitdeb18b0a30fe55b635e9236b600b5cbb334495dc (patch)
treeb6271b2f14a09bbb4494f96fc817302c748d057f /devel
parent5ab0db49c01dcc5a1fe16ac411bd843545757efd (diff)
downloadfreebsd-ports-gnome-deb18b0a30fe55b635e9236b600b5cbb334495dc.tar.gz
freebsd-ports-gnome-deb18b0a30fe55b635e9236b600b5cbb334495dc.tar.zst
freebsd-ports-gnome-deb18b0a30fe55b635e9236b600b5cbb334495dc.zip
New port.
DoctorJ is a set of applications that analyze Java code. Documentation is verified for compliance with the standard and for accuracy against the code, beyond what javadoc does. Statistics for a file or project can be generated, including the number of lines of code per class and method, and the overall total. A syntax analyzer is in development PR: 51042 Approved by: roberto(mentor)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/doctorj/Makefile22
-rw-r--r--devel/doctorj/distinfo1
-rw-r--r--devel/doctorj/pkg-descr12
-rw-r--r--devel/doctorj/pkg-plist1
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b8ac0b603d2..0ce7305f0c98 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -150,6 +150,7 @@
SUBDIR += dmake
SUBDIR += dmalloc
SUBDIR += doc++
+ SUBDIR += doctorj
SUBDIR += dotconf
SUBDIR += doxygen
SUBDIR += e4graph
diff --git a/devel/doctorj/Makefile b/devel/doctorj/Makefile
new file mode 100644
index 000000000000..e640f19eae15
--- /dev/null
+++ b/devel/doctorj/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# Ports collection makefile for: doctorj
+# Date created: Wed Apr 16, 2003
+# Whom: Michael L. Hostbaek (mich@freebsdcluster.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= doctorj
+PORTVERSION= 4.0.0
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= mich@freebsdcluster.org
+COMMENT= A tool for analyzing Java code and documentation
+
+GNU_CONFIGURE= yes
+
+MAN1= doctorj.1
+
+.include <bsd.port.mk>
diff --git a/devel/doctorj/distinfo b/devel/doctorj/distinfo
new file mode 100644
index 000000000000..bd1765ed657b
--- /dev/null
+++ b/devel/doctorj/distinfo
@@ -0,0 +1 @@
+MD5 (doctorj-4.0.0.tar.gz) = b20953d4182ac0311496745c97c687c4
diff --git a/devel/doctorj/pkg-descr b/devel/doctorj/pkg-descr
new file mode 100644
index 000000000000..8d59f1e25a2d
--- /dev/null
+++ b/devel/doctorj/pkg-descr
@@ -0,0 +1,12 @@
+DoctorJ is a set of applications that analyze Java code. Documentation is
+verified for compliance with the standard and for accuracy against the
+code, beyond what javadoc does. Statistics for a file or project can be
+generated, including the number of lines of code per class and method,
+and the overall total. A syntax analyzer is in development.
+
+
+WWW: http://doctorj.sourceforge.net/
+AUTHOR: Jeff Pace <jpace@incava.org>
+
+ - Michael L. Hostbaek
+ mich@freebsdcluster.org
diff --git a/devel/doctorj/pkg-plist b/devel/doctorj/pkg-plist
new file mode 100644
index 000000000000..63b44cd2ac73
--- /dev/null
+++ b/devel/doctorj/pkg-plist
@@ -0,0 +1 @@
+bin/doctorj