aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-02 23:26:23 +0800
committerbapt <bapt@FreeBSD.org>2013-09-02 23:26:23 +0800
commite1d30c56d8683b1cbbbfac166938d461c936cb0e (patch)
treec58201dfe596662f56821940b522267813007f01 /devel
parent0511e7239d40a4e00f460b712435334d766a531a (diff)
downloadfreebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.tar.gz
freebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.tar.zst
freebsd-ports-gnome-e1d30c56d8683b1cbbbfac166938d461c936cb0e.zip
Add an explicit dependency on pkgconf
Diffstat (limited to 'devel')
-rw-r--r--devel/libccid/Makefile8
-rw-r--r--devel/libvirt/Makefile2
2 files changed, 4 insertions, 6 deletions
diff --git a/devel/libccid/Makefile b/devel/libccid/Makefile
index 8a3f72d3fc31..b1f24fa2443d 100644
--- a/devel/libccid/Makefile
+++ b/devel/libccid/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: libccid
-# Date created: 2005-01-20
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= ccid
@@ -20,8 +17,9 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
+USES= pkgconfig perl5
GNU_CONFIGURE= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
CONFIGURE_ARGS= --enable-usbdropdir=${PREFIX}/lib/pcsc/drivers \
--enable-ccidtwindir=${PREFIX}/lib/pcsc/drivers/serial
CONFIGURE_ENV= LIBUSB_CFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/libvirt/Makefile b/devel/libvirt/Makefile
index 0514c931a48e..a5e6fd1135dc 100644
--- a/devel/libvirt/Makefile
+++ b/devel/libvirt/Makefile
@@ -51,7 +51,7 @@ PORTSCOUT= limit:\d+\.\d+\.\d+$$
LDFLAGS+= -L${LOCALBASE}/lib -fstack-protector
-USES= charsetfix pathfix gmake
+USES= charsetfix pathfix gmake pkgconfig
USE_LDCONFIG= yes
USE_PYTHON_BUILD= yes
SHLIB_VER= 1001