aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-06-23 18:38:12 +0800
committermiwi <miwi@FreeBSD.org>2008-06-23 18:38:12 +0800
commite8c1020349036b28156c2d9cce0831967bde5520 (patch)
tree4941743e7dab73873070d507a38457e6f4711bd5 /devel
parentd5a22d20524c0d1c8c49ae7714219dd24b187378 (diff)
downloadfreebsd-ports-gnome-e8c1020349036b28156c2d9cce0831967bde5520.tar.gz
freebsd-ports-gnome-e8c1020349036b28156c2d9cce0831967bde5520.tar.zst
freebsd-ports-gnome-e8c1020349036b28156c2d9cce0831967bde5520.zip
libLAS is a BSD library for reading and writing ASPRS LAS version 1.0 and
1.1 data. LAS-formatted data is heavily used in LiDAR processing operations, and the LAS format is a sequential binary format used to store data from sensors and as intermediate processing storage by some applications. WWW: http://liblas.org/ PR: ports/124838 Submitted by: Wen Heping <wenheping at gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/liblas/Makefile20
-rw-r--r--devel/liblas/distinfo3
-rw-r--r--devel/liblas/pkg-descr6
-rw-r--r--devel/liblas/pkg-plist38
5 files changed, 68 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a812d68daada..de5bf4999ee1 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -636,6 +636,7 @@
SUBDIR += libiqxmlrpc
SUBDIR += libisc
SUBDIR += libixp
+ SUBDIR += liblas
SUBDIR += libleaftag
SUBDIR += liblogging
SUBDIR += libltdl15
diff --git a/devel/liblas/Makefile b/devel/liblas/Makefile
new file mode 100644
index 000000000000..6c8da1a98d89
--- /dev/null
+++ b/devel/liblas/Makefile
@@ -0,0 +1,20 @@
+# New ports collection makefile for: liblas
+# Date created: 21 June 2008
+# Whom: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= liblas
+PORTVERSION= 0.9.7
+CATEGORIES= devel
+MASTER_SITES= http://liblas.org/raw-attachment/wiki/${PORTVERSION}/
+DISTNAME= las-${PORTVERSION}
+
+MAINTAINER= wenheping@gmail.com
+COMMENT= A Library For Reading And Writing LAS-Format Data
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+.include <bsd.port.mk>
diff --git a/devel/liblas/distinfo b/devel/liblas/distinfo
new file mode 100644
index 000000000000..f2156495e2cc
--- /dev/null
+++ b/devel/liblas/distinfo
@@ -0,0 +1,3 @@
+MD5 (las-0.9.7.tar.bz2) = 4600b06e261ac53a9bc823168af86710
+SHA256 (las-0.9.7.tar.bz2) = 89385222588948b5d27943fed5ea743dc98709a4195ac946abd8264ba7f933be
+SIZE (las-0.9.7.tar.bz2) = 288072
diff --git a/devel/liblas/pkg-descr b/devel/liblas/pkg-descr
new file mode 100644
index 000000000000..17895fa7d78d
--- /dev/null
+++ b/devel/liblas/pkg-descr
@@ -0,0 +1,6 @@
+libLAS is a BSD library for reading and writing ASPRS LAS version 1.0 and
+1.1 data. LAS-formatted data is heavily used in LiDAR processing operations,
+and the LAS format is a sequential binary format used to store data from
+sensors and as intermediate processing storage by some applications.
+
+WWW: http://liblas.org/
diff --git a/devel/liblas/pkg-plist b/devel/liblas/pkg-plist
new file mode 100644
index 000000000000..44602f333462
--- /dev/null
+++ b/devel/liblas/pkg-plist
@@ -0,0 +1,38 @@
+bin/las2las
+bin/las2txt
+bin/lasinfo
+bin/lasmerge
+bin/txt2las
+include/liblas/cstdint.hpp
+include/liblas/endian.hpp
+include/liblas/exception.hpp
+include/liblas/file.hpp
+include/liblas/fwd.hpp
+include/liblas/guid.hpp
+include/liblas/iterator.hpp
+include/liblas/las_config.h
+include/liblas/las_version.h
+include/liblas/laserror.hpp
+include/liblas/lasfile.hpp
+include/liblas/lasheader.hpp
+include/liblas/laspoint.hpp
+include/liblas/lasreader.hpp
+include/liblas/lasrecordheader.hpp
+include/liblas/laswriter.hpp
+include/liblas/liblas.h
+include/liblas/liblas.hpp
+include/liblas/reader.hpp
+include/liblas/reader10.hpp
+include/liblas/reader11.hpp
+include/liblas/sha1.hpp
+include/liblas/sharedptr.hpp
+include/liblas/timer.hpp
+include/liblas/utility.hpp
+include/liblas/writer.hpp
+include/liblas/writer10.hpp
+include/liblas/writer11.hpp
+lib/liblas.a
+lib/liblas.la
+lib/liblas.so
+lib/liblas.so.1
+@dirrm include/liblas