aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-10-07 13:45:04 +0800
committerlinimon <linimon@FreeBSD.org>2007-10-07 13:45:04 +0800
commite9b556135b3e4068be9ec53d65e526a353da19e6 (patch)
tree3631800b38966f03de424f6228f938054f94dd22 /devel
parent6c105d7853336dcccdbcc998e9ac6da17d4439db (diff)
downloadfreebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.tar.gz
freebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.tar.zst
freebsd-ports-gnome-e9b556135b3e4068be9ec53d65e526a353da19e6.zip
Set USE_PERL5/WANT_PERL as appropriate, for ports that either depend on
perl unconditonally, or conditionally. To be able to conditionalize the inclusion of bsd.perl.mk, they now need to be defined before the inclusion of bsd.port.pre.mk. Hat: portmgr
Diffstat (limited to 'devel')
-rw-r--r--devel/subversion-devel/Makefile2
-rw-r--r--devel/subversion-freebsd/Makefile2
-rw-r--r--devel/subversion/Makefile2
-rw-r--r--devel/subversion16/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/devel/subversion-devel/Makefile b/devel/subversion-devel/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion-devel/Makefile
+++ b/devel/subversion-devel/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion-freebsd/Makefile b/devel/subversion-freebsd/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion-freebsd/Makefile
+++ b/devel/subversion-freebsd/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index d0e06a97203c..7a3cfa7c55a9 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -27,6 +27,7 @@ USE_BZIP2= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ARGS= --with-ssl
+WANT_PERL= yes
USE_RC_SUBR= svnserve
@@ -94,7 +95,6 @@ PLIST_SUB+= WITHOUT_BDB=""
.if defined(WITH_PERL)
USE_PERL5= 5.8.0+
SWIG_BINDINGS+= yes
-USE_PERL5= yes
PLIST_SUB+= WITH_PERL=""
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= SVN::Base.3 \