aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-12-26 15:39:00 +0800
committerijliao <ijliao@FreeBSD.org>2003-12-26 15:39:00 +0800
commitefdb865db24f83d55faf261788430535e8398608 (patch)
tree8e495ab88c4d6275ab327078d2378661b8068fc9 /devel
parent9c7748b600a1bdad7e6221cea7b761e102a57bc7 (diff)
downloadfreebsd-ports-gnome-efdb865db24f83d55faf261788430535e8398608.tar.gz
freebsd-ports-gnome-efdb865db24f83d55faf261788430535e8398608.tar.zst
freebsd-ports-gnome-efdb865db24f83d55faf261788430535e8398608.zip
add ustl 0.4.1
Codespace-frugal STL implementation
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ustl/Makefile25
-rw-r--r--devel/ustl/distinfo1
-rw-r--r--devel/ustl/pkg-descr4
-rw-r--r--devel/ustl/pkg-plist42
5 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4847b11ca842..c68788e6b2de 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1129,6 +1129,7 @@
SUBDIR += umbrello
SUBDIR += upnp
SUBDIR += ups-debug
+ SUBDIR += ustl
SUBDIR += varconf
SUBDIR += vb2c
SUBDIR += veepee
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
new file mode 100644
index 000000000000..3bf0651ced5f
--- /dev/null
+++ b/devel/ustl/Makefile
@@ -0,0 +1,25 @@
+# ex:ts=8
+# Ports collection makefile for: uSTL
+# Date created: Dec 26, 2003
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= ustl
+PORTVERSION= 0.4.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Codespace-frugal STL implementation
+
+USE_BZIP2= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+HAS_CONFIGURE= yes
+USE_GMAKE= yes
+ALL_TARGET= # empty
+
+.include <bsd.port.mk>
diff --git a/devel/ustl/distinfo b/devel/ustl/distinfo
new file mode 100644
index 000000000000..68fa3cdbcd5a
--- /dev/null
+++ b/devel/ustl/distinfo
@@ -0,0 +1 @@
+MD5 (ustl-0.4-1.tar.bz2) = a6ae59bc5e1ad54cb700a48ea67d7fa1
diff --git a/devel/ustl/pkg-descr b/devel/ustl/pkg-descr
new file mode 100644
index 000000000000..9690e76cc94b
--- /dev/null
+++ b/devel/ustl/pkg-descr
@@ -0,0 +1,4 @@
+uSTL (micro-STL) is a partial implementation of the STL specification intended
+to reduce code size of the derivative programs.
+
+WWW: http://ustl.sourceforge.net/
diff --git a/devel/ustl/pkg-plist b/devel/ustl/pkg-plist
new file mode 100644
index 000000000000..69621d3eb450
--- /dev/null
+++ b/devel/ustl/pkg-plist
@@ -0,0 +1,42 @@
+include/ustl/cmemlink.h
+include/ustl/config.h
+include/ustl/fdostream.h
+include/ustl/memblock.h
+include/ustl/memlink.h
+include/ustl/mistream.h
+include/ustl/mostream.h
+include/ustl/sistream.h
+include/ustl/sostream.h
+include/ustl/strmsize.h
+include/ustl/ualgo.h
+include/ustl/ualgobase.h
+include/ustl/ubitset.h
+include/ustl/uctralgo.h
+include/ustl/uexception.h
+include/ustl/ufunction.h
+include/ustl/uios.h
+include/ustl/uiosfunc.h
+include/ustl/uiterator.h
+include/ustl/ulimits.h
+include/ustl/ulist.h
+include/ustl/umap.h
+include/ustl/umemory.h
+include/ustl/umultimap.h
+include/ustl/umultiset.h
+include/ustl/unew.h
+include/ustl/unumeric.h
+include/ustl/upair.h
+include/ustl/upredalgo.h
+include/ustl/uset.h
+include/ustl/uspecial.h
+include/ustl/ustack.h
+include/ustl/ustl.h
+include/ustl/ustring.h
+include/ustl/utf8.h
+include/ustl/utuple.h
+include/ustl/utypes.h
+include/ustl/uutility.h
+include/ustl/uvector.h
+@dirrm include/ustl
+include/ustl.h
+lib/libustl.a