aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-12-18 17:09:16 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-12-18 17:09:16 +0800
commitf40a76681826a9fd0d00837310c0d4f0360e5f53 (patch)
tree8035e3a0fea1fe1ae4bfbf3b30ba2c4c1d960010 /devel
parent9fd7a77d209c8eba90e9faf14bde811cd9b71b3f (diff)
downloadfreebsd-ports-gnome-f40a76681826a9fd0d00837310c0d4f0360e5f53.tar.gz
freebsd-ports-gnome-f40a76681826a9fd0d00837310c0d4f0360e5f53.tar.zst
freebsd-ports-gnome-f40a76681826a9fd0d00837310c0d4f0360e5f53.zip
- Add p5-Thrift-XS 1.04
Thrift::XS provides faster versions of Thrift::BinaryProtocol and Thrift::MemoryBuffer. Thrift compact protocol support is also available, just replace Thrift::XS::BinaryProtocol with Thrift::XS::CompactProtocol. To use, simply replace your Thrift initialization code with the appropriate Thrift::XS version. WWW: http://search.cpan.org/dist/Thrift-XS/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Thrift-XS/Makefile39
-rw-r--r--devel/p5-Thrift-XS/distinfo2
-rw-r--r--devel/p5-Thrift-XS/pkg-descr10
-rw-r--r--devel/p5-Thrift-XS/pkg-plist21
5 files changed, 73 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 74b65e4f314f..f0531d76dd34 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2538,6 +2538,7 @@
SUBDIR += p5-Thread-Queue-Duplex
SUBDIR += p5-Thread-Suspend
SUBDIR += p5-Thrift
+ SUBDIR += p5-Thrift-XS
SUBDIR += p5-Throwable
SUBDIR += p5-Tie-Array-Pack
SUBDIR += p5-Tie-Array-Sorted
diff --git a/devel/p5-Thrift-XS/Makefile b/devel/p5-Thrift-XS/Makefile
new file mode 100644
index 000000000000..9e3e8813008e
--- /dev/null
+++ b/devel/p5-Thrift-XS/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: p5-Thrift-XS
+# Date created: 2011-12-15
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Thrift-XS
+PORTVERSION= 1.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:AGRUNDMA
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Faster Thrift binary protocol encoding and decoding
+
+BUILD_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= p5-Bit-Vector>=0:${PORTSDIR}/math/p5-Bit-Vector \
+ p5-HTTP-Message>=0:${PORTSDIR}/www/p5-HTTP-Message \
+ p5-IO-String>=0:${PORTSDIR}/devel/p5-IO-String \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+
+TEST_DEPENDS= p5-Proc-ProcessTable>=0:${PORTSDIR}/devel/p5-Proc-ProcessTable \
+ p5-Test-BinaryData>=0:${PORTSDIR}/devel/p5-Test-BinaryData \
+ p5-Test-Pod>=1.14:${PORTSDIR}/devel/p5-Test-Pod \
+ p5-Test-Pod-Coverage>=1.04:${PORTSDIR}/devel/p5-Test-Pod-Coverage
+
+PERL_CONFIGURE= yes
+
+MAN3= Thrift::XS.3 \
+ Thrift::XS::BinaryProtocol.3 \
+ Thrift::XS::CompactProtocol.3 \
+ Thrift::XS::MemoryBuffer.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Thrift-XS/distinfo b/devel/p5-Thrift-XS/distinfo
new file mode 100644
index 000000000000..ed0f5e3a6f46
--- /dev/null
+++ b/devel/p5-Thrift-XS/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Thrift-XS-1.04.tar.gz) = 96a9b9ce9dfc9c888e1752014666c83ef70de90e2e658baf58bd39c029369089
+SIZE (Thrift-XS-1.04.tar.gz) = 79142
diff --git a/devel/p5-Thrift-XS/pkg-descr b/devel/p5-Thrift-XS/pkg-descr
new file mode 100644
index 000000000000..7a5455342a8c
--- /dev/null
+++ b/devel/p5-Thrift-XS/pkg-descr
@@ -0,0 +1,10 @@
+Thrift::XS provides faster versions of Thrift::BinaryProtocol and
+Thrift::MemoryBuffer.
+
+Thrift compact protocol support is also available, just replace
+Thrift::XS::BinaryProtocol with Thrift::XS::CompactProtocol.
+
+To use, simply replace your Thrift initialization code with the appropriate
+Thrift::XS version.
+
+WWW: http://search.cpan.org/dist/Thrift-XS/
diff --git a/devel/p5-Thrift-XS/pkg-plist b/devel/p5-Thrift-XS/pkg-plist
new file mode 100644
index 000000000000..6ef1794a6fac
--- /dev/null
+++ b/devel/p5-Thrift-XS/pkg-plist
@@ -0,0 +1,21 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/BinaryProtocol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/BufferedTransport.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/FramedTransport.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/HttpClient.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/MemoryBuffer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/Protocol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/Server.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/Socket.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/Transport.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/XS/BinaryProtocol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/XS/CompactProtocol.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Thrift/XS/MemoryBuffer.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Thrift/XS/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Thrift/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Thrift/XS/XS.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thrift/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Thrift
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Thrift/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Thrift