aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2013-09-25 20:31:15 +0800
committerwg <wg@FreeBSD.org>2013-09-25 20:31:15 +0800
commitf5b3e4f72ab44ccf9c1fa8b1ef7194a231e8d68c (patch)
tree560edd89ed0b721e0b63c218392076a1a873062c /devel
parent5b16cdd82ee236986eaec510b9ff50327b3efa4a (diff)
downloadfreebsd-ports-gnome-f5b3e4f72ab44ccf9c1fa8b1ef7194a231e8d68c.tar.gz
freebsd-ports-gnome-f5b3e4f72ab44ccf9c1fa8b1ef7194a231e8d68c.tar.zst
freebsd-ports-gnome-f5b3e4f72ab44ccf9c1fa8b1ef7194a231e8d68c.zip
devel/lightning: update to 2.0.1
- Update to 2.0.1 [1] - Use options helpers Changes: https://lists.gnu.org/archive/html/lightning/2013-09/msg00006.html PR: ports/182370 Submitted by: Vitaly Magerya <vmagerya gmail.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/lightning/Makefile15
-rw-r--r--devel/lightning/distinfo4
-rw-r--r--devel/lightning/files/patch-configure19
-rw-r--r--devel/lightning/files/patch-include-lightning.h11
-rw-r--r--devel/lightning/pkg-plist1
5 files changed, 7 insertions, 43 deletions
diff --git a/devel/lightning/Makefile b/devel/lightning/Makefile
index d11a6b834443..09db75a49856 100644
--- a/devel/lightning/Makefile
+++ b/devel/lightning/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= lightning
-PORTVERSION= 2.0.0
+PORTVERSION= 2.0.1
CATEGORIES= devel
MASTER_SITES= GNU
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -13,6 +13,9 @@ COMMENT= Generates assembly language code at run-time
OPTIONS_DEFINE= ASSERTIONS
ASSERTIONS_DESC=Enable runtime code generation assertions
+ASSERTIONS_CONFIGURE_ON=--enable-assertions=yes
+ASSERTIONS_CONFIGURE_OFF=--enable-assertions=no
+
ONLY_FOR_ARCHS= i386 amd64 arm ia64 powerpc sparc64 mips
USE_LDCONFIG= yes
@@ -21,16 +24,6 @@ CONFIGURE_ARGS= --enable-disassembler=no
PLIST_SUB+= JIT_ARCH=${ARCH:S/i386/x86/:S/amd64/x86/:S/sparc64/sparc/:S/powerpc/ppc/}
-INFO= lightning
-
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MASSERTIONS}
-CONFIGURE_ARGS+=--enable-assertions=yes
-.else
-CONFIGURE_ARGS+=--enable-assertions=no
-.endif
-
regression-test: build
(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} \
${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} check)
diff --git a/devel/lightning/distinfo b/devel/lightning/distinfo
index 640a56d9b581..43ab803c7fef 100644
--- a/devel/lightning/distinfo
+++ b/devel/lightning/distinfo
@@ -1,2 +1,2 @@
-SHA256 (lightning-2.0.0.tar.gz) = e41736c5c6c40eeb194e3f9fec3209e86f07f9471d0aacc5d35c1c8e55621054
-SIZE (lightning-2.0.0.tar.gz) = 852571
+SHA256 (lightning-2.0.1.tar.gz) = 6513a793937db5b1df62a8cf75ad2195143107efdab914d69f77e3fc6e4e81b1
+SIZE (lightning-2.0.1.tar.gz) = 861965
diff --git a/devel/lightning/files/patch-configure b/devel/lightning/files/patch-configure
deleted file mode 100644
index dc9bf7b6ca60..000000000000
--- a/devel/lightning/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig 2013-08-23 21:12:43.000000000 +0300
-+++ configure 2013-08-25 15:53:56.000000000 +0300
-@@ -11650,6 +11650,7 @@
- fi
-
- case "$host_os" in
-+ *freebsd*) SHLIB="" ;;
- *hpux*) SHLIB="-ldld" ;;
- *) SHLIB="-ldl" ;;
- esac
-@@ -11657,7 +11658,7 @@
-
- cpu=
- case "$target_cpu" in
-- i?86|x86_64) cpu=x86 ;;
-+ i?86|x86_64|amd64) cpu=x86 ;;
- *arm*) cpu=arm ;;
- *mips*) cpu=mips ;;
- *powerpc*) cpu=ppc ;;
diff --git a/devel/lightning/files/patch-include-lightning.h b/devel/lightning/files/patch-include-lightning.h
deleted file mode 100644
index 27031030ccae..000000000000
--- a/devel/lightning/files/patch-include-lightning.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- include/lightning.h.orig 2013-09-02 13:38:10.000000000 +0300
-+++ include/lightning.h 2013-09-02 14:57:27.000000000 +0300
-@@ -38,7 +38,7 @@
- # define __WORDSIZE WORDSIZE
- # elif defined(__SIZEOF_POINTER__) /* ppc aix */
- # define __WORDSIZE (__SIZEOF_POINTER__ << 3)
--# elif defined(_ILP32) /* hppa hp-ux */
-+# elif defined(_ILP32) || defined(__i386__) /* hppa hp-ux, i386 gcc 4.2 */
- # define __WORDSIZE 32
- # elif defined(_LP64) /* ia64 hp-ux (with cc +DD64) */
- # define __WORDSIZE 64
diff --git a/devel/lightning/pkg-plist b/devel/lightning/pkg-plist
index 5a0abf8930db..40563f99ed56 100644
--- a/devel/lightning/pkg-plist
+++ b/devel/lightning/pkg-plist
@@ -1,5 +1,6 @@
include/lightning.h
include/lightning/jit_%%JIT_ARCH%%.h
+info/lightning.info
lib/liblightning.a
lib/liblightning.la
lib/liblightning.so