aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-11-29 11:42:09 +0800
committerclsung <clsung@FreeBSD.org>2006-11-29 11:42:09 +0800
commitf7832391c640a6b04ce3942f8f50f8445cc987a1 (patch)
treeb67259d38e6c65daa6eeb3a0620558468933a73a /devel
parent2fe17fb377f724c8f1c7100ab4ecde987933988c (diff)
downloadfreebsd-ports-gnome-f7832391c640a6b04ce3942f8f50f8445cc987a1.tar.gz
freebsd-ports-gnome-f7832391c640a6b04ce3942f8f50f8445cc987a1.tar.zst
freebsd-ports-gnome-f7832391c640a6b04ce3942f8f50f8445cc987a1.zip
- Update to 0.9.0
- fix pkg-plist - fix WWW PR: ports/103699 Submitted by: Geraud CONTINSOUZAS <geraud_AT_gcu dot info> Approved by: maintainer (Jonathan Weiss)
Diffstat (limited to 'devel')
-rw-r--r--devel/ruby-gems/Makefile2
-rw-r--r--devel/ruby-gems/Makefile.common2
-rw-r--r--devel/ruby-gems/distinfo6
-rw-r--r--devel/ruby-gems/pkg-descr2
-rw-r--r--devel/ruby-gems/pkg-plist26
5 files changed, 21 insertions, 17 deletions
diff --git a/devel/ruby-gems/Makefile b/devel/ruby-gems/Makefile
index 80a665a2ea6f..efc5212b9a65 100644
--- a/devel/ruby-gems/Makefile
+++ b/devel/ruby-gems/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gems
-PORTVERSION= 0.8.11
+PORTVERSION= 0.9.0
CATEGORIES= devel ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ruby${PORTNAME}
diff --git a/devel/ruby-gems/Makefile.common b/devel/ruby-gems/Makefile.common
index 78b871f319a0..512f1239f1b8 100644
--- a/devel/ruby-gems/Makefile.common
+++ b/devel/ruby-gems/Makefile.common
@@ -42,4 +42,4 @@ PLIST_SUB+= PORTVERSION="${PORTVERSION}" \
RUBYGEMBIN= ${LOCALBASE}/bin/gem
do-install:
- ${RUBYGEMBIN} install --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
+ ${RUBYGEMBIN} install --no-ri --install-dir ${PREFIX}/lib/ruby/gems/${REV} ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME}${EXTRACT_SUFX}
diff --git a/devel/ruby-gems/distinfo b/devel/ruby-gems/distinfo
index a0aea7d8bcd9..59096d3ca737 100644
--- a/devel/ruby-gems/distinfo
+++ b/devel/ruby-gems/distinfo
@@ -1,3 +1,3 @@
-MD5 (ruby/rubygems-0.8.11.tgz) = aa363b428c4c1fc2e076a4ff77b957d7
-SHA256 (ruby/rubygems-0.8.11.tgz) = 6ad2b857248aef0e9a5297f708f9988fbade78e16d670109937a73e56fdbae6d
-SIZE (ruby/rubygems-0.8.11.tgz) = 160265
+MD5 (ruby/rubygems-0.9.0.tgz) = 5d496e1f415b8b4033ab867f01d1161f
+SHA256 (ruby/rubygems-0.9.0.tgz) = 6e90baff5ec951939ffcec569b9e1829e46da56cd320b1de1c8e2f5be828fef0
+SIZE (ruby/rubygems-0.9.0.tgz) = 174321
diff --git a/devel/ruby-gems/pkg-descr b/devel/ruby-gems/pkg-descr
index 3ee65cd4c60c..b00e14e62058 100644
--- a/devel/ruby-gems/pkg-descr
+++ b/devel/ruby-gems/pkg-descr
@@ -12,4 +12,4 @@ Using RubyGems, you can:
- easily remove libraries you no longer use
- have power and control over your Ruby platform!
-WWW: http://rubygems.rubyforge.org/wiki/wiki.pl
+WWW: http://docs.rubygems.org/
diff --git a/devel/ruby-gems/pkg-plist b/devel/ruby-gems/pkg-plist
index fd5e934b66b2..6951bcad88f0 100644
--- a/devel/ruby-gems/pkg-plist
+++ b/devel/ruby-gems/pkg-plist
@@ -1,26 +1,28 @@
bin/gem
bin/gem_server
bin/gem_mirror
+bin/gemlock
+bin/gemri
bin/gemwhich
-bin/generate_yaml_index.rb
+bin/index_gem_repository.rb
bin/update_rubygems
lib/ruby/gems/%%RUBY_VER%%/cache/sources-0.0.1.gem
lib/ruby/gems/%%RUBY_VER%%/gems/sources-0.0.1/lib/sources.rb
lib/ruby/gems/%%RUBY_VER%%/specifications/sources-0.0.1.gemspec
-@unexec rm %D/lib/ruby/gems/%%RUBY_VER%%/source_cache 2>/dev/null || true
%%RUBY_SITELIBDIR%%/gemconfigure.rb
+%%RUBY_SITELIBDIR%%/rbconfig/datadir.rb
%%RUBY_SITELIBDIR%%/rubygems/builder.rb
%%RUBY_SITELIBDIR%%/rubygems/cmd_manager.rb
%%RUBY_SITELIBDIR%%/rubygems/command.rb
%%RUBY_SITELIBDIR%%/rubygems/config_file.rb
%%RUBY_SITELIBDIR%%/rubygems/custom_require.rb
%%RUBY_SITELIBDIR%%/rubygems/dependency_list.rb
-%%RUBY_SITELIBDIR%%/rubygems/deployment.rb
%%RUBY_SITELIBDIR%%/rubygems/doc_manager.rb
%%RUBY_SITELIBDIR%%/rubygems/format.rb
%%RUBY_SITELIBDIR%%/rubygems/gem_commands.rb
-%%RUBY_SITELIBDIR%%/rubygems/gem_runner.rb
%%RUBY_SITELIBDIR%%/rubygems/gem_openssl.rb
+%%RUBY_SITELIBDIR%%/rubygems/gem_runner.rb
+%%RUBY_SITELIBDIR%%/rubygems/incremental_fetcher.rb
%%RUBY_SITELIBDIR%%/rubygems/installer.rb
%%RUBY_SITELIBDIR%%/rubygems/loadpath_manager.rb
%%RUBY_SITELIBDIR%%/rubygems/old_format.rb
@@ -38,12 +40,14 @@ lib/ruby/gems/%%RUBY_VER%%/specifications/sources-0.0.1.gemspec
%%RUBY_SITELIBDIR%%/rubygems.rb
%%RUBY_SITELIBDIR%%/ubygems.rb
@exec mkdir -p %D/lib/ruby/gems/%%RUBY_VER%%/doc
+@dirrm %%RUBY_SITELIBDIR%%/rbconfig
@dirrm %%RUBY_SITELIBDIR%%/rubygems
-@dirrm lib/ruby/gems/1.8/specifications
-@dirrm lib/ruby/gems/1.8/gems/sources-0.0.1/lib
-@dirrm lib/ruby/gems/1.8/gems/sources-0.0.1
-@dirrm lib/ruby/gems/1.8/gems
-@dirrm lib/ruby/gems/1.8/doc
-@dirrm lib/ruby/gems/1.8/cache
-@dirrm lib/ruby/gems/1.8
+@dirrmtry lib/ruby/gems/%%RUBY_VER%%/source_cache
+@dirrm lib/ruby/gems/%%RUBY_VER%%/specifications
+@dirrm lib/ruby/gems/%%RUBY_VER%%/gems/sources-0.0.1/lib
+@dirrm lib/ruby/gems/%%RUBY_VER%%/gems/sources-0.0.1
+@dirrm lib/ruby/gems/%%RUBY_VER%%/gems
+@dirrm lib/ruby/gems/%%RUBY_VER%%/doc
+@dirrm lib/ruby/gems/%%RUBY_VER%%/cache
+@dirrm lib/ruby/gems/%%RUBY_VER%%
@dirrm lib/ruby/gems