aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-02-10 23:42:09 +0800
committerjbeich <jbeich@FreeBSD.org>2017-02-10 23:42:09 +0800
commitfc2c845076ebcbcd33aeb2489c31b6c330f0f91b (patch)
tree95b6e43640ef7de16ee9191894b891edf75d3cec /devel
parent4cc7664376942a9d5f029f02a009be71ab615845 (diff)
downloadfreebsd-ports-gnome-fc2c845076ebcbcd33aeb2489c31b6c330f0f91b.tar.gz
freebsd-ports-gnome-fc2c845076ebcbcd33aeb2489c31b6c330f0f91b.tar.zst
freebsd-ports-gnome-fc2c845076ebcbcd33aeb2489c31b6c330f0f91b.zip
devel/p5-Event-Lib: unbreak after r433286
- Add a patch to compile with libevent 2.1 (only compile-tested!) after https://github.com/libevent/libevent/commit/cba59e53253b - Reformat an existing patch through "make makepatch" - Drop maintainership as the current maintainer no longer uses the port and wishes to resign PR: 216531 Submitted by: Fabian Keil <fk@fabiankeil.de> (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Event-Lib/Makefile4
-rw-r--r--devel/p5-Event-Lib/files/patch-Lib.xs14
-rw-r--r--devel/p5-Event-Lib/files/patch-Makefile.PL14
3 files changed, 21 insertions, 11 deletions
diff --git a/devel/p5-Event-Lib/Makefile b/devel/p5-Event-Lib/Makefile
index 279769321085..cff1b61243f9 100644
--- a/devel/p5-Event-Lib/Makefile
+++ b/devel/p5-Event-Lib/Makefile
@@ -8,13 +8,11 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-MAINTAINER= fk@fabiankeil.de
+MAINTAINER= ports@FreeBSD.org
COMMENT= Makes libevent(3) accessible with Perl
LIB_DEPENDS= libevent.so:devel/libevent2
-BROKEN= fails to build with libevent 2.1
-
USES= perl5
USE_PERL5= configure
diff --git a/devel/p5-Event-Lib/files/patch-Lib.xs b/devel/p5-Event-Lib/files/patch-Lib.xs
new file mode 100644
index 000000000000..78b24555762b
--- /dev/null
+++ b/devel/p5-Event-Lib/files/patch-Lib.xs
@@ -0,0 +1,14 @@
+--- Lib.xs.orig 2007-07-29 11:02:37 UTC
++++ Lib.xs
+@@ -125,6 +125,11 @@ void free_args (struct event_args *args)
+ Safefree(args);
+ }
+
++#if LIBEVENT_VERSION_NUMBER > 0x02010101
++// From event-internal.h
++#define ev_arg ev_evcallback.evcb_arg
++#endif
++
+ void refresh_event (struct event_args *args, char *class) {
+ SV *sv = newSV(0);
+ sv_setref_pv(sv, class, (void*)args);
diff --git a/devel/p5-Event-Lib/files/patch-Makefile.PL b/devel/p5-Event-Lib/files/patch-Makefile.PL
index 6e2bc8fcfbb6..123d246521ae 100644
--- a/devel/p5-Event-Lib/files/patch-Makefile.PL
+++ b/devel/p5-Event-Lib/files/patch-Makefile.PL
@@ -1,6 +1,6 @@
---- Makefile.PL.orig Tue Mar 7 08:37:40 2006
-+++ Makefile.PL Mon Jun 5 23:31:13 2006
-@@ -2,7 +2,11 @@
+--- Makefile.PL.orig 2007-07-29 11:14:02 UTC
++++ Makefile.PL
+@@ -2,7 +2,11 @@ use 5.006;
use ExtUtils::MakeMaker;
use Config;
@@ -13,9 +13,7 @@
# purge @ARGV of CCFLAGS
---- Makefile.PL
-+++ Makefile.PL
-@@ -17,8 +17,9 @@ sub have_libevent {
+@@ -13,8 +17,9 @@ sub have_libevent {
my $LIBS = $args{ LIBS } || "-levent";
my $INC = $args{ INC } || "-I/usr/include";
if ($^O eq "freebsd") {
@@ -27,7 +25,7 @@
}
elsif ($^O eq "darwin") {
$LIBS = "$LIBS -L/sw/lib -L/opt/local/lib";
-@@ -59,8 +60,9 @@ sub get_defines {
+@@ -55,8 +60,9 @@ sub get_defines {
my $LIBS = $args{ LIBS } || "-levent";
my $INC = $args{ INC } || "-I/usr/include";
if ($^O eq "freebsd") {
@@ -39,7 +37,7 @@
}
elsif ($^O eq "darwin") {
$LIBS = "-L/sw/lib -L/opt/local/lib $LIBS";
-@@ -100,6 +102,12 @@ EOD
+@@ -96,6 +102,12 @@ EOD
$args{LIBS} = '-levent -lm' if ! exists $args{LIBS};