aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2004-06-03 10:56:43 +0800
committerijliao <ijliao@FreeBSD.org>2004-06-03 10:56:43 +0800
commitfcbebe28011a88c922a5e55ea5b3fc09a40c416b (patch)
treeaeb0fa7bbac97cccea2d5dd7510f50b5a44ba49e /devel
parent4054c11b1c1a2d603c8765c793cf89685c986405 (diff)
downloadfreebsd-ports-gnome-fcbebe28011a88c922a5e55ea5b3fc09a40c416b.tar.gz
freebsd-ports-gnome-fcbebe28011a88c922a5e55ea5b3fc09a40c416b.tar.zst
freebsd-ports-gnome-fcbebe28011a88c922a5e55ea5b3fc09a40c416b.zip
add p5-POE-Component-Child 1.31
POE child management PR: 62175 Submitted by: Zach Thompson <lin-chi@lastamericanempire.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Component-Child/Makefile27
-rw-r--r--devel/p5-POE-Component-Child/distinfo1
-rw-r--r--devel/p5-POE-Component-Child/pkg-descr5
-rw-r--r--devel/p5-POE-Component-Child/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 86676cb3c950..21e37e498c8f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -840,6 +840,7 @@
SUBDIR += p5-PCSC-Card
SUBDIR += p5-POE
SUBDIR += p5-POE-API-Peek
+ SUBDIR += p5-POE-Component-Child
SUBDIR += p5-POE-Component-Client-HTTP
SUBDIR += p5-POE-Component-Client-POP3
SUBDIR += p5-POE-Component-Client-Ping
diff --git a/devel/p5-POE-Component-Child/Makefile b/devel/p5-POE-Component-Child/Makefile
new file mode 100644
index 000000000000..27064d5f57de
--- /dev/null
+++ b/devel/p5-POE-Component-Child/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-Child
+# Date created: 31 January 2004
+# Whom: Zach Thompson <lin-chi@lastamericanempire.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Child
+PORTVERSION= 1.31
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lin-chi@lastamericanempire.com
+COMMENT= POE child management
+
+BUILD_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Child.3
+
+post-install:
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-Child/distinfo b/devel/p5-POE-Component-Child/distinfo
new file mode 100644
index 000000000000..af566e8d7f79
--- /dev/null
+++ b/devel/p5-POE-Component-Child/distinfo
@@ -0,0 +1 @@
+MD5 (POE-Component-Child-1.31.tar.gz) = e3989793a524fed21f48ca3ef443b538
diff --git a/devel/p5-POE-Component-Child/pkg-descr b/devel/p5-POE-Component-Child/pkg-descr
new file mode 100644
index 000000000000..3b3a663c4a07
--- /dev/null
+++ b/devel/p5-POE-Component-Child/pkg-descr
@@ -0,0 +1,5 @@
+POE-Component-Child
+
+This component allows for the creation and management of children
+processes within the POE environment.
+
diff --git a/devel/p5-POE-Component-Child/pkg-plist b/devel/p5-POE-Component-Child/pkg-plist
new file mode 100644
index 000000000000..a1b221ff6abd
--- /dev/null
+++ b/devel/p5-POE-Component-Child/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/POE/Component/Child.pm
+%%SITE_PERL%%/mach/auto/POE/Component/Child/.packlist
+@dirrm %%SITE_PERL%%/mach/auto/POE/Component/Child
+@unexec rmdir %D/%%SITE_PERL%%/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/POE 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/POE/Component 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/mach/auto/POE 2>/dev/null || true