aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2006-08-02 09:21:33 +0800
committerijliao <ijliao@FreeBSD.org>2006-08-02 09:21:33 +0800
commitfd5752dde4f60b38f72bfe63017c4dceadb521aa (patch)
tree9fb4a1a663cd8f1b629db5ef206401a92b3896de /devel
parent081185abb45414bbae7f922f37d49ee753e28931 (diff)
downloadfreebsd-ports-gnome-fd5752dde4f60b38f72bfe63017c4dceadb521aa.tar.gz
freebsd-ports-gnome-fd5752dde4f60b38f72bfe63017c4dceadb521aa.tar.zst
freebsd-ports-gnome-fd5752dde4f60b38f72bfe63017c4dceadb521aa.zip
add p5-AI-Prolog 0.734
Perl extension for logic programming PR: 101019
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-AI-Prolog/Makefile55
-rw-r--r--devel/p5-AI-Prolog/distinfo3
-rw-r--r--devel/p5-AI-Prolog/files/patch-Makefile.PL31
-rw-r--r--devel/p5-AI-Prolog/pkg-descr5
-rw-r--r--devel/p5-AI-Prolog/pkg-plist30
6 files changed, 125 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index f442ab2a3fef..c5e74a04e2e0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -726,6 +726,7 @@
SUBDIR += p4genpatch
SUBDIR += p4v
SUBDIR += p5-AI-Pathfinding-AStar
+ SUBDIR += p5-AI-Prolog
SUBDIR += p5-Acme-MetaSyntactic
SUBDIR += p5-Agent
SUBDIR += p5-Algorithm-Accounting
diff --git a/devel/p5-AI-Prolog/Makefile b/devel/p5-AI-Prolog/Makefile
new file mode 100644
index 000000000000..ddeeea095f52
--- /dev/null
+++ b/devel/p5-AI-Prolog/Makefile
@@ -0,0 +1,55 @@
+# ex:ts=8
+# Ports collection makefile for: AI::Prolog
+# Date created: Jul 29, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= AI-Prolog
+PORTVERSION= 0.734
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Perl extension for logic programming
+
+BUILD_DEPENDS= p5-aliased>=0.11:${PORTSDIR}/devel/p5-aliased \
+ p5-Clone>=0.15:${PORTSDIR}/devel/p5-Clone \
+ p5-Exporter-Tidy>=0.06:${PORTSDIR}/devel/p5-Exporter-Tidy \
+ p5-Hash-AsObject>=0.05:${PORTSDIR}/devel/p5-Hash-AsObject \
+ p5-Regexp-Common>=2.119:${PORTSDIR}/textproc/p5-Regexp-Common \
+ p5-Test-Differences>=0.47:${PORTSDIR}/devel/p5-Test-Differences \
+ p5-Test-Exception>=0.20:${PORTSDIR}/devel/p5-Test-Exception \
+ p5-Test-MockModule>=0.04:${PORTSDIR}/devel/p5-Test-MockModule \
+ p5-Test-Warn>=0.08:${PORTSDIR}/devel/p5-Test-Warn \
+ p5-Text-Balanced>=1.95:${PORTSDIR}/textproc/p5-Text-Balanced \
+ p5-Text-Quote>=0.03:${PORTSDIR}/textproc/p5-Text-Quote \
+ p5-Term-ReadKey>=2.21:${PORTSDIR}/devel/p5-Term-ReadKey
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN1= aiprolog.1
+MAN3= AI::Prolog.3 \
+ AI::Prolog::Article.3 \
+ AI::Prolog::Builtins.3 \
+ AI::Prolog::ChoicePoint.3 \
+ AI::Prolog::Cookbook.3 \
+ AI::Prolog::Engine.3 \
+ AI::Prolog::Engine::Primitives.3 \
+ AI::Prolog::Introduction.3 \
+ AI::Prolog::KnowledgeBase.3 \
+ AI::Prolog::Parser.3 \
+ AI::Prolog::Parser::PreProcessor.3 \
+ AI::Prolog::Parser::PreProcessor::Math.3 \
+ AI::Prolog::Term.3 \
+ AI::Prolog::Term::Cut.3 \
+ AI::Prolog::Term::Number.3 \
+ AI::Prolog::TermList.3 \
+ AI::Prolog::TermList::Clause.3 \
+ AI::Prolog::TermList::Primitive.3 \
+ AI::Prolog::TermList::Step.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-AI-Prolog/distinfo b/devel/p5-AI-Prolog/distinfo
new file mode 100644
index 000000000000..22701f193cae
--- /dev/null
+++ b/devel/p5-AI-Prolog/distinfo
@@ -0,0 +1,3 @@
+MD5 (AI-Prolog-0.734.tar.gz) = 7d4c7c50efbd6076f07cb9d4c39cfafc
+SHA256 (AI-Prolog-0.734.tar.gz) = eb096f48e65e84e980925a450c8f71839360b601809e712d3737315225827d23
+SIZE (AI-Prolog-0.734.tar.gz) = 67939
diff --git a/devel/p5-AI-Prolog/files/patch-Makefile.PL b/devel/p5-AI-Prolog/files/patch-Makefile.PL
new file mode 100644
index 000000000000..da7f499d80e5
--- /dev/null
+++ b/devel/p5-AI-Prolog/files/patch-Makefile.PL
@@ -0,0 +1,31 @@
+--- Makefile.PL.orig Sat Jul 29 17:27:55 2006
++++ Makefile.PL Sat Jul 29 17:28:17 2006
+@@ -2,20 +2,20 @@
+ use ExtUtils::MakeMaker qw/WriteMakefile prompt/;
+
+ my (@program, @extra_modules);
+-print <<"END_NOTE";
++#print <<"END_NOTE";
++#
++#The 'aiprolog' shell is optional. If you choose to install it, Term::ReadLine
++#and Term::ReadKey will be added to your list of prerequisites.
++#
++#END_NOTE
+
+-The 'aiprolog' shell is optional. If you choose to install it, Term::ReadLine
+-and Term::ReadKey will be added to your list of prerequisites.
+-
+-END_NOTE
+-
+-if (prompt("Do you wish to install the 'aiprolog' shell?", "y") =~ /^[Yy]/) {
++#if (prompt("Do you wish to install the 'aiprolog' shell?", "y") =~ /^[Yy]/) {
+ @program = (EXE_FILES => [ "bin/aiprolog" ]);
+ @extra_modules = (
+ 'Term::ReadLine' => 1.01,
+ 'Term::ReadKey' => 2.21,
+ );
+-}
++#}
+
+ WriteMakefile(
+ 'NAME' => 'AI::Prolog',
diff --git a/devel/p5-AI-Prolog/pkg-descr b/devel/p5-AI-Prolog/pkg-descr
new file mode 100644
index 000000000000..ab8c0d5f9ec5
--- /dev/null
+++ b/devel/p5-AI-Prolog/pkg-descr
@@ -0,0 +1,5 @@
+AI::Prolog is merely a convenient wrapper for a pure Perl Prolog compiler.
+Regrettably, at the current time, this requires you to know Prolog. That will
+change in the future.
+
+WWW: http://search.cpan.org/dist/AI-Prolog/
diff --git a/devel/p5-AI-Prolog/pkg-plist b/devel/p5-AI-Prolog/pkg-plist
new file mode 100644
index 000000000000..3baffb3d3709
--- /dev/null
+++ b/devel/p5-AI-Prolog/pkg-plist
@@ -0,0 +1,30 @@
+bin/aiprolog
+%%SITE_PERL%%/AI/Prolog/Introduction.pod
+%%SITE_PERL%%/AI/Prolog/Article.pod
+%%SITE_PERL%%/AI/Prolog/TermList.pm
+%%SITE_PERL%%/AI/Prolog/Parser.pm
+%%SITE_PERL%%/AI/Prolog/Builtins.pod
+%%SITE_PERL%%/AI/Prolog/ChoicePoint.pm
+%%SITE_PERL%%/AI/Prolog/Cookbook.pod
+%%SITE_PERL%%/AI/Prolog/Term.pm
+%%SITE_PERL%%/AI/Prolog/Engine.pm
+%%SITE_PERL%%/AI/Prolog/KnowledgeBase.pm
+%%SITE_PERL%%/AI/Prolog/Parser/PreProcessor.pm
+%%SITE_PERL%%/AI/Prolog/Parser/PreProcessor/Math.pm
+%%SITE_PERL%%/AI/Prolog/TermList/Primitive.pm
+%%SITE_PERL%%/AI/Prolog/TermList/Clause.pm
+%%SITE_PERL%%/AI/Prolog/TermList/Step.pm
+%%SITE_PERL%%/AI/Prolog/Engine/Primitives.pm
+%%SITE_PERL%%/AI/Prolog/Term/Cut.pm
+%%SITE_PERL%%/AI/Prolog/Term/Number.pm
+%%SITE_PERL%%/AI/Prolog.pm
+@dirrm %%SITE_PERL%%/AI/Prolog/TermList
+@dirrm %%SITE_PERL%%/AI/Prolog/Term
+@dirrm %%SITE_PERL%%/AI/Prolog/Parser/PreProcessor
+@dirrm %%SITE_PERL%%/AI/Prolog/Parser
+@dirrm %%SITE_PERL%%/AI/Prolog/Engine
+@dirrm %%SITE_PERL%%/AI/Prolog
+@dirrmtry %%SITE_PERL%%/AI
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/Prolog/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AI/Prolog
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/AI