aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-09-11 16:22:51 +0800
committerjbeich <jbeich@FreeBSD.org>2017-09-11 16:22:51 +0800
commit18945fcf17e8c668e530d74e18993d7095eab007 (patch)
treeaf8334a852473ba77c3373e21ab298e01bd9eaf4 /devel
parent2da5754c8a12f6d4565ada6427bc12a34901f439 (diff)
downloadfreebsd-ports-gnome-18945fcf17e8c668e530d74e18993d7095eab007.tar.gz
freebsd-ports-gnome-18945fcf17e8c668e530d74e18993d7095eab007.tar.zst
freebsd-ports-gnome-18945fcf17e8c668e530d74e18993d7095eab007.zip
devel/pecl-intl: switch to C++11, required by ICU >= 59
In file included from /wrkdirs/usr/ports/devel/pecl-intl/work/intl-3.0.0/intl_convertcpp.cpp:21: In file included from ./intl_convertcpp.h:26: /usr/local/include/unicode/unistr.h:3025:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text)) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3087:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text), length) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3180:7: error: delegating constructors are permitted only in C++11 UnicodeString(Char16Ptr(buffer), buffLength, buffCapacity) {} ^~~~~~~~~~~~~ PR: 218788
Diffstat (limited to 'devel')
-rw-r--r--devel/pecl-intl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/pecl-intl/Makefile b/devel/pecl-intl/Makefile
index 30327cc0961e..7c8f3bad0ada 100644
--- a/devel/pecl-intl/Makefile
+++ b/devel/pecl-intl/Makefile
@@ -3,7 +3,7 @@
PORTNAME= intl
PORTVERSION= 3.0.0
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= devel pear
MAINTAINER= sunpoet@FreeBSD.org
@@ -14,6 +14,7 @@ LICENSE= PHP301
LIB_DEPENDS= libicui18n.so:devel/icu
IGNORE_WITH_PHP=70 71
-USES= php:pecl
+USES= compiler:c++11-lib php:pecl
+USE_CXXSTD= gnu++11
.include <bsd.port.mk>