aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2017-09-11 16:23:37 +0800
committerjbeich <jbeich@FreeBSD.org>2017-09-11 16:23:37 +0800
commit9086803dcf5f62d26351f4ff21f65769f85db909 (patch)
tree58f8a65beb054698a2dec9d9ba980257e9dfa6d6 /devel
parent562bf1702249021b3964e6bbb9233cb2b9f98880 (diff)
downloadfreebsd-ports-gnome-9086803dcf5f62d26351f4ff21f65769f85db909.tar.gz
freebsd-ports-gnome-9086803dcf5f62d26351f4ff21f65769f85db909.tar.zst
freebsd-ports-gnome-9086803dcf5f62d26351f4ff21f65769f85db909.zip
devel/php7{0,1}-intl: switch to C++11, required by ICU >= 59
In file included from /wrkdirs/usr/ports/devel/php70-intl/work/php-7.0.19/ext/intl/intl_convertcpp.cpp:21: In file included from ./intl_convertcpp.h:26: /usr/local/include/unicode/unistr.h:3025:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text)) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3087:7: error: delegating constructors are permitted only in C++11 UnicodeString(ConstChar16Ptr(text), length) {} ^~~~~~~~~~~~~ /usr/local/include/unicode/unistr.h:3180:7: error: delegating constructors are permitted only in C++11 UnicodeString(Char16Ptr(buffer), buffLength, buffCapacity) {} ^~~~~~~~~~~~~ PR: 218788
Diffstat (limited to 'devel')
-rw-r--r--devel/php70-intl/Makefile4
-rw-r--r--devel/php71-intl/Makefile4
2 files changed, 8 insertions, 0 deletions
diff --git a/devel/php70-intl/Makefile b/devel/php70-intl/Makefile
index 7fbefd3675e5..23a1f881acaf 100644
--- a/devel/php70-intl/Makefile
+++ b/devel/php70-intl/Makefile
@@ -1,10 +1,14 @@
# Created by: Alex Dupre <ale@FreeBSD.org>
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php70
PKGNAMESUFFIX= -intl
+USES= compiler:c++11-lib
+USE_CXXSTD= gnu++11
+
.include "${MASTERDIR}/Makefile"
diff --git a/devel/php71-intl/Makefile b/devel/php71-intl/Makefile
index 3544627cd377..73447731b0b4 100644
--- a/devel/php71-intl/Makefile
+++ b/devel/php71-intl/Makefile
@@ -1,9 +1,13 @@
# $FreeBSD$
+PORTREVISION= 1
CATEGORIES= devel
MASTERDIR= ${.CURDIR}/../../lang/php71
PKGNAMESUFFIX= -intl
+USES= compiler:c++11-lib
+USE_CXXSTD= gnu++11
+
.include "${MASTERDIR}/Makefile"