aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-08 12:48:19 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-08 12:48:19 +0800
commitd84f4d0dd5f35c7d8e046d3ce5cda4ba47e3e14f (patch)
treea44f356ca00fd1ad34fcf89b5a11c0c47c670015 /devel
parentbaf7e6f3f3ad5bc04cd365270bc14b99fbfa258f (diff)
downloadfreebsd-ports-gnome-d84f4d0dd5f35c7d8e046d3ce5cda4ba47e3e14f.tar.gz
freebsd-ports-gnome-d84f4d0dd5f35c7d8e046d3ce5cda4ba47e3e14f.tar.zst
freebsd-ports-gnome-d84f4d0dd5f35c7d8e046d3ce5cda4ba47e3e14f.zip
[NEW] devel/py-frozendict: Immutable dictionary implementation for Python
frozendict is an immutable wrapper around dictionaries that implements the complete mapping interface. It can be used as a drop-in replacement for dictionaries where immutability is desired. WWW: https://github.com/slezica/python-frozendict PR: 205914 Submitted by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-frozendict/Makefile21
-rw-r--r--devel/py-frozendict/distinfo2
-rw-r--r--devel/py-frozendict/pkg-descr5
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 13c28fcf90ae..ab247fe24c4f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4040,6 +4040,7 @@
SUBDIR += py-freenas.dispatcher
SUBDIR += py-freenas.utils
SUBDIR += py-freezegun
+ SUBDIR += py-frozendict
SUBDIR += py-fs
SUBDIR += py-fsm
SUBDIR += py-fudge
diff --git a/devel/py-frozendict/Makefile b/devel/py-frozendict/Makefile
new file mode 100644
index 000000000000..d3add31a43f5
--- /dev/null
+++ b/devel/py-frozendict/Makefile
@@ -0,0 +1,21 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= frozendict
+PORTVERSION= 0.5
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Immutable dictionary implementation for Python
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-frozendict/distinfo b/devel/py-frozendict/distinfo
new file mode 100644
index 000000000000..f5e412531dc5
--- /dev/null
+++ b/devel/py-frozendict/distinfo
@@ -0,0 +1,2 @@
+SHA256 (frozendict-0.5.tar.gz) = 560c424af4913dad5aa1f6933e78837e597c7000dda2e3624a6e37b5a0799354
+SIZE (frozendict-0.5.tar.gz) = 2167
diff --git a/devel/py-frozendict/pkg-descr b/devel/py-frozendict/pkg-descr
new file mode 100644
index 000000000000..dce02db6ebce
--- /dev/null
+++ b/devel/py-frozendict/pkg-descr
@@ -0,0 +1,5 @@
+frozendict is an immutable wrapper around dictionaries that implements the
+complete mapping interface. It can be used as a drop-in replacement for
+dictionaries where immutability is desired.
+
+WWW: https://github.com/slezica/python-frozendict