aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskreuzer <skreuzer@FreeBSD.org>2017-03-21 22:27:07 +0800
committerskreuzer <skreuzer@FreeBSD.org>2017-03-21 22:27:07 +0800
commit0e0d2ea795e7d12501e22a872dbb0b68ac4622b7 (patch)
tree1178618b539da94c2594d7d54ce2b1bf06bfa4d3 /devel
parentde7dd2e1098a9df63dbca6b4191bd47c50886526 (diff)
downloadfreebsd-ports-gnome-0e0d2ea795e7d12501e22a872dbb0b68ac4622b7.tar.gz
freebsd-ports-gnome-0e0d2ea795e7d12501e22a872dbb0b68ac4622b7.tar.zst
freebsd-ports-gnome-0e0d2ea795e7d12501e22a872dbb0b68ac4622b7.zip
Add a python 3 variant of tabulate
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-tabulate/Makefile2
-rw-r--r--devel/py3-tabulate/Makefile7
3 files changed, 9 insertions, 1 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 88bcdf46bd94..1058b05c7a30 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4934,6 +4934,7 @@
SUBDIR += py3-setproctitle
SUBDIR += py3-simplejson
SUBDIR += py3-six
+ SUBDIR += py3-tabulate
SUBDIR += py3-threema-msgapi
SUBDIR += py3-vcversioner
SUBDIR += py3-wcwidth
diff --git a/devel/py-tabulate/Makefile b/devel/py-tabulate/Makefile
index 61ea91963ea8..4872b12eb511 100644
--- a/devel/py-tabulate/Makefile
+++ b/devel/py-tabulate/Makefile
@@ -13,7 +13,7 @@ COMMENT= Pretty-print tabular data in Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-USES= python
+USES?= python
USE_PYTHON= autoplist distutils
NO_ARCH= yes
diff --git a/devel/py3-tabulate/Makefile b/devel/py3-tabulate/Makefile
new file mode 100644
index 000000000000..11351b190099
--- /dev/null
+++ b/devel/py3-tabulate/Makefile
@@ -0,0 +1,7 @@
+# $FreeBSD$
+
+MASTERDIR= ${.CURDIR}/../py-tabulate
+
+USES= python:3.1+
+
+.include "${MASTERDIR}/Makefile"