aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-05-28 20:03:47 +0800
committerskv <skv@FreeBSD.org>2007-05-28 20:03:47 +0800
commit12bf3efca407cd563e4273a4a5e91c5b515efcb2 (patch)
treef30dc3786f4d15eac577755c1125c285c16eed14 /devel
parent705c82c185782b728da81db2549b0e72c8d5a52d (diff)
downloadfreebsd-ports-gnome-12bf3efca407cd563e4273a4a5e91c5b515efcb2.tar.gz
freebsd-ports-gnome-12bf3efca407cd563e4273a4a5e91c5b515efcb2.tar.zst
freebsd-ports-gnome-12bf3efca407cd563e4273a4a5e91c5b515efcb2.zip
* fix dependencies
* fix perl path [1] PR: ports/112257 [1] Submitted by: Christopher McCrory<chrismcc+freebsd xx pricegrabber.com> [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/bugzilla/Makefile11
-rw-r--r--devel/bugzilla3/Makefile11
2 files changed, 12 insertions, 10 deletions
diff --git a/devel/bugzilla/Makefile b/devel/bugzilla/Makefile
index 3d98a30d7515..67be6c1b1594 100644
--- a/devel/bugzilla/Makefile
+++ b/devel/bugzilla/Makefile
@@ -77,7 +77,7 @@ USE_PGSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
- ${SITE_PERL}/Template/Plugin/GD/Image:${PORTSDIR}/www/p5-Template-GD
+ ${SITE_PERL}/Template/Plugin/GD/Image.pm:${PORTSDIR}/www/p5-Template-GD
.endif
.ifdef WITH_CHARTING_MODULES
@@ -85,7 +85,8 @@ RUN_DEPENDS+= ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
.endif
.ifdef WITH_PATCH_VIEWER
-RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader
+RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader \
+ interdiff:${PORTSDIR}/misc/patchutils
.endif
.ifdef WITH_MORE_HTML
@@ -95,7 +96,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-P
.ifdef WITH_INBOUND_EMAIL
RUN_DEPENDS+= ${SITE_PERL}/Email/MIME/Attachment/Stripper.pm:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
- ${SITE_PERL}/Email/Reply:${PORTSDIR}/mail/p5-Email-Reply
+ ${SITE_PERL}/Email/Reply.pm:${PORTSDIR}/mail/p5-Email-Reply
.endif
.ifdef WITH_MOVE_BUGZ
@@ -140,8 +141,8 @@ post-patch:
${WRKSRC}/checksetup.pl
@${FIND} ${WRKSRC} \( -name "CVS" -or -name ".cvsignore" -or -name "*.orig" \
-or -name "README.docs" \) | ${XARGS} ${RM} -rf
- @${FIND} ${WRKSRC} -name "*.p[ml]" | \
- ${XARGS} ${REINPLACE_CMD} -i '' -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!'
+ ${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -i '' \
+ -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!g; s=/usr/bin/perl=${PERL}=g' {} \+
do-build:
@${SED} -e "s:%%BUGZILLADIR%%:${BUGZILLADIR}:g; s:%%DOCSDIR%%:${DOCSDIR}:g" \
diff --git a/devel/bugzilla3/Makefile b/devel/bugzilla3/Makefile
index 3d98a30d7515..67be6c1b1594 100644
--- a/devel/bugzilla3/Makefile
+++ b/devel/bugzilla3/Makefile
@@ -77,7 +77,7 @@ USE_PGSQL= yes
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \
${SITE_PERL}/GD/Text.pm:${PORTSDIR}/graphics/p5-GD-TextUtil \
- ${SITE_PERL}/Template/Plugin/GD/Image:${PORTSDIR}/www/p5-Template-GD
+ ${SITE_PERL}/Template/Plugin/GD/Image.pm:${PORTSDIR}/www/p5-Template-GD
.endif
.ifdef WITH_CHARTING_MODULES
@@ -85,7 +85,8 @@ RUN_DEPENDS+= ${SITE_PERL}/Chart/Base.pm:${PORTSDIR}/graphics/p5-chart
.endif
.ifdef WITH_PATCH_VIEWER
-RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader
+RUN_DEPENDS+= ${SITE_PERL}/PatchReader.pm:${PORTSDIR}/devel/p5-PatchReader \
+ interdiff:${PORTSDIR}/misc/patchutils
.endif
.ifdef WITH_MORE_HTML
@@ -95,7 +96,7 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/HTML/Parser.pm:${PORTSDIR}/www/p5-HTML-P
.ifdef WITH_INBOUND_EMAIL
RUN_DEPENDS+= ${SITE_PERL}/Email/MIME/Attachment/Stripper.pm:${PORTSDIR}/mail/p5-Email-MIME-Attachment-Stripper \
- ${SITE_PERL}/Email/Reply:${PORTSDIR}/mail/p5-Email-Reply
+ ${SITE_PERL}/Email/Reply.pm:${PORTSDIR}/mail/p5-Email-Reply
.endif
.ifdef WITH_MOVE_BUGZ
@@ -140,8 +141,8 @@ post-patch:
${WRKSRC}/checksetup.pl
@${FIND} ${WRKSRC} \( -name "CVS" -or -name ".cvsignore" -or -name "*.orig" \
-or -name "README.docs" \) | ${XARGS} ${RM} -rf
- @${FIND} ${WRKSRC} -name "*.p[ml]" | \
- ${XARGS} ${REINPLACE_CMD} -i '' -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!'
+ ${FIND} ${WRKSRC} -type f -exec ${REINPLACE_CMD} -i '' \
+ -e 's!/usr/lib/sendmail!/usr/sbin/sendmail!g; s=/usr/bin/perl=${PERL}=g' {} \+
do-build:
@${SED} -e "s:%%BUGZILLADIR%%:${BUGZILLADIR}:g; s:%%DOCSDIR%%:${DOCSDIR}:g" \