aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvd <vd@FreeBSD.org>2016-09-30 16:46:29 +0800
committervd <vd@FreeBSD.org>2016-09-30 16:46:29 +0800
commit14d1a37eecf827893a3f3f231e6944a955cdf55d (patch)
treedf7743ecd089c1215bef97149864f341cc809a32 /devel
parentbf60f7cae66ddc2c39fbe6607ab3dc0319c8513a (diff)
downloadfreebsd-ports-gnome-14d1a37eecf827893a3f3f231e6944a955cdf55d.tar.gz
freebsd-ports-gnome-14d1a37eecf827893a3f3f231e6944a955cdf55d.tar.zst
freebsd-ports-gnome-14d1a37eecf827893a3f3f231e6944a955cdf55d.zip
devel/google-sparsehash: Upgrade to 2.0.3 and rename to devel/sparsehash
* The project was moved from Google Code to GitHub (unbreak), hinted by [1] * Upgrade from 2.0.2 to 2.0.3 * Remove now unneeded patches * Remove the requirement for C++11 - the code does not need it * Use PREFIX instead of LOCALBASE as a destination directory PR: 213093 [1] Submitted by: Erik Nordstrom <erik@nordstroem.no> [1]
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile2
-rw-r--r--devel/google-sparsehash/distinfo2
-rw-r--r--devel/google-sparsehash/files/patch-src__hashtable_test.cc11
-rw-r--r--devel/google-sparsehash/files/patch-src__sparsehash__internal__sparsehashtable.h29
-rw-r--r--devel/sparsehash/Makefile (renamed from devel/google-sparsehash/Makefile)18
-rw-r--r--devel/sparsehash/distinfo3
-rw-r--r--devel/sparsehash/pkg-descr (renamed from devel/google-sparsehash/pkg-descr)0
-rw-r--r--devel/sparsehash/pkg-plist (renamed from devel/google-sparsehash/pkg-plist)0
8 files changed, 12 insertions, 53 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a3480a9ecfa5..8c9c4c91a73a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -767,7 +767,6 @@
SUBDIR += goffice010
SUBDIR += google-gdata
SUBDIR += google-perftools
- SUBDIR += google-sparsehash
SUBDIR += google-styleguide
SUBDIR += googlemock
SUBDIR += googletest
@@ -5376,6 +5375,7 @@
SUBDIR += sparc64-gcc
SUBDIR += sparc64-xtoolchain-gcc
SUBDIR += spark
+ SUBDIR += sparsehash
SUBDIR += spatialindex
SUBDIR += spdict
SUBDIR += spice-protocol
diff --git a/devel/google-sparsehash/distinfo b/devel/google-sparsehash/distinfo
deleted file mode 100644
index 3e525d1d02bf..000000000000
--- a/devel/google-sparsehash/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-SHA256 (sparsehash-2.0.2.tar.gz) = 2ed639a7155607c097c2029af5f4287296595080b2e5dd2e2ebd9bbb7450b87c
-SIZE (sparsehash-2.0.2.tar.gz) = 340514
diff --git a/devel/google-sparsehash/files/patch-src__hashtable_test.cc b/devel/google-sparsehash/files/patch-src__hashtable_test.cc
deleted file mode 100644
index 0fd5ffd04cb7..000000000000
--- a/devel/google-sparsehash/files/patch-src__hashtable_test.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/hashtable_test.cc.orig 2012-02-22 21:49:42.000000000 +0100
-+++ src/hashtable_test.cc 2015-02-28 13:31:07.532995000 +0100
-@@ -898,7 +898,7 @@
- // Now swap back, using the free-function swap
- // NOTE: MSVC seems to have trouble with this free swap, not quite
- // sure why. I've given up trying to fix it though.
--#ifdef _MSC_VER
-+#if defined(_MSC_VER) || (defined(__clang__) && __clang_major__ >= 3 && __clang_minor__ >= 6)
- other_ht.swap(this->ht_);
- #else
- swap(this->ht_, other_ht);
diff --git a/devel/google-sparsehash/files/patch-src__sparsehash__internal__sparsehashtable.h b/devel/google-sparsehash/files/patch-src__sparsehash__internal__sparsehashtable.h
deleted file mode 100644
index 67b264fd0a22..000000000000
--- a/devel/google-sparsehash/files/patch-src__sparsehash__internal__sparsehashtable.h
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./src/sparsehash/internal/sparsehashtable.h.orig 2014-09-13 09:25:42.349531861 -0700
-+++ ./src/sparsehash/internal/sparsehashtable.h 2014-09-13 09:27:25.632525344 -0700
-@@ -165,7 +165,7 @@
- public:
- typedef sparse_hashtable_iterator<V,K,HF,ExK,SetK,EqK,A> iterator;
- typedef sparse_hashtable_const_iterator<V,K,HF,ExK,SetK,EqK,A> const_iterator;
-- typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,A>::nonempty_iterator
-+ typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,value_alloc_type>::nonempty_iterator
- st_iterator;
-
- typedef std::forward_iterator_tag iterator_category; // very little defined!
-@@ -217,7 +217,7 @@
- public:
- typedef sparse_hashtable_iterator<V,K,HF,ExK,SetK,EqK,A> iterator;
- typedef sparse_hashtable_const_iterator<V,K,HF,ExK,SetK,EqK,A> const_iterator;
-- typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,A>::const_nonempty_iterator
-+ typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,value_alloc_type>::const_nonempty_iterator
- st_iterator;
-
- typedef std::forward_iterator_tag iterator_category; // very little defined!
-@@ -271,7 +271,7 @@
-
- public:
- typedef sparse_hashtable_destructive_iterator<V,K,HF,ExK,SetK,EqK,A> iterator;
-- typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,A>::destructive_iterator
-+ typedef typename sparsetable<V,DEFAULT_GROUP_SIZE,value_alloc_type>::destructive_iterator
- st_iterator;
-
- typedef std::forward_iterator_tag iterator_category; // very little defined!
diff --git a/devel/google-sparsehash/Makefile b/devel/sparsehash/Makefile
index bb34b3a22529..404e8246417d 100644
--- a/devel/google-sparsehash/Makefile
+++ b/devel/sparsehash/Makefile
@@ -1,28 +1,26 @@
# Created by: Vasil Dimov <vd@datamax.bg>
# $FreeBSD$
-PORTNAME= google-sparsehash
-PORTVERSION= 2.0.2
-PORTREVISION= 2
+PORTNAME= sparsehash
+PORTVERSION= 2.0.3
CATEGORIES= devel
-MASTER_SITES= GOOGLE_CODE \
- LOCAL/vd/${PORTNAME}
-PROJECTHOST= sparsehash
-DISTNAME= sparsehash-${PORTVERSION}
+DISTNAME= ${PORTNAME}-${PORTNAME}-${PORTVERSION}
MAINTAINER= vd@FreeBSD.org
COMMENT= Extremely memory-efficient hash_map implementation
-BROKEN= Unfetchable (google code has gone away)
+LICENSE= BSD3CLAUSE
+
+USE_GITHUB= yes
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
-USES= compiler:c++11-lang
OPTIONS_DEFINE= DOCS
post-patch:
${REINPLACE_CMD} -e \
- 's|^pkgconfigdir = .*|pkgconfigdir = ${LOCALBASE}/libdata/pkgconfig|' \
+ 's|^pkgconfigdir = .*|pkgconfigdir = ${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
post-patch-DOCS-on:
diff --git a/devel/sparsehash/distinfo b/devel/sparsehash/distinfo
new file mode 100644
index 000000000000..b6ac6fa4c3ca
--- /dev/null
+++ b/devel/sparsehash/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1475222400
+SHA256 (sparsehash-sparsehash-2.0.3_GH0.tar.gz) = 05e986a5c7327796dad742182b2d10805a8d4f511ad090da0490f146c1ff7a8c
+SIZE (sparsehash-sparsehash-2.0.3_GH0.tar.gz) = 322046
diff --git a/devel/google-sparsehash/pkg-descr b/devel/sparsehash/pkg-descr
index e63d843c9ecc..e63d843c9ecc 100644
--- a/devel/google-sparsehash/pkg-descr
+++ b/devel/sparsehash/pkg-descr
diff --git a/devel/google-sparsehash/pkg-plist b/devel/sparsehash/pkg-plist
index 7155a4788a72..7155a4788a72 100644
--- a/devel/google-sparsehash/pkg-plist
+++ b/devel/sparsehash/pkg-plist