aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2013-02-15 09:55:09 +0800
committermiwi <miwi@FreeBSD.org>2013-02-15 09:55:09 +0800
commit15f84380e007828f9691cb27b609820a6af901ca (patch)
tree8e7c3a23cb411ba563bfe8ae93954a3b4406b74d /devel
parentdeb06d82b464f7e78670b2eff771b4bd8daa6003 (diff)
downloadfreebsd-ports-gnome-15f84380e007828f9691cb27b609820a6af901ca.tar.gz
freebsd-ports-gnome-15f84380e007828f9691cb27b609820a6af901ca.tar.zst
freebsd-ports-gnome-15f84380e007828f9691cb27b609820a6af901ca.zip
- Update to 0.52.14
PR: 175031 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/newt/Makefile120
-rw-r--r--devel/newt/distinfo4
-rw-r--r--devel/newt/files/patch-ab77
-rw-r--r--devel/newt/files/patch-form.c (renamed from devel/newt/files/patch-ac)0
-rw-r--r--devel/newt/files/patch-whiptail8
-rw-r--r--devel/newt/files/patch-whiptcl74
-rw-r--r--devel/newt/pkg-plist270
7 files changed, 176 insertions, 377 deletions
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 5600bb32df41..c63e334c000a 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -1,11 +1,9 @@
# $FreeBSD$
PORTNAME= newt
-PORTVERSION= 0.52.11
-PORTREVISION= 3
+PORTVERSION= 0.52.14
CATEGORIES= devel
MASTER_SITES= https://fedorahosted.org/releases/n/e/newt/
-PKGNAMESUFFIX= ${PYTHONSUFFIX}${TCLSUFFIX}
MAINTAINER= ports@FreeBSD.org
COMMENT= Not Erik's Windowing Toolkit: console I/O handling library
@@ -13,84 +11,94 @@ COMMENT= Not Erik's Windowing Toolkit: console I/O handling library
LIB_DEPENDS= slang:${PORTSDIR}/devel/libslang2 \
popt:${PORTSDIR}/devel/popt
+OPTIONS_DEFINE= PYTHON TCL NLS
+
+USE_GMAKE= yes
GNU_CONFIGURE= yes
+MAKE_ENV= PCFLAGS="${CFLAGS}" TCLVERSION="tcl${TCL_VER}"
USE_LDCONFIG= yes
+MAKE_JOBS_UNSAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lcurses
+
+PLIST_SUB= SOVERSION="${SOVERSION}" \
+ VERSION="${PORTVERSION}"
+
+SUB_LIST= VERSION="${PORTVERSION}"
+
+MAN1= whiptail.1
+
SOVERSION= ${PORTVERSION:R:E}
-TCL_NODOT= tcl${TCL_VER:S/.//}
-CFLAGS+= -Werror
-MAKE_ENV+= PCFLAGS="${CFLAGS}" TCLVERSION="tcl${TCL_VER}"
-PLIST_SUB+= SOVERSION=${SOVERSION} \
- VERSION=${PORTVERSION} \
- EXAMPLESDIR="${EXAMPLESDIR:S,${PREFIX}/,,}"
-SUB_LIST= VERSION=${PORTVERSION}
-USE_GMAKE= yes
-MAKE_JOBS_UNSAFE= yes
+.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+=--disable-nls
-.else
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-.if defined(WITH_PYTHON)
-PYTHONSUFFIX= -${PYTHON_PKGNAMEPREFIX:S/-//}
+
+.if ${PORT_OPTIONS:MPYTHON}
USE_PYTHON= -2.7
-MAKE_ENV+= WITH_PYTHON=yes
-PLIST_SUB+= PYTHONOPT="" \
- PYNUM=${PYTHON_VERSION:S/python//}
+INSTALLS_EGGINFO= yes
+PLIST_SUB+= PYTHONOPT=""
SUB_FILES+= setup.py
.else
PLIST_SUB+= PYTHONOPT="@comment "
.endif
-.if defined(WITH_TCL)
+.if ${PORT_OPTIONS:MTCL}
USE_TCL= 84+
-TCLSUFFIX= -${TCL_NODOT}
-MAKE_ENV+= WITH_TCL=yes TCL_LIBDIR=${TCL_LIBDIR:Q}
-PLIST_SUB+= TCLOPT="" TCL_VER=${TCL_VER}
+MAKE_ENV+= TCL_LIBDIR=${TCL_LIBDIR:Q}
CPPFLAGS+= -I${TCL_INCLUDEDIR:Q}
SUB_FILES+= pkgIndex.tcl
-
-pre-su-install:
- ${MKDIR} ${TCL_LIBDIR}/whip
-
+PLIST_SUB+= TCLOPT="" TCL_LIBDIR=${TCL_LIBDIR:S,${PREFIX}/,,}
.else
-PLIST_SUB+= TCLOPT="@comment "
CONFIGURE_ARGS+=--without-tcl
+PLIST_SUB+= TCLOPT="@comment "
.endif
-MAN1= whiptail.1
-
-.include <bsd.port.pre.mk>
-
post-patch:
- ${REINPLACE_CMD} -e 's,^\(SONAME=\).*,\1${SOVERSION},g' \
- ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|/usr/include/slang|${LOCALBASE:Q}/include|' \
- -e 's|-lslang|-lcurses -L${LOCALBASE:Q}/lib -lslang|' \
- -e 's|-ltcl8.4||' \
- -e 's|^pkgconfigdir.*|pkgconfigdir=${LOCALBASE:Q}/libdata/pkgconfig|' \
- -e 's,PYTHONVERS =.*,PYTHONVERS=${PYTHON_VER},' \
- ${WRKSRC}/Makefile.in
- ${REINPLACE_CMD} -e 's,PyMem_DEL,PyObject_DEL,g' \
- ${WRKSRC}/snackmodule.c
-
-.if defined(WITH_PYTHON)
-pre-install:
- @${LN} -sf ${WRKSRC}/libnewt.so.${SOVERSION} ${WRKSRC}/libnewt.so
- @cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${WRKDIR}/setup.py build
+ @${REINPLACE_CMD} -e \
+ '/^SONAME/s|=.*|=${SOVERSION}|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e \
+ 's|@CPP@|@CC@ -E| ; \
+ s|-I/usr/include/slang|| ; \
+ /^PYTHONVERS/s|=.*|=${PYTHON_VERSION}| ; \
+ /^pkgconfigdir/s|=.*|=${PREFIX}/libdata/pkgconfig| ; \
+ s| -g | |g ; \
+ /make -C/s|^|#| ; \
+ /whiptcl.so/s|install|${TRUE}|' ${WRKSRC}/Makefile.in
+
+post-build: apply-slist
+.if ${PORT_OPTIONS:MPYTHON}
+ @${LN} -sf libnewt.so.${SOVERSION} ${WRKSRC}/libnewt.so
+ @(cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${WRKDIR}/setup.py \
+ build)
.endif
post-install:
-.if defined(WITH_TCL)
- ${INSTALL_DATA} ${WRKDIR}/pkgIndex.tcl ${TCL_LIBDIR}/whip/
+ @${STRIP_CMD} ${PREFIX}/bin/whiptail
+.if ${PORT_OPTIONS:MNLS}
+ @(cd ${WRKSRC}/po && ${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} \
+ ${MAKEFILE} ${MAKE_ARGS} datadir=${PREFIX}/share \
+ ${INSTALL_TARGET})
+.endif
+.if ${PORT_OPTIONS:MPYTHON}
+ @(cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${WRKDIR}/setup.py \
+ install --prefix=${PREFIX})
.endif
-.if defined(WITH_PYTHON)
- @cd ${WRKSRC} && ${MAKE_ENV} ${PYTHON_CMD} ${WRKDIR}/setup.py install --prefix=${PREFIX}
-.if !defined(NOPORTEXAMPLES)
- ${MKDIR} ${EXAMPLESDIR}/
- ${INSTALL_SCRIPT} ${WRKSRC}/peanuts.py ${WRKSRC}/popcorn.py ${EXAMPLESDIR}/
+.if ${PORT_OPTIONS:MTCL}
+ @${MKDIR} ${TCL_LIBDIR}/whip
+ (cd ${WRKSRC} && ${INSTALL_DATA} whiptcl.so ${TCL_LIBDIR}/whip)
+ (cd ${WRKDIR} && ${INSTALL_DATA} pkgIndex.tcl ${TCL_LIBDIR}/whip)
.endif
+.if ${PORT_OPTIONS:MEXAMPLES}
+ @${MKDIR} ${EXAMPLESDIR}
+ (cd ${WRKSRC} && ${INSTALL_SCRIPT} peanuts.py popcorn.py ${EXAMPLESDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/newt/distinfo b/devel/newt/distinfo
index 831696c1d3ea..bf8d36ac948b 100644
--- a/devel/newt/distinfo
+++ b/devel/newt/distinfo
@@ -1,2 +1,2 @@
-SHA256 (newt-0.52.11.tar.gz) = 8bac17b4272475f5e172b9894b8c062a6e5ab0689a736d9dbbcc1695604fb8d7
-SIZE (newt-0.52.11.tar.gz) = 175596
+SHA256 (newt-0.52.14.tar.gz) = f70f4f58baa60388ddf2e39249ffb00898fb40f2b2767e42e2ab51fe4b40978e
+SIZE (newt-0.52.14.tar.gz) = 183621
diff --git a/devel/newt/files/patch-ab b/devel/newt/files/patch-ab
deleted file mode 100644
index d73d4a146e1d..000000000000
--- a/devel/newt/files/patch-ab
+++ /dev/null
@@ -1,77 +0,0 @@
---- Makefile.in.orig 2009-09-24 17:03:09.000000000 +0200
-+++ Makefile.in 2010-11-03 15:56:33.000000000 +0100
-@@ -2,7 +2,7 @@ LIBS = -lslang
- LIBTCL = -ltcl8.4
-
- CC = @CC@
--CPP = @CPP@
-+CPP = $(CC) -E
- CFLAGS = @CFLAGS@
- CPPFLAGS = -D_GNU_SOURCE -I/usr/include/slang @CPPFLAGS@
-
-@@ -50,7 +50,7 @@ else
- TARGET=depend $(PROGS)
- endif
-
--all: $(TARGET) _snackmodule.so
-+all: $(TARGET)
-
- test: test.o $(LIBNEWT)
- $(CC) -g -o test test.o $(LIBNEWT) $(LIBS)
-@@ -67,19 +67,19 @@ showchars: showchars.o $(LIBNEWT)
- showkey: showkey.o $(LIBNEWT)
- $(CC) -g -o showkey showkey.o $(LIBNEWT) $(LIBS)
-
-+ifdef PYTHONVERS
-+install-sh: _snackmodule.so
-+all: _snackmodule.so
- _snackmodule.so: snackmodule.c $(LIBNEWTSH)
-- for ver in $(PYTHONVERS) ; do \
-- mkdir -p $$ver ;\
-- $(CC) $(CFLAGS) -I/usr/include/$$ver $(SHCFLAGS) -c -o $$ver/snackmodule.o snackmodule.c ;\
-- $(CC) --shared $(SHCFLAGS) -o $$ver/_snackmodule.so $$ver/snackmodule.o -L . -lnewt ;\
-- done
-- touch $@
-+ $(CC) $(CFLAGS) $(CPPFLAGS) -I${LOCALBASE}/include/python${PYTHONVERS} $(SHCFLAGS) -c -o snackmodule.o snackmodule.c
-+ $(CC) --shared $(SHCFLAGS) -o _snackmodule.so snackmodule.o -L . -lnewt
-+endif
-
- whiptail: $(NDIALOGOBJS) $(LIBNEWTSH)
- $(CC) -g -o whiptail $(NDIALOGOBJS) -L . -lnewt $(LIBS) -lpopt
-
- whiptcl.so: $(WHIPTCLOBJS) $(LIBNEWTSH)
-- $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) -lpopt
-+ $(CC) -shared $(SHCFLAGS) -o whiptcl.so $(WHIPTCLOBJS) -L . -lnewt $(LIBTCL) $(LIBS) -lpopt
-
- $(LIBNEWT): $(LIBOBJS)
- ar rv $@ $^
-@@ -118,20 +118,20 @@ install: $(LIBNEWT) install-sh whiptail
- install -m 644 $(LIBNEWT) $(instroot)/$(libdir)
- install -m 755 whiptail $(instroot)/$(bindir)
- install -m 644 whiptail.1 $(instroot)/$(man1dir)
-- make -C po datadir=$(instroot)/$(datadir) install
-- install -m 644 -D libnewt.pc $(instroot)/$(pkgconfigdir)/libnewt.pc
-+ ${MAKE} -C po datadir=$(instroot)/$(datadir) install
-+ install -m 644 libnewt.pc $(instroot)/$(pkgconfigdir)/libnewt.pc
-
--install-sh: sharedlib $(WHIPTCLSO) _snackmodule.so
-+install-sh: sharedlib $(WHIPTCLSO)
- [ -d $(instroot)/$(libdir) ] || install -m 755 -d $(instroot)/$(libdir)
- install -m 755 $(LIBNEWTSH) $(instroot)/$(libdir)
- ln -sf $(LIBNEWTSONAME) $(instroot)/$(libdir)/libnewt.so
- ln -sf $(LIBNEWTSH) $(instroot)/$(libdir)/$(LIBNEWTSONAME)
-- [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so $(instroot)/$(libdir) || :
-- for ver in $(PYTHONVERS) ; do \
-- [ -d $(instroot)/$(libdir)/$$ver/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/$$ver/site-packages ;\
-- install -m 755 $$ver/_snackmodule.so $(instroot)/$(libdir)/$$ver/site-packages ;\
-- install -m 644 snack.py $(instroot)/$(libdir)/$$ver/site-packages ;\
-- done
-+ [ -n "$(WHIPTCLSO)" ] && install -m 755 whiptcl.so ${TCL_LIBDIR}/whip || :
-+ifdef PYTHONVERS
-+ [ -d $(instroot)/$(libdir)/python${PYTHONVERS}/site-packages ] || install -m 755 -d $(instroot)/$(libdir)/python${PYTHONVERS}/site-packages
-+ install -m 755 _snackmodule.so $(instroot)/$(libdir)/python${PYTHONVERS}/site-packages
-+ install -m 644 snack.py $(instroot)/$(libdir)/python${PYTHONVERS}/site-packages
-+endif
-
- Makefile: newt.spec
- echo "You need to rerun ./configure before continuing"
diff --git a/devel/newt/files/patch-ac b/devel/newt/files/patch-form.c
index ac5d6d61b21e..ac5d6d61b21e 100644
--- a/devel/newt/files/patch-ac
+++ b/devel/newt/files/patch-form.c
diff --git a/devel/newt/files/patch-whiptail b/devel/newt/files/patch-whiptail
deleted file mode 100644
index c6fd1f8bfec1..000000000000
--- a/devel/newt/files/patch-whiptail
+++ /dev/null
@@ -1,8 +0,0 @@
---- whiptail.c 2009-09-24 11:03:09.000000000 -0400
-+++ whiptail.c 2010-01-06 01:17:31.000000000 -0500
-@@ -9,4 +9,5 @@
- #include <wchar.h>
- #include <slang.h>
-+#include <sys/stat.h>
-
- #include "nls.h"
diff --git a/devel/newt/files/patch-whiptcl b/devel/newt/files/patch-whiptcl
deleted file mode 100644
index e0b52e2afec0..000000000000
--- a/devel/newt/files/patch-whiptcl
+++ /dev/null
@@ -1,74 +0,0 @@
---- whiptcl.c 2009-09-24 11:03:09.000000000 -0400
-+++ whiptcl.c 2010-01-06 02:44:52.000000000 -0500
-@@ -6,6 +6,6 @@
- #include "dialogboxes.h"
- #include "newt.h"
--#include "popt.h"
--#include "tcl.h"
-+#include <popt.h>
-+#include <tcl.h>
-
- enum mode { MODE_NONE, MODE_MSGBOX, MODE_YESNO, MODE_CHECKLIST, MODE_INPUTBOX,
-@@ -20,12 +20,12 @@
-
- static char * setBacktext(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags);
-+ const char * name1, const char * name2, int flags);
- static char * setHelptext(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags);
-+ const char * name1, const char * name2, int flags);
- static char * setFullButtons(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags);
-+ const char * name1, const char * name2, int flags);
-
- static int wtFinish(ClientData clientData, Tcl_Interp * interp, int argc,
-- char ** argv) {
-+ const char ** argv) {
- newtFinished();
-
-@@ -34,5 +34,5 @@
-
- static int wtInit(ClientData clientData, Tcl_Interp * interp, int argc,
-- char ** argv) {
-+ const char ** argv) {
- newtInit();
- newtCls();
-@@ -239,5 +239,5 @@
-
- case MODE_NONE:
-- /* this can't happen */
-+ ; /* this can't happen */
- break;
- }
-@@ -259,5 +259,5 @@
-
- static char * setBacktext(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags) {
-+ const char * name1, const char * name2, int flags) {
- static char blankLine[81] = " "
- " ";
-@@ -271,6 +271,6 @@
-
- static char * setHelptext(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags) {
-- char * text = Tcl_GetVar(interp, "whiptcl_helpline", TCL_GLOBAL_ONLY);
-+ const char * name1, const char * name2, int flags) {
-+ const char * text = Tcl_GetVar(interp, "whiptcl_helpline", TCL_GLOBAL_ONLY);
-
- if (!text)
-@@ -286,6 +286,6 @@
-
- static char * setFullButtons(ClientData data, Tcl_Interp * interp,
-- char * name1, char * name2, int flags) {
-- char * val = Tcl_GetVar(interp, "whiptcl_fullbuttons", TCL_GLOBAL_ONLY);
-+ const char * name1, const char * name2, int flags) {
-+ const char * val = Tcl_GetVar(interp, "whiptcl_fullbuttons", TCL_GLOBAL_ONLY);
- int rc;
- int state;
-@@ -306,4 +306,6 @@
- Tcl_CreateCommand(interp, "whiptcl_cmd", (Tcl_CmdProc *) wtCmd, NULL, NULL);
-
-+ Tcl_PkgProvide(interp, "Whip", VERSION);
-+
- return TCL_OK;
- }
diff --git a/devel/newt/pkg-plist b/devel/newt/pkg-plist
index 9fd82768681b..a95c02d11ed7 100644
--- a/devel/newt/pkg-plist
+++ b/devel/newt/pkg-plist
@@ -1,167 +1,117 @@
-%%PORTEXAMPLES%%%%PYTHONOPT%%%%EXAMPLESDIR%%/peanuts.py
-%%PORTEXAMPLES%%%%PYTHONOPT%%%%EXAMPLESDIR%%/popcorn.py
-%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/_snack.so
-%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/_snackmodule.so
-%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/newt-%%VERSION%%-py%%PYNUM%%.egg-info
-%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/snack.py
-%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/snack.pyc
-%%TCLOPT%%lib/tcl%%TCL_VER%%/whip/pkgIndex.tcl
-%%TCLOPT%%lib/tcl%%TCL_VER%%/whip/whiptcl.so
bin/whiptail
include/newt.h
lib/libnewt.a
lib/libnewt.so
lib/libnewt.so.%%SOVERSION%%
lib/libnewt.so.%%VERSION%%
+%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/_snack.so
+%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/_snackmodule.so
+%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/snack.py
+%%PYTHONOPT%%%%PYTHON_SITELIBDIR%%/snack.pyc
+%%TCLOPT%%%%TCL_LIBDIR%%/whip/pkgIndex.tcl
+%%TCLOPT%%%%TCL_LIBDIR%%/whip/whiptcl.so
libdata/pkgconfig/libnewt.pc
-share/locale/ar/LC_MESSAGES/newt.mo
-share/locale/as/LC_MESSAGES/newt.mo
-share/locale/ast/LC_MESSAGES/newt.mo
-share/locale/bal/LC_MESSAGES/newt.mo
-share/locale/bg/LC_MESSAGES/newt.mo
-share/locale/bn/LC_MESSAGES/newt.mo
-share/locale/bn_IN/LC_MESSAGES/newt.mo
-share/locale/bs/LC_MESSAGES/newt.mo
-share/locale/ca/LC_MESSAGES/newt.mo
-share/locale/cs/LC_MESSAGES/newt.mo
-share/locale/cy/LC_MESSAGES/newt.mo
-share/locale/da/LC_MESSAGES/newt.mo
-share/locale/de/LC_MESSAGES/newt.mo
-share/locale/dz/LC_MESSAGES/newt.mo
-share/locale/el/LC_MESSAGES/newt.mo
-share/locale/eo/LC_MESSAGES/newt.mo
-share/locale/es/LC_MESSAGES/newt.mo
-share/locale/et/LC_MESSAGES/newt.mo
-share/locale/eu/LC_MESSAGES/newt.mo
-share/locale/fi/LC_MESSAGES/newt.mo
-share/locale/fr/LC_MESSAGES/newt.mo
-share/locale/ga/LC_MESSAGES/newt.mo
-share/locale/gl/LC_MESSAGES/newt.mo
-share/locale/gu/LC_MESSAGES/newt.mo
-share/locale/he/LC_MESSAGES/newt.mo
-share/locale/hi/LC_MESSAGES/newt.mo
-share/locale/hr/LC_MESSAGES/newt.mo
-share/locale/hu/LC_MESSAGES/newt.mo
-share/locale/id/LC_MESSAGES/newt.mo
-share/locale/it/LC_MESSAGES/newt.mo
-share/locale/ja/LC_MESSAGES/newt.mo
-share/locale/km/LC_MESSAGES/newt.mo
-share/locale/kn/LC_MESSAGES/newt.mo
-share/locale/ko/LC_MESSAGES/newt.mo
-share/locale/ku/LC_MESSAGES/newt.mo
-share/locale/lt/LC_MESSAGES/newt.mo
-share/locale/mg/LC_MESSAGES/newt.mo
-share/locale/mk/LC_MESSAGES/newt.mo
-share/locale/ml/LC_MESSAGES/newt.mo
-share/locale/mr/LC_MESSAGES/newt.mo
-share/locale/ms/LC_MESSAGES/newt.mo
-share/locale/nb/LC_MESSAGES/newt.mo
-share/locale/ne/LC_MESSAGES/newt.mo
-share/locale/nl/LC_MESSAGES/newt.mo
-share/locale/nn/LC_MESSAGES/newt.mo
-share/locale/pa/LC_MESSAGES/newt.mo
-share/locale/pl/LC_MESSAGES/newt.mo
-share/locale/pt/LC_MESSAGES/newt.mo
-share/locale/pt_BR/LC_MESSAGES/newt.mo
-share/locale/ro/LC_MESSAGES/newt.mo
-share/locale/ru/LC_MESSAGES/newt.mo
-share/locale/sk/LC_MESSAGES/newt.mo
-share/locale/sl/LC_MESSAGES/newt.mo
-share/locale/sq/LC_MESSAGES/newt.mo
-share/locale/sr/LC_MESSAGES/newt.mo
-share/locale/sr@latin/LC_MESSAGES/newt.mo
-share/locale/sv/LC_MESSAGES/newt.mo
-share/locale/ta/LC_MESSAGES/newt.mo
-share/locale/te/LC_MESSAGES/newt.mo
-share/locale/th/LC_MESSAGES/newt.mo
-share/locale/tl/LC_MESSAGES/newt.mo
-share/locale/tr/LC_MESSAGES/newt.mo
-share/locale/uk/LC_MESSAGES/newt.mo
-share/locale/vi/LC_MESSAGES/newt.mo
-share/locale/wo/LC_MESSAGES/newt.mo
-share/locale/xh/LC_MESSAGES/newt.mo
-share/locale/zh_CN/LC_MESSAGES/newt.mo
-share/locale/zh_TW/LC_MESSAGES/newt.mo
-@dirrmtry share/locale/zh_TW
-@dirrmtry share/locale/zh_CN
-@dirrmtry share/locale/xh/LC_MESSAGES
-@dirrmtry share/locale/xh
-@dirrmtry share/locale/wo/LC_MESSAGES
-@dirrmtry share/locale/wo
-@dirrmtry share/locale/vi
-@dirrmtry share/locale/uk
-@dirrmtry share/locale/tr
-@dirrmtry share/locale/tl/LC_MESSAGES
-@dirrmtry share/locale/tl
-@dirrmtry share/locale/th
-@dirrmtry share/locale/te/LC_MESSAGES
-@dirrmtry share/locale/te
-@dirrmtry share/locale/ta
-@dirrmtry share/locale/sv
-@dirrmtry share/locale/sr@latin/LC_MESSAGES
-@dirrmtry share/locale/sr@latin
-@dirrmtry share/locale/sr
-@dirrmtry share/locale/sq
-@dirrmtry share/locale/sl
-@dirrmtry share/locale/sk
-@dirrmtry share/locale/ru
-@dirrmtry share/locale/ro
-@dirrmtry share/locale/pt_BR
-@dirrmtry share/locale/pt
-@dirrmtry share/locale/pl
-@dirrmtry share/locale/pa
-@dirrmtry share/locale/nn
-@dirrmtry share/locale/nl
-@dirrmtry share/locale/ne
-@dirrmtry share/locale/nb
-@dirrmtry share/locale/ms
-@dirrmtry share/locale/mr/LC_MESSAGES
-@dirrmtry share/locale/mr
-@dirrmtry share/locale/ml
-@dirrmtry share/locale/mk
-@dirrmtry share/locale/mg/LC_MESSAGES
-@dirrmtry share/locale/mg
-@dirrmtry share/locale/lt
-@dirrmtry share/locale/ku/LC_MESSAGES
-@dirrmtry share/locale/ku
-@dirrmtry share/locale/ko
-@dirrmtry share/locale/kn
-@dirrmtry share/locale/km/LC_MESSAGES
-@dirrmtry share/locale/km
-@dirrmtry share/locale/ja
-@dirrmtry share/locale/it
-@dirrmtry share/locale/id
-@dirrmtry share/locale/hu
-@dirrmtry share/locale/hr
-@dirrmtry share/locale/hi
-@dirrmtry share/locale/he
-@dirrmtry share/locale/gu
-@dirrmtry share/locale/gl
-@dirrmtry share/locale/ga
-@dirrmtry share/locale/fr
-@dirrmtry share/locale/fi
-@dirrmtry share/locale/eu
-@dirrmtry share/locale/et
-@dirrmtry share/locale/es
-@dirrmtry share/locale/eo
-@dirrmtry share/locale/el
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
-@dirrmtry share/locale/de
-@dirrmtry share/locale/da
-@dirrmtry share/locale/cy
-@dirrmtry share/locale/cs
-@dirrmtry share/locale/ca
-@dirrmtry share/locale/bs
-@dirrmtry share/locale/bn_IN/LC_MESSAGES
-@dirrmtry share/locale/bn_IN
-@dirrmtry share/locale/bn
-@dirrmtry share/locale/bg
-@dirrmtry share/locale/bal/LC_MESSAGES
-@dirrmtry share/locale/bal
-@dirrmtry share/locale/ast/LC_MESSAGES
-@dirrmtry share/locale/ast
-@dirrmtry share/locale/as/LC_MESSAGES
-@dirrmtry share/locale/as
-@dirrmtry share/locale/ar
-%%PORTEXAMPLES%%%%PYTHONOPT%%@dirrm %%EXAMPLESDIR%%
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/peanuts.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/popcorn.py
+%%NLS%%share/locale/ar/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/as/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ast/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/bal/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/bg/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/bn/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/bn_IN/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/bs/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ca/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/cs/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/cy/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/da/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/de/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/dz/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/el/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/es/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/et/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/eu/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/fa/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/fi/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ga/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/gl/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/gu/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/he/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/hi/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/hr/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/id/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/it/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/km/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/kn/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ko/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ku/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/lt/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/mg/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/mk/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ml/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/mr/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/nb/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/nds/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ne/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/nn/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/pa/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/pt/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/pt_BR/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ru/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sk/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sl/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sq/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sr/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sr@latin/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/ta/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/te/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/th/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/tl/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/tr/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/uk/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/wo/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/xh/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/newt.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/newt.mo
+%%NLS%%@dirrmtry share/locale/xh/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/xh
+%%NLS%%@dirrmtry share/locale/wo/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/wo
+%%NLS%%@dirrmtry share/locale/tl/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/tl
+%%NLS%%@dirrmtry share/locale/te/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/te
+%%NLS%%@dirrmtry share/locale/sr@latin/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/sr@latin
+%%NLS%%@dirrmtry share/locale/nds/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/nds
+%%NLS%%@dirrmtry share/locale/mr/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/mr
+%%NLS%%@dirrmtry share/locale/mg/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/mg
+%%NLS%%@dirrmtry share/locale/ku/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ku
+%%NLS%%@dirrmtry share/locale/km/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/km
+%%NLS%%@dirrmtry share/locale/dz/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/dz
+%%NLS%%@dirrmtry share/locale/bn_IN/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/bn_IN
+%%NLS%%@dirrmtry share/locale/bal/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/bal
+%%NLS%%@dirrmtry share/locale/ast/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/ast
+%%NLS%%@dirrmtry share/locale/as/LC_MESSAGES
+%%NLS%%@dirrmtry share/locale/as
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%TCLOPT%%@dirrm %%TCL_LIBDIR%%/whip