aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2014-04-12 18:48:25 +0800
committertota <tota@FreeBSD.org>2014-04-12 18:48:25 +0800
commit17a18c41099e44deb807f4d4b134c0b3ebbeff9f (patch)
tree482165e06e6a1877711f20fde9c26465ac4023aa /devel
parent2ccdb7218c9738c193e0a1d5784479ee607a410d (diff)
downloadfreebsd-ports-gnome-17a18c41099e44deb807f4d4b134c0b3ebbeff9f.tar.gz
freebsd-ports-gnome-17a18c41099e44deb807f4d4b134c0b3ebbeff9f.tar.zst
freebsd-ports-gnome-17a18c41099e44deb807f4d4b134c0b3ebbeff9f.zip
- Support STAGEDIR [1]
- Use USE_PYDISTUTILS= yes instead of easy_install - Use PYDISTUTILS_AUTOPLIST - Make docs unconditional to stage * Remove bsd.port.options.mk, accordingly * Remove OPTIONSFILE which is not needed - Unmute INSTALL_WRKSRC in post-install target - Remove x-generate-plist target which should have been done at r317309 when pkg-plist was removed - Bump PORTREVISION PR: ports/188493 [1] Submitted by: Bartek Rutkowski <ports@robakdesign.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/py-funcparserlib/Makefile26
1 files changed, 7 insertions, 19 deletions
diff --git a/devel/py-funcparserlib/Makefile b/devel/py-funcparserlib/Makefile
index 6f4cf9cfad0c..c695e4308be2 100644
--- a/devel/py-funcparserlib/Makefile
+++ b/devel/py-funcparserlib/Makefile
@@ -3,6 +3,7 @@
PORTNAME= funcparserlib
PORTVERSION= 0.3.6
+PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,32 +14,19 @@ COMMENT= Recursive descent parsing library based on functional combinators
LICENSE= MIT
USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
PORTDOCS= README doc
DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
-PLIST_FILES= %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%
-
OPTIONS_DEFINE= DOCS
-OPTIONSFILE= ${PORT_DBDIR}/py-${PORTNAME}/options
-
-NO_STAGE= yes
-.include <bsd.port.options.mk>
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${RM} -f ${WRKSRC}/doc/Makefile
- @${MKDIR} ${DOCSDIR}
- @cd ${INSTALL_WRKSRC} \
- && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/\{} \; \
- && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} \{} ${DOCSDIR}/\{} \;
-.endif
-
-x-generate-plist:
- ${FIND} ${PYTHON_SITELIBDIR}/${PORTNAME} -type f | ${SORT} | \
- ${SED} -e 's,${PYTHON_SITELIBDIR},%%PYTHON_SITELIBDIR%%,' > pkg-plist.new
- ${FIND} ${PYTHON_SITELIBDIR}/${PORTNAME} -type d -depth | ${SORT} -r | \
- ${SED} -e 's,${PYTHON_SITELIBDIR},@dirrm %%PYTHON_SITELIBDIR%%,' >> pkg-plist.new
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ cd ${INSTALL_WRKSRC} \
+ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${STAGEDIR}${DOCSDIR}/\{} \; \
+ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} \{} ${STAGEDIR}${DOCSDIR}/\{} \;
.include <bsd.port.mk>