aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-06-14 04:31:50 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-06-14 04:31:50 +0800
commit18ff2efbc471b28a03872fcc8b047ff6e260746f (patch)
tree5b07545084b8fbedcb4401a311eb9d0bcc71f3b4 /devel
parentc04fd804fbad7045be4fdd065b7233f112a40204 (diff)
downloadfreebsd-ports-gnome-18ff2efbc471b28a03872fcc8b047ff6e260746f.tar.gz
freebsd-ports-gnome-18ff2efbc471b28a03872fcc8b047ff6e260746f.tar.zst
freebsd-ports-gnome-18ff2efbc471b28a03872fcc8b047ff6e260746f.zip
- Fix build when using WITH_CCACHE_BUILD.
ccache's documentation says to set CCACHE_SLOPPINESS=time_macros and CFLAGS+= -fpch-preprocess (it's a magic check in ccache for the string), but doing these does not actually fix the build when files are cached. Disabling PCH for ccache still results in an 18 second build, down from 143, on a 12 core machine. - While here, strip libraries with STRIP_CMD (not bumping rev as this is not significant enough to warrant a rebuild).
Diffstat (limited to 'devel')
-rw-r--r--devel/boost-all/compiled.mk5
-rw-r--r--devel/boost-libs/Makefile4
2 files changed, 7 insertions, 2 deletions
diff --git a/devel/boost-all/compiled.mk b/devel/boost-all/compiled.mk
index f8d0910ddcb8..f40bf5eaf92f 100644
--- a/devel/boost-all/compiled.mk
+++ b/devel/boost-all/compiled.mk
@@ -45,6 +45,11 @@ BJAM_ARGS+= optimization=speed
BJAM_ARGS+= inlining=full
.endif
+# ccache build fails when using precompiled headers, on a cached build.
+.if defined(WITH_CCACHE_BUILD)
+BJAM_ARGS+= pch=off
+.endif
+
post-patch:
.if defined(USE_BINUTILS)
@${ECHO} "using ${BOOST_TOOLSET} : : ${CXX} : <linkflags>-B${LOCALBASE}/bin ;" >> ${WRKSRC}/tools/build/v2/user-config.jam
diff --git a/devel/boost-libs/Makefile b/devel/boost-libs/Makefile
index a4ad90d5bcc7..4f666fd08a5d 100644
--- a/devel/boost-libs/Makefile
+++ b/devel/boost-libs/Makefile
@@ -17,8 +17,6 @@ ICU_DESC= Boost.Regex with ICU unicode support
.include "${.CURDIR}/../boost-all/compiled.mk"
-NO_CCACHE= yes
-
BJAM_ARGS+= --without-python
.if defined(X_BUILD_FOR)
BJAM_ARGS+= --without-context --without-coroutine \
@@ -61,6 +59,8 @@ post-install:
@${CAT} ${PKG_MESSAGE_FILE_THREADS} >> ${PKGMESSAGE}
@${ECHO_CMD} >> ${PKGMESSAGE}
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so
+
@${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g" \
-e "s|%%PYTHON_INCLUDEDIR%%|${PYTHON_INCLUDEDIR}|g" \