aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authordvl <dvl@FreeBSD.org>2017-05-12 02:14:51 +0800
committerdvl <dvl@FreeBSD.org>2017-05-12 02:14:51 +0800
commit19848501806627574eee668c27c2f7747d6154e9 (patch)
tree263e5f9aadfb2ecd037d7268f1377fb6d9a11c55 /devel
parent3cc263d53b693ffad82550108e37cf3eddd8812c (diff)
downloadfreebsd-ports-gnome-19848501806627574eee668c27c2f7747d6154e9.tar.gz
freebsd-ports-gnome-19848501806627574eee668c27c2f7747d6154e9.tar.zst
freebsd-ports-gnome-19848501806627574eee668c27c2f7747d6154e9.zip
Revive devel/py-argparse
Some ports need newer versions of py-argparse and Python 2.7 ships with 1.1 Approved by: lwhsu (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-argparse/Makefile18
-rw-r--r--devel/py-argparse/distinfo3
-rw-r--r--devel/py-argparse/pkg-descr7
4 files changed, 29 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index da4e9a0e52e0..979a871e726c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4121,6 +4121,7 @@
SUBDIR += py-appdirs
SUBDIR += py-application
SUBDIR += py-apptools
+ SUBDIR += py-argparse
SUBDIR += py-apscheduler
SUBDIR += py-archetypes.querywidget
SUBDIR += py-archetypes.referencebrowserwidget
diff --git a/devel/py-argparse/Makefile b/devel/py-argparse/Makefile
new file mode 100644
index 000000000000..791c4a2ce3c1
--- /dev/null
+++ b/devel/py-argparse/Makefile
@@ -0,0 +1,18 @@
+# Created by: Li-Wen Hsu <lwhsu@lwhsu.org>
+# $FreeBSD$
+
+PORTNAME= argparse
+PORTVERSION= 1.4.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Optparse-inspired command-line parsing library
+
+LICENSE= PSFL
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+.include <bsd.port.mk>
diff --git a/devel/py-argparse/distinfo b/devel/py-argparse/distinfo
new file mode 100644
index 000000000000..560a723c0aa9
--- /dev/null
+++ b/devel/py-argparse/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1477489570
+SHA256 (argparse-1.4.0.tar.gz) = 62b089a55be1d8949cd2bc7e0df0bddb9e028faefc8c32038cc84862aefdd6e4
+SIZE (argparse-1.4.0.tar.gz) = 70508
diff --git a/devel/py-argparse/pkg-descr b/devel/py-argparse/pkg-descr
new file mode 100644
index 000000000000..2b888feccc53
--- /dev/null
+++ b/devel/py-argparse/pkg-descr
@@ -0,0 +1,7 @@
+Argparse takes the best of the optparse command-line parsing module and brings
+it new life. Argparse adds positional as well as optional arguments, the
+ability to create parsers for sub-commands, more informative help and usage
+messages, and much more. At the same time, it retains the ease and flexibility
+of use that made optparse so popular.
+
+WWW: http://code.google.com/p/argparse/