aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2018-10-10 02:17:37 +0800
committerswills <swills@FreeBSD.org>2018-10-10 02:17:37 +0800
commit1dead2c55cd1bd7bfa16c11b133f555114f14b21 (patch)
tree42745dd3e7a0581c787592d1a7bce390bb8df1fa /devel
parent8310fc52a5acab288fa9625e8b0161893a756534 (diff)
downloadfreebsd-ports-gnome-1dead2c55cd1bd7bfa16c11b133f555114f14b21.tar.gz
freebsd-ports-gnome-1dead2c55cd1bd7bfa16c11b133f555114f14b21.tar.zst
freebsd-ports-gnome-1dead2c55cd1bd7bfa16c11b133f555114f14b21.zip
devel/thrift: fix build with GCC-based arches
PR: 231699 Submitted by: Piotr Kubaj <pkubaj@anongoth.pl> Approved by: maintainer timeout (komarov@valerka.net, >2 weeks)
Diffstat (limited to 'devel')
-rw-r--r--devel/thrift/Makefile6
-rw-r--r--devel/thrift/files/patch-lib_lua_src_usocket.c10
2 files changed, 11 insertions, 5 deletions
diff --git a/devel/thrift/Makefile b/devel/thrift/Makefile
index 7c769960ed2a..78768c4d9f8e 100644
--- a/devel/thrift/Makefile
+++ b/devel/thrift/Makefile
@@ -12,11 +12,7 @@ COMMENT= Framework for scalable cross-language services development
LICENSE= APACHE20
-BROKEN_mips= fails to compile: unrecognized command line option "-Wno-c++11-long-long"
-BROKEN_mips64= fails to compile: unrecognized command line option "-Wno-c++11-long-long"
-BROKEN_powerpc64= fails to compile: unrecognized command line option "-Wno-c++11-long-long"
-
-USES= autoreconf libtool pkgconfig
+USES= autoreconf compiler:c++11-lang libtool pkgconfig
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/thrift/files/patch-lib_lua_src_usocket.c b/devel/thrift/files/patch-lib_lua_src_usocket.c
new file mode 100644
index 000000000000..4c480b57c627
--- /dev/null
+++ b/devel/thrift/files/patch-lib_lua_src_usocket.c
@@ -0,0 +1,10 @@
+--- lib/lua/src/usocket.c.orig 2018-09-24 22:09:54 UTC
++++ lib/lua/src/usocket.c
+@@ -25,6 +25,7 @@
+ #include <unistd.h>
+ #include <fcntl.h>
+ #include <errno.h>
++#include <netinet/in.h>
+
+ #include <stdio.h> // TODO REMOVE
+