aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorjonathan <jonathan@FreeBSD.org>2016-09-22 19:15:28 +0800
committerjonathan <jonathan@FreeBSD.org>2016-09-22 19:15:28 +0800
commit1f6de68090e93aa1c6eb25a9cd3c00570f6ca814 (patch)
treee6240cd7c3493ab9e2c376bc12a2dce1713f42f5 /devel
parentf262406ba0daca2d7253255f847a67fdd47d9f64 (diff)
downloadfreebsd-ports-gnome-1f6de68090e93aa1c6eb25a9cd3c00570f6ca814.tar.gz
freebsd-ports-gnome-1f6de68090e93aa1c6eb25a9cd3c00570f6ca814.tar.zst
freebsd-ports-gnome-1f6de68090e93aa1c6eb25a9cd3c00570f6ca814.zip
New port: devel/libgrading Library for grading C/C++ assignments
This port provides libgrading, a library for evaluating C- and C++-language assignments in programming classes. It could also be used as a unit testing framework, but it's designed to treat the code under test with some suspicion (using Capsicum sandboxing by default). It also allows different tests to be assigned different weights towards the overall grade/score, which is not typically a feature of unit testing frameworks. Approved by: mat Differential Revision: https://reviews.freebsd.org/D7956
Diffstat (limited to 'devel')
-rw-r--r--devel/libgrading/Makefile24
-rw-r--r--devel/libgrading/distinfo3
-rw-r--r--devel/libgrading/pkg-descr5
3 files changed, 32 insertions, 0 deletions
diff --git a/devel/libgrading/Makefile b/devel/libgrading/Makefile
new file mode 100644
index 000000000000..d58506400a5e
--- /dev/null
+++ b/devel/libgrading/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= libgrading
+PORTVERSION= 0.1.2
+DISTVERSIONPREFIX= v
+CATEGORIES= devel
+
+MAINTAINER= jonathan@FreeBSD.org
+COMMENT= Simple library for grading C- and C++-language assignments
+
+LICENSE= APACHE20
+
+LIB_DEPENDS= libdistance.so:devel/libdistance
+
+USE_GITHUB= yes
+GH_ACCOUNT= trombonehero
+
+USES= cmake
+USE_LDCONFIG= yes
+
+PLIST_FILES= include/libgrading.h \
+ lib/libgrading.so
+
+.include <bsd.port.mk>
diff --git a/devel/libgrading/distinfo b/devel/libgrading/distinfo
new file mode 100644
index 000000000000..428863c5a615
--- /dev/null
+++ b/devel/libgrading/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474311154
+SHA256 (trombonehero-libgrading-v0.1.2_GH0.tar.gz) = 1d0e11cf1adef7bc40df08ef1f984f4f8dcc2172d5bd1bae7a48e0871b546fa7
+SIZE (trombonehero-libgrading-v0.1.2_GH0.tar.gz) = 44136
diff --git a/devel/libgrading/pkg-descr b/devel/libgrading/pkg-descr
new file mode 100644
index 000000000000..273088438865
--- /dev/null
+++ b/devel/libgrading/pkg-descr
@@ -0,0 +1,5 @@
+This is a simple library for grading C- and C++-language assignments. It runs
+each test case in a child process in order to capture common programming errors
+such as infinite loops and segmentation faults.
+
+WWW: http://trombonehero.github.io/libgrading/