aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2015-06-09 03:16:19 +0800
committermat <mat@FreeBSD.org>2015-06-09 03:16:19 +0800
commit2104814d452482616ca4e15546b44ca53688c651 (patch)
tree0c2047c0c1d90d473e9698c76fc578f5325222fe /devel
parent14a611edbe2fb28562e4e23cd4427b457f0494f3 (diff)
downloadfreebsd-ports-gnome-2104814d452482616ca4e15546b44ca53688c651.tar.gz
freebsd-ports-gnome-2104814d452482616ca4e15546b44ca53688c651.tar.zst
freebsd-ports-gnome-2104814d452482616ca4e15546b44ca53688c651.zip
Mark those BROKEN, they don't build with Perl 5.22+
Sponsored by: Absolight
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Devel-MAT/Makefile4
-rw-r--r--devel/p5-Regexp-Compare/Makefile8
2 files changed, 11 insertions, 1 deletions
diff --git a/devel/p5-Devel-MAT/Makefile b/devel/p5-Devel-MAT/Makefile
index 9fd2b3561cc8..767ef484ee6d 100644
--- a/devel/p5-Devel-MAT/Makefile
+++ b/devel/p5-Devel-MAT/Makefile
@@ -34,6 +34,10 @@ BUILD_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
RUN_DEPENDS+= p5-Module-Pluggable>=0:${PORTSDIR}/devel/p5-Module-Pluggable
.endif
+.if ${PERL_LEVEL} >= 502200
+tROKEN= Fails to build with Perl >= 5.22
+.endif
+
post-install:
@${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/MAT/Dumper/Dumper.so ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/MAT/MAT.so
@${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/MAT/Dumper/Dumper.so ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Devel/MAT/MAT.so
diff --git a/devel/p5-Regexp-Compare/Makefile b/devel/p5-Regexp-Compare/Makefile
index e10389118bcd..837d8a44187a 100644
--- a/devel/p5-Regexp-Compare/Makefile
+++ b/devel/p5-Regexp-Compare/Makefile
@@ -17,4 +17,10 @@ LICENSE_COMB= dual
USE_PERL5= 5.16+ configure
USES= perl5
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} >= 502200
+BROKEN= Fails to build with Perl >= 5.22
+.endif
+
+.include <bsd.port.post.mk>