aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-11-11 21:12:02 +0800
committertijl <tijl@FreeBSD.org>2015-11-11 21:12:02 +0800
commit23aea82226205ee47492218593611b43ef9382dc (patch)
tree7403fa9d47369ead86ca91d31bb768dfa497aa38 /devel
parentc328f1b1f119bbdd93b50e337616e961cbe2ecbf (diff)
downloadfreebsd-ports-gnome-23aea82226205ee47492218593611b43ef9382dc.tar.gz
freebsd-ports-gnome-23aea82226205ee47492218593611b43ef9382dc.tar.zst
freebsd-ports-gnome-23aea82226205ee47492218593611b43ef9382dc.zip
- Pass --without-guile to configure when GUILE option is off
- Use CONFIGURE_WITH for other options as well PR: 204041
Diffstat (limited to 'devel')
-rw-r--r--devel/gdb/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/devel/gdb/Makefile b/devel/gdb/Makefile
index f19e28b47974..d3e564dc36d4 100644
--- a/devel/gdb/Makefile
+++ b/devel/gdb/Makefile
@@ -56,15 +56,13 @@ BASE_READLINE_USES= readline
BASE_READLINE_CFLAGS= -D_rl_echoing_p=readline_echoing_p
BUNDLED_READLINE_CONFIGURE_OFF= --with-system-readline
DEBUG_CFLAGS= -g
-EXPAT_CONFIGURE_ON= --with-expat=yes
-EXPAT_CONFIGURE_OFF= --without-expat
+EXPAT_CONFIGURE_WITH= expat
EXPAT_LIB_DEPENDS= libexpat.so:${PORTSDIR}/textproc/expat2
-GUILE_CONFIGURE_ON= --with-guile
+GUILE_CONFIGURE_WITH= guile
GUILE_USES= pkgconfig
GUILE_LIB_DEPENDS= libguile-2.0.so:${PORTSDIR}/lang/guile2
PORT_READLINE_USES= readline:port
-PYTHON_CONFIGURE_ON= --with-python=${PYTHON_CMD}
-PYTHON_CONFIGURE_OFF= --without-python
+PYTHON_CONFIGURE_WITH= python=${PYTHON_CMD}
PYTHON_USES= python:2
TUI_CONFIGURE_ENABLE= tui