aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-05-13 11:35:51 +0800
committerlinimon <linimon@FreeBSD.org>2017-05-13 11:35:51 +0800
commit2b1838bc534c937c3ea0514a46ee015f34b8ae46 (patch)
tree0e89021fd44a8edda1d97d4e3b9b90599d254d40 /devel
parent6bc03c0fcc5387275e3b6640596109d8a95c0397 (diff)
downloadfreebsd-ports-gnome-2b1838bc534c937c3ea0514a46ee015f34b8ae46.tar.gz
freebsd-ports-gnome-2b1838bc534c937c3ea0514a46ee015f34b8ae46.tar.zst
freebsd-ports-gnome-2b1838bc534c937c3ea0514a46ee015f34b8ae46.zip
Mark some ports failing on power64. In cases where the error message
was a stub, provide a real one. While here, pet portlint. Approved by: portmgr (tier-2 blanket)
Diffstat (limited to 'devel')
-rw-r--r--devel/kore/Makefile2
-rw-r--r--devel/libepoll-shim/Makefile2
-rw-r--r--devel/libgpkg/Makefile2
-rw-r--r--devel/libopkele/Makefile2
-rw-r--r--devel/liborcus/Makefile2
-rw-r--r--devel/libpololu-avr/Makefile2
-rw-r--r--devel/openocd/Makefile2
-rw-r--r--devel/pear-PHP_UML/Makefile2
-rw-r--r--devel/pear-TheSeer_fXSL/Makefile2
-rw-r--r--devel/pecl-qb/Makefile2
-rw-r--r--devel/pecl-swoole/Makefile2
-rw-r--r--devel/py-greenlet/Makefile3
-rw-r--r--devel/py-libzfs/Makefile2
-rw-r--r--devel/py-pycapsicum/Makefile2
-rw-r--r--devel/radare2/Makefile8
-rw-r--r--devel/spdlog/Makefile2
-rw-r--r--devel/talloc/Makefile2
-rw-r--r--devel/thrift-cpp/Makefile12
18 files changed, 43 insertions, 10 deletions
diff --git a/devel/kore/Makefile b/devel/kore/Makefile
index b27f8e66aee7..0dbc9ef3d03a 100644
--- a/devel/kore/Makefile
+++ b/devel/kore/Makefile
@@ -13,6 +13,8 @@ COMMENT= Web application framework for writing web APIs in C
LICENSE= ISCL
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: cc1: error: -Werror=c11-extensions: No option -Wc11-extensions
+
USES= compiler gmake
USE_GITHUB= yes
diff --git a/devel/libepoll-shim/Makefile b/devel/libepoll-shim/Makefile
index c1f06781dc3d..4cda215546e3 100644
--- a/devel/libepoll-shim/Makefile
+++ b/devel/libepoll-shim/Makefile
@@ -10,6 +10,8 @@ COMMENT= epoll shim implemented using kevent
LICENSE= MIT
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option -Wno-missing-variable-declarations
+
USE_GITHUB= yes
GH_ACCOUNT= FreeBSDDesktop
GH_PROJECT= epoll-shim
diff --git a/devel/libgpkg/Makefile b/devel/libgpkg/Makefile
index 321f739eb011..1db4ac001fd7 100644
--- a/devel/libgpkg/Makefile
+++ b/devel/libgpkg/Makefile
@@ -14,6 +14,8 @@ COMMENT= SQLite 3 extension of minimal OGC GeoPackage implementation
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to link: cc: Internal error: Segmentation fault (program ld)
+
OPTIONS_DEFINE= GEOS
OPTIONS_DEFAULT=GEOS
diff --git a/devel/libopkele/Makefile b/devel/libopkele/Makefile
index 74ea77c10810..7e3730397324 100644
--- a/devel/libopkele/Makefile
+++ b/devel/libopkele/Makefile
@@ -18,6 +18,8 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libtidy.so:www/tidy-lib \
libxslt.so:textproc/libxslt
+BROKEN_powerpc64= fails to compile: iterator.h: error: invalid abstract return type
+
USE_LDCONFIG= yes
USES= libtool gmake pathfix pkgconfig compiler:c++11-lang ssl
GNU_CONFIGURE= yes
diff --git a/devel/liborcus/Makefile b/devel/liborcus/Makefile
index e99cfa05b8c0..745fbf9a11a9 100644
--- a/devel/liborcus/Makefile
+++ b/devel/liborcus/Makefile
@@ -14,6 +14,8 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/include/mdds-1.2/mdds/global.hpp:devel/mdds
LIB_DEPENDS= libboost_system.so:devel/boost-libs
+BROKEN_powerpc64= fails to configure: checking for the Boost program_options library... no
+
GNU_CONFIGURE= yes
USES= compiler:c++11-lib libtool pathfix pkgconfig tar:xz
USE_LDCONFIG= yes
diff --git a/devel/libpololu-avr/Makefile b/devel/libpololu-avr/Makefile
index 3493677bd864..52b2ba0cf5a0 100644
--- a/devel/libpololu-avr/Makefile
+++ b/devel/libpololu-avr/Makefile
@@ -12,6 +12,8 @@ LICENSE= MIT
BUILD_DEPENDS= ${LOCALBASE}/avr/lib/libc.a:devel/avr-libc
RUN_DEPENDS= ${LOCALBASE}/avr/lib/libc.a:devel/avr-libc
+BROKEN_powerpc64= fails to build: OrangutanAnalog.h: internal compiler error: Segmentation fault
+
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= pololu
diff --git a/devel/openocd/Makefile b/devel/openocd/Makefile
index 0df61aa3a82b..393371ba3b2a 100644
--- a/devel/openocd/Makefile
+++ b/devel/openocd/Makefile
@@ -11,6 +11,8 @@ COMMENT= Open On-Chip Debugger
BUILD_DEPENDS= ${LOCALBASE}/bin/makeinfo:print/texinfo
+BROKEN_powerpc64= fails to configure: error: C compiler cannot create executables
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --disable-werror
CONFIGURE_ENV= MAKEINFO=${LOCALBASE}/bin/makeinfo
diff --git a/devel/pear-PHP_UML/Makefile b/devel/pear-PHP_UML/Makefile
index c7275b9cd683..0d89b5aa2c47 100644
--- a/devel/pear-PHP_UML/Makefile
+++ b/devel/pear-PHP_UML/Makefile
@@ -14,6 +14,8 @@ BUILD_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear \
${PEARDIR}/Console/CommandLine.php:devel/pear-Console_CommandLine
RUN_DEPENDS= ${PEARDIR}/PEAR.php:devel/pear
+BROKEN_powerpc64= fails to package: Signal 11
+
USES= pear
USE_PHP= spl xsl
diff --git a/devel/pear-TheSeer_fXSL/Makefile b/devel/pear-TheSeer_fXSL/Makefile
index d0e99d71dcde..fa39d36cf6bb 100644
--- a/devel/pear-TheSeer_fXSL/Makefile
+++ b/devel/pear-TheSeer_fXSL/Makefile
@@ -16,6 +16,8 @@ LICENSE= BSD3CLAUSE
BUILD_DEPENDS= ${PEARDIR}/.channels/pear.netpirates.net.reg:devel/pear-channel-theseer
RUN_DEPENDS= ${PEARDIR}/.channels/pear.netpirates.net.reg:devel/pear-channel-theseer
+BROKEN_powerpc64= fails to package: Signal 11
+
USE_PHP= dom xml xsl
PEAR_CHANNEL= theseer
USES= pear
diff --git a/devel/pecl-qb/Makefile b/devel/pecl-qb/Makefile
index 6a5b2e61020e..19c518b9e035 100644
--- a/devel/pecl-qb/Makefile
+++ b/devel/pecl-qb/Makefile
@@ -11,6 +11,8 @@ COMMENT= PHP Accelerator designed mainly for graphic work
LICENSE= PHP301
+BROKEN_powerpc64= fails to build: Killing runaway build after 7200 seconds with no output
+
USES= php:pecl
IGNORE_WITH_PHP= 70
diff --git a/devel/pecl-swoole/Makefile b/devel/pecl-swoole/Makefile
index 0701c135e055..6815f6b4ad5b 100644
--- a/devel/pecl-swoole/Makefile
+++ b/devel/pecl-swoole/Makefile
@@ -11,6 +11,8 @@ COMMENT= Asynchronous & concurrent & distributed networking framework
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to build: swoole_config.h: error GCC 4.4 or later required
+
USES= execinfo php:pecl ssl
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/devel/py-greenlet/Makefile b/devel/py-greenlet/Makefile
index ec67badc93a3..8b14d31f8b77 100644
--- a/devel/py-greenlet/Makefile
+++ b/devel/py-greenlet/Makefile
@@ -13,6 +13,9 @@ COMMENT= Light-weight microthreads for Python
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+NOT_FOR_ARCHS= powerpc64
+NOT_FOR_ARCHS_REASON= greenlet needs to be ported to this platform
+
DO_MAKE_TEST= ${PYTHON_CMD}
TEST_TARGET= run-tests.py
USE_PYTHON= autoplist concurrent distutils
diff --git a/devel/py-libzfs/Makefile b/devel/py-libzfs/Makefile
index 413008feed21..3dc12ba7defa 100644
--- a/devel/py-libzfs/Makefile
+++ b/devel/py-libzfs/Makefile
@@ -11,6 +11,8 @@ COMMENT= Python libzfs bindings
LICENSE= BSD2CLAUSE
+BROKEN_powerpc64= fails to build: libzfs.c: error: convert_for_assignment: incompatible type for argument 3 of zfs_path_to_zhandle
+
USE_GITHUB= yes
GH_ACCOUNT= freenas
GH_PROJECT= py-libzfs
diff --git a/devel/py-pycapsicum/Makefile b/devel/py-pycapsicum/Makefile
index 85a31e633394..ad10203d5507 100644
--- a/devel/py-pycapsicum/Makefile
+++ b/devel/py-pycapsicum/Makefile
@@ -12,6 +12,8 @@ COMMENT= Python interface to capsicum security
LICENSE= BSD3CLAUSE
+BROKEN_powerpc64= fails to compile: _pycapsicum.c: error: 'for' loop initial declaration used outside C99 mode
+
USES= python
USE_PYTHON= autoplist distutils
diff --git a/devel/radare2/Makefile b/devel/radare2/Makefile
index 931d53db634b..09310b0a5fb1 100644
--- a/devel/radare2/Makefile
+++ b/devel/radare2/Makefile
@@ -12,14 +12,12 @@ COMMENT= Tools to disasm, debug, analyze, and manipulate binary files
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-BROKEN_aarch64= Does not build: Unsupported BSD architecture
-BROKEN_mips64= Does not build: Unsupported BSD architecture
-BROKEN_powerpc64= Does not build
-BROKEN_sparc64= Does not build
-
BUILD_DEPENDS+= pkg-config:devel/pkgconf
LIB_DEPENDS+= libcapstone.so:devel/capstone4
+NOT_FOR_ARCHS= aarch64 armv6 mips mips64 powerpc powerpc64 sparc64
+NOT_FOR_ARCHS_REASON= does not build: Unsupported BSD architecture
+
CONFIGURE_ARGS+= --with-syscapstone
USES= gmake pathfix pkgconfig tar:xz
diff --git a/devel/spdlog/Makefile b/devel/spdlog/Makefile
index 443fe673490a..17938f583aeb 100644
--- a/devel/spdlog/Makefile
+++ b/devel/spdlog/Makefile
@@ -13,6 +13,8 @@ COMMENT= Super fast C++ logging library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
+BROKEN_powerpc64= fails to compile: includes.h: error: chrono: No such file or directory
+
USE_GITHUB= yes
GH_ACCOUNT= gabime
diff --git a/devel/talloc/Makefile b/devel/talloc/Makefile
index 9fa63daea333..b72fe75f32c2 100644
--- a/devel/talloc/Makefile
+++ b/devel/talloc/Makefile
@@ -14,6 +14,8 @@ LICENSE= LGPL3
CONFLICTS= samba33-3.*
+BROKEN_powerpc64= fails to compile: cc1: error: unrecognized command line option "-Wno-format-length"
+
USES= compiler pkgconfig waf
USE_LDCONFIG= yes
WAF_CMD= buildtools/bin/waf
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index a1a4bd3597e7..f0b55e7bb7bd 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -6,18 +6,20 @@ PORTVERSION= ${THRIFT_PORTVERSION} # to keep in sync with thrift
PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= devel
+MASTER_SITES= APACHE/thrift/${PORTVERSION}
PKGNAMESUFFIX= -cpp
-MASTER_SITES= APACHE/thrift/${PORTVERSION}
-DISTNAME= thrift-${PORTVERSION}
+DISTNAME= thrift-${PORTVERSION}
MAINTAINER= komarov@valerka.net
COMMENT= C++ interface to Thrift
-DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
-
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libevent.so:devel/libevent
+DISTINFO_FILE= ${.CURDIR}/../thrift/distinfo
+
+BROKEN_powerpc64= fails to compile: undefined reference to std::__throw_out_of_range_fmt
+
USES= autoreconf pkgconfig gmake compiler:c++11-lang \
libtool pathfix ssl
GNU_CONFIGURE= yes
@@ -55,7 +57,7 @@ USE_CXXSTD= c++11
.endif
.if ${SSL_DEFAULT} == openssl-devel
-BROKEN= Cannot find libcrypto.
+BROKEN= cannot find libcrypto
.endif
post-install: