aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormatthew <matthew@FreeBSD.org>2017-08-02 22:07:49 +0800
committermatthew <matthew@FreeBSD.org>2017-08-02 22:07:49 +0800
commit2dc5ab50108b0ae9c347f81441d802bbb3216115 (patch)
treee7dac96890873d6a4509fd436f61dcf0e79054f0 /devel
parentbea15c025efc1b4b85a0984f09a479cebe7ae499 (diff)
downloadfreebsd-ports-gnome-2dc5ab50108b0ae9c347f81441d802bbb3216115.tar.gz
freebsd-ports-gnome-2dc5ab50108b0ae9c347f81441d802bbb3216115.tar.zst
freebsd-ports-gnome-2dc5ab50108b0ae9c347f81441d802bbb3216115.zip
A package-based, source code amalgamater for collapsing Python
packages into a single module. The big idea here is to glue most of the source files in a package or subpackage together into a single module, called __amalgam__.py. Combined with some hooks in the __init__.py, this should dramatically reduce the number of files that are being searched for inside of the package. This is critical in larger projects where import times are the major startup time cost. WWW: https://github.com/xonsh/amalgamate PR: 220596
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-amalgamate/Makefile18
-rw-r--r--devel/py-amalgamate/Makefile~17
-rw-r--r--devel/py-amalgamate/distinfo3
-rw-r--r--devel/py-amalgamate/pkg-descr11
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a3eae152de43..5b938ced8c92 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4152,6 +4152,7 @@
SUBDIR += py-ZopeUndo
SUBDIR += py-adb
SUBDIR += py-akismet
+ SUBDIR += py-amalgamate
SUBDIR += py-aniso8601
SUBDIR += py-anonfunc
SUBDIR += py-anyconfig
diff --git a/devel/py-amalgamate/Makefile b/devel/py-amalgamate/Makefile
new file mode 100644
index 000000000000..f6bfcc3a6e01
--- /dev/null
+++ b/devel/py-amalgamate/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= amalgamate
+PORTVERSION= 0.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Collapse Python packages into a single module
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-amalgamate/Makefile~ b/devel/py-amalgamate/Makefile~
new file mode 100644
index 000000000000..db8787ffe835
--- /dev/null
+++ b/devel/py-amalgamate/Makefile~
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= amalgamate
+PORTVERSION= 0.1.3
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Collapse Python packages into a single module
+
+LICENSE= BSD3CLAUSE
+
+USES= python:3.4+
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/py-amalgamate/distinfo b/devel/py-amalgamate/distinfo
new file mode 100644
index 000000000000..7ebf24fed65d
--- /dev/null
+++ b/devel/py-amalgamate/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501677698
+SHA256 (amalgamate-0.1.3.tar.gz) = e38696998145ee7b5eaabe7ab60e60108e64448eefcb73eb7f917fe24e6ff761
+SIZE (amalgamate-0.1.3.tar.gz) = 10766
diff --git a/devel/py-amalgamate/pkg-descr b/devel/py-amalgamate/pkg-descr
new file mode 100644
index 000000000000..24336410a2c7
--- /dev/null
+++ b/devel/py-amalgamate/pkg-descr
@@ -0,0 +1,11 @@
+A package-based, source code amalgamater for collapsing Python
+packages into a single module.
+
+The big idea here is to glue most of the source files in a package or
+subpackage together into a single module, called
+__amalgam__.py. Combined with some hooks in the __init__.py, this
+should dramatically reduce the number of files that are being searched
+for inside of the package. This is critical in larger projects where
+import times are the major startup time cost.
+
+WWW: https://github.com/xonsh/amalgamate