aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2010-12-22 18:31:37 +0800
committermat <mat@FreeBSD.org>2010-12-22 18:31:37 +0800
commit2e84893760a36e63f73cf2a95341b066dd22baf8 (patch)
tree9c4bf229a69d2e8ebef16182c116f1fd71bdd850 /devel
parent5afca14b35ff6168a810f4df3860dc48de75a2a2 (diff)
downloadfreebsd-ports-gnome-2e84893760a36e63f73cf2a95341b066dd22baf8.tar.gz
freebsd-ports-gnome-2e84893760a36e63f73cf2a95341b066dd22baf8.tar.zst
freebsd-ports-gnome-2e84893760a36e63f73cf2a95341b066dd22baf8.zip
This POE component encapsulates a session that sends events to client sessions
on a schedule as defined by a DateTime::Set iterator.
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-POE-Component-Schedule/Makefile27
-rw-r--r--devel/p5-POE-Component-Schedule/distinfo3
-rw-r--r--devel/p5-POE-Component-Schedule/pkg-descr4
-rw-r--r--devel/p5-POE-Component-Schedule/pkg-plist3
5 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2c0e71924e37..b17c716998eb 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2015,6 +2015,7 @@
SUBDIR += p5-POE-Component-Pluggable
SUBDIR += p5-POE-Component-RSS
SUBDIR += p5-POE-Component-RSSAggregator
+ SUBDIR += p5-POE-Component-Schedule
SUBDIR += p5-POE-Component-Server-XMLRPC
SUBDIR += p5-POE-Component-TSTP
SUBDIR += p5-POE-Devel-Profiler
diff --git a/devel/p5-POE-Component-Schedule/Makefile b/devel/p5-POE-Component-Schedule/Makefile
new file mode 100644
index 000000000000..e48b30e96263
--- /dev/null
+++ b/devel/p5-POE-Component-Schedule/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: POE-Component-Schedule
+# Date created: December 21 2010
+# Whom: mat
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Schedule
+PORTVERSION= 0.95
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= mat@FreeBSD.org
+COMMENT= Schedule POE Events using a cron spec
+
+BUILD_DEPENDS= ${SITE_PERL}/Test/Simple.pm:${PORTSDIR}/devel/p5-Test-Simple \
+ ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
+RUN_DEPENDS= ${SITE_PERL}/POE.pm:${PORTSDIR}/devel/p5-POE \
+ ${SITE_PERL}/DateTime/Set.pm:${PORTSDIR}/devel/p5-DateTime-Set
+
+PERL_MODBUILD= yes
+
+MAN3= POE::Component::Schedule.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-POE-Component-Schedule/distinfo b/devel/p5-POE-Component-Schedule/distinfo
new file mode 100644
index 000000000000..55c92e217933
--- /dev/null
+++ b/devel/p5-POE-Component-Schedule/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Schedule-0.95.tar.gz) = b902b657b8114468382955c345ed05ca
+SHA256 (POE-Component-Schedule-0.95.tar.gz) = 1f7145d2d1a1d39d708eee8231555ec86e61aa4fec6465b3d36a2d2b6589876d
+SIZE (POE-Component-Schedule-0.95.tar.gz) = 18894
diff --git a/devel/p5-POE-Component-Schedule/pkg-descr b/devel/p5-POE-Component-Schedule/pkg-descr
new file mode 100644
index 000000000000..36a6a261adce
--- /dev/null
+++ b/devel/p5-POE-Component-Schedule/pkg-descr
@@ -0,0 +1,4 @@
+This component extends POE::Component::Schedule by adding an easy way t specify
+event schedules using a simple cron spec.
+
+WWW: http://search.cpan.org/dist/POE-Component-Cron/
diff --git a/devel/p5-POE-Component-Schedule/pkg-plist b/devel/p5-POE-Component-Schedule/pkg-plist
new file mode 100644
index 000000000000..fcd44281fe7a
--- /dev/null
+++ b/devel/p5-POE-Component-Schedule/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/POE/Component/Schedule.pm
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE