aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2018-06-29 21:37:54 +0800
committerale <ale@FreeBSD.org>2018-06-29 21:37:54 +0800
commit318ecffd57a0a2878a3118328546ac25c5905663 (patch)
tree0ffcf6d4a454c65b3fc2a0643ec98a622eedadc1 /devel
parent5ed5164259fa0e8d5196390edc4d30b3eb83e587 (diff)
downloadfreebsd-ports-gnome-318ecffd57a0a2878a3118328546ac25c5905663.tar.gz
freebsd-ports-gnome-318ecffd57a0a2878a3118328546ac25c5905663.tar.zst
freebsd-ports-gnome-318ecffd57a0a2878a3118328546ac25c5905663.zip
Fix build on aarch64, armv6, armv7.
PR: 229382 Submitted by: tobik
Diffstat (limited to 'devel')
-rw-r--r--devel/jakarta-commons-daemon/Makefile4
-rw-r--r--devel/jakarta-commons-daemon/files/patch-configure11
2 files changed, 11 insertions, 4 deletions
diff --git a/devel/jakarta-commons-daemon/Makefile b/devel/jakarta-commons-daemon/Makefile
index 2cabf90b1d8a..7097bf08277a 100644
--- a/devel/jakarta-commons-daemon/Makefile
+++ b/devel/jakarta-commons-daemon/Makefile
@@ -15,10 +15,6 @@ COMMENT= Wrapper code to start/stop a Java application as a daemon
LICENSE= APACHE20
-BROKEN_aarch64= fails to compile: 'jni_md.h' file not found
-BROKEN_armv6= fails to compile: 'jni_md.h' file not found
-BROKEN_armv7= fails to compile: 'jni_md.h' file not found
-
OPTIONS_DEFINE= DOCS
USE_JAVA= yes
diff --git a/devel/jakarta-commons-daemon/files/patch-configure b/devel/jakarta-commons-daemon/files/patch-configure
new file mode 100644
index 000000000000..240a0979310e
--- /dev/null
+++ b/devel/jakarta-commons-daemon/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2018-06-29 12:40:33 UTC
++++ configure
+@@ -3504,7 +3504,7 @@ then
+ $as_echo "jni_md.h found in $JAVA_HOME/$JAVA_INC" >&6; }
+ INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/$JAVA_INC"
+ else
+- INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$supported_os"
++ INCLUDES="$INCLUDES -I$JAVA_HOME/include -I$JAVA_HOME/include/$JAVA_OS"
+ fi
+
+ if test "$GCC" = "yes"