aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2007-06-14 09:57:12 +0800
committerclsung <clsung@FreeBSD.org>2007-06-14 09:57:12 +0800
commit32a947a431746dd556c7f4d6ac8b17328a067f1a (patch)
tree159cfcc7eece8041cd2a5e1179ebb4a2902b66e8 /devel
parent953ec6a41b26eebfc39a856577f70fd967b3c7e4 (diff)
downloadfreebsd-ports-gnome-32a947a431746dd556c7f4d6ac8b17328a067f1a.tar.gz
freebsd-ports-gnome-32a947a431746dd556c7f4d6ac8b17328a067f1a.tar.zst
freebsd-ports-gnome-32a947a431746dd556c7f4d6ac8b17328a067f1a.zip
Add p5-IO-Async 0.07, perl modules that implement asynchronous
filehandle IO. PR: ports/113505 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-IO-Async/Makefile25
-rw-r--r--devel/p5-IO-Async/distinfo3
-rw-r--r--devel/p5-IO-Async/pkg-descr10
-rw-r--r--devel/p5-IO-Async/pkg-plist16
5 files changed, 55 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9d451d37bc17..2a5c14702e33 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1205,6 +1205,7 @@
SUBDIR += p5-IO
SUBDIR += p5-IO-AIO
SUBDIR += p5-IO-All
+ SUBDIR += p5-IO-Async
SUBDIR += p5-IO-Capture
SUBDIR += p5-IO-CaptureOutput
SUBDIR += p5-IO-Digest
diff --git a/devel/p5-IO-Async/Makefile b/devel/p5-IO-Async/Makefile
new file mode 100644
index 000000000000..51ea2c33e07f
--- /dev/null
+++ b/devel/p5-IO-Async/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-IO-Async
+# Date created: 2007-06-10
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Async
+PORTVERSION= 0.07
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl modules that implement asynchronous filehandle IO
+
+PERL_CONFIGURE= yes
+
+MAN3= IO::Async.3 IO::Async::Buffer.3 IO::Async::ChildManager.3 \
+ IO::Async::Notifier.3 IO::Async::Set.3 \
+ IO::Async::Set::GMainLoop.3 IO::Async::Set::IO_Poll.3 \
+ IO::Async::Set::Select.3 IO::Async::SignalProxy.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-IO-Async/distinfo b/devel/p5-IO-Async/distinfo
new file mode 100644
index 000000000000..76e50d8dc66f
--- /dev/null
+++ b/devel/p5-IO-Async/distinfo
@@ -0,0 +1,3 @@
+MD5 (IO-Async-0.07.tar.gz) = d0addd5a98b59de0c15f6542937ec7f9
+SHA256 (IO-Async-0.07.tar.gz) = 133efb840a7d8d558de7c875aadc176b6dea4d786a6aa53b7eedfb2b223968d2
+SIZE (IO-Async-0.07.tar.gz) = 30647
diff --git a/devel/p5-IO-Async/pkg-descr b/devel/p5-IO-Async/pkg-descr
new file mode 100644
index 000000000000..a45e81dc546b
--- /dev/null
+++ b/devel/p5-IO-Async/pkg-descr
@@ -0,0 +1,10 @@
+This collection of modules allows programs to be written that perform
+asynchronous filehandle IO operations. A typical program using them
+would consist of a single subclass of IO::Async::Set to act as a
+container for a number of IO::Async::Notifier objects (or subclasses
+thereof). The set itself is responsible for checking read- or
+write-readiness, and informing the notifiers of these conditions. The
+notifiers then perform whatever work is required on these conditions,
+by using subclass methods or callback functions.
+
+WWW: http://search.cpan.org/dist/IO-Async/
diff --git a/devel/p5-IO-Async/pkg-plist b/devel/p5-IO-Async/pkg-plist
new file mode 100644
index 000000000000..6e26a805c80b
--- /dev/null
+++ b/devel/p5-IO-Async/pkg-plist
@@ -0,0 +1,16 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/IO/Async/.packlist
+%%SITE_PERL%%/IO/Async.pod
+%%SITE_PERL%%/IO/Async/Buffer.pm
+%%SITE_PERL%%/IO/Async/ChildManager.pm
+%%SITE_PERL%%/IO/Async/Notifier.pm
+%%SITE_PERL%%/IO/Async/Set.pm
+%%SITE_PERL%%/IO/Async/Set/GMainLoop.pm
+%%SITE_PERL%%/IO/Async/Set/IO_Poll.pm
+%%SITE_PERL%%/IO/Async/Set/Select.pm
+%%SITE_PERL%%/IO/Async/SignalProxy.pm
+@dirrmtry %%SITE_PERL%%/mach/auto/IO/Async
+@dirrmtry %%SITE_PERL%%/mach/auto/IO
+@dirrmtry %%SITE_PERL%%/IO/Async/Set
+@dirrmtry %%SITE_PERL%%/IO/Async
+@dirrmtry %%SITE_PERL%%/IO