aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2014-06-15 16:39:47 +0800
committermiwi <miwi@FreeBSD.org>2014-06-15 16:39:47 +0800
commit35c83fcb7d7cd07b2feea2088f17d797a45adf74 (patch)
tree0496333796db218076a8a23cd1ee7b3e1e880960 /devel
parentdcf9c26dc35f71cb3678dc932b73b450d2f3a3b2 (diff)
downloadfreebsd-ports-gnome-35c83fcb7d7cd07b2feea2088f17d797a45adf74.tar.gz
freebsd-ports-gnome-35c83fcb7d7cd07b2feea2088f17d797a45adf74.tar.zst
freebsd-ports-gnome-35c83fcb7d7cd07b2feea2088f17d797a45adf74.zip
Plan is a Python package for writing and deploying cron jobs. Plan will
convert Python code to cron syntax. You can easily manage your cron jobs with Plan like a charm. It is designed for elegancy and writing cron jobs with as little amount of code as possible. It's extensible but comes with serveral good useful job types out of the box. WWW: https://github.com/fengsp/plan PR: ports/190948 Submitted by: Bartek Rutkowski <ports@robakdesign.com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-plan/Makefile21
-rw-r--r--devel/py-plan/distinfo2
-rw-r--r--devel/py-plan/pkg-descr7
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 317c87ea1944..806c8040a545 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3752,6 +3752,7 @@
SUBDIR += py-phpserialize
SUBDIR += py-pika
SUBDIR += py-pip
+ SUBDIR += py-plan
SUBDIR += py-plex
SUBDIR += py-ply
SUBDIR += py-polib
diff --git a/devel/py-plan/Makefile b/devel/py-plan/Makefile
new file mode 100644
index 000000000000..9fb7100c50d4
--- /dev/null
+++ b/devel/py-plan/Makefile
@@ -0,0 +1,21 @@
+# Created by: Bartek Rutkowski <ports@robakdesign.com>
+# $FreeBSD$
+
+PORTNAME= plan
+PORTVERSION= 0.1
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@robakdesign.com
+COMMENT= Python package for writing and deploying cron jobs
+
+LICENSE= BSD3CLAUSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}click>=1.1:${PORTSDIR}/devel/py-click
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/py-plan/distinfo b/devel/py-plan/distinfo
new file mode 100644
index 000000000000..fffdd728f9ae
--- /dev/null
+++ b/devel/py-plan/distinfo
@@ -0,0 +1,2 @@
+SHA256 (plan-0.1.tar.gz) = 2fb3a1811661f3f24dd80fcf41b1d88a02dbb069392a7d8ddbb9fccb1ba1d37b
+SIZE (plan-0.1.tar.gz) = 14140
diff --git a/devel/py-plan/pkg-descr b/devel/py-plan/pkg-descr
new file mode 100644
index 000000000000..4566cfb8d45e
--- /dev/null
+++ b/devel/py-plan/pkg-descr
@@ -0,0 +1,7 @@
+Plan is a Python package for writing and deploying cron jobs. Plan will
+convert Python code to cron syntax. You can easily manage your cron jobs
+with Plan like a charm. It is designed for elegancy and writing cron jobs
+with as little amount of code as possible. It's extensible but comes with
+serveral good useful job types out of the box.
+
+WWW: https://github.com/fengsp/plan