aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2005-09-30 02:15:23 +0800
committergarga <garga@FreeBSD.org>2005-09-30 02:15:23 +0800
commit37ee11a71e5396f9de20793125352f06f6295d13 (patch)
tree3949419dca3e49d567af1c78b430765188a9cb30 /devel
parentf6963e5c7ebea83d0b143d67073420d53b15009f (diff)
downloadfreebsd-ports-gnome-37ee11a71e5396f9de20793125352f06f6295d13.tar.gz
freebsd-ports-gnome-37ee11a71e5396f9de20793125352f06f6295d13.tar.zst
freebsd-ports-gnome-37ee11a71e5396f9de20793125352f06f6295d13.zip
Add ruby-zoom 0.2.0, a Ruby binding to the Z39.50 Object-Orientation
Model (ZOOM). PR: ports/86213 Submitted by: Mitsuru YOSHIDA <mitsuru@riken.jp>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-zoom/Makefile44
-rw-r--r--devel/ruby-zoom/distinfo2
-rw-r--r--devel/ruby-zoom/files/patch-extconf.rb10
-rw-r--r--devel/ruby-zoom/pkg-descr6
-rw-r--r--devel/ruby-zoom/pkg-plist15
-rw-r--r--devel/rubygem-zoom/Makefile44
-rw-r--r--devel/rubygem-zoom/distinfo2
-rw-r--r--devel/rubygem-zoom/files/patch-extconf.rb10
-rw-r--r--devel/rubygem-zoom/pkg-descr6
-rw-r--r--devel/rubygem-zoom/pkg-plist15
11 files changed, 155 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 4b5f8b112cb5..b61a0b21ae24 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1482,6 +1482,7 @@
SUBDIR += ruby-sysvipc
SUBDIR += ruby-textbuf
SUBDIR += ruby-tzfile
+ SUBDIR += ruby-zoom
SUBDIR += rubygem-activesupport
SUBDIR += rubygem-rake
SUBDIR += rubygem-rgl
diff --git a/devel/ruby-zoom/Makefile b/devel/ruby-zoom/Makefile
new file mode 100644
index 000000000000..100cd39a5f91
--- /dev/null
+++ b/devel/ruby-zoom/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby-zoom
+# Date created: 16 September 2005
+# Whom: Mitsuru YOSHIDA <mitsuru@riken.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zoom
+PORTVERSION= 0.2.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/5601/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= mitsuru@riken.jp
+COMMENT= A Ruby binding to the Z39.50 Object-Orientation Model (ZOOM)
+
+LIB_DEPENDS= yaz.2:${PORTSDIR}/net/yaz
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+DOCS= ChangeLog README doc/ascii/api.txt doc/xhtml/*
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/ruby-zoom/distinfo b/devel/ruby-zoom/distinfo
new file mode 100644
index 000000000000..7c356ed88624
--- /dev/null
+++ b/devel/ruby-zoom/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/ruby-zoom-0.2.0.tar.gz) = ef85f8aa8a78666fdd46c95d91a23e7c
+SIZE (ruby/ruby-zoom-0.2.0.tar.gz) = 24168
diff --git a/devel/ruby-zoom/files/patch-extconf.rb b/devel/ruby-zoom/files/patch-extconf.rb
new file mode 100644
index 000000000000..9f06853a3e5c
--- /dev/null
+++ b/devel/ruby-zoom/files/patch-extconf.rb
@@ -0,0 +1,10 @@
+--- extconf.rb.org Fri Sep 2 20:18:20 2005
++++ extconf.rb Fri Sep 2 20:38:41 2005
+@@ -9,6 +9,6 @@
+ err "Yaz ZOOM header not available" unless have_header("yaz/zoom.h")
+
+ $CFLAGS << " #{`yaz-config --cflags`} "
+-$LDFLAGS << " #{`yaz-config --libs`} "
++$LDFLAGS << " #{`yaz-config --libs`}".chomp
+
+ create_makefile("zoom", "src")
diff --git a/devel/ruby-zoom/pkg-descr b/devel/ruby-zoom/pkg-descr
new file mode 100644
index 000000000000..f842f5d84c06
--- /dev/null
+++ b/devel/ruby-zoom/pkg-descr
@@ -0,0 +1,6 @@
+Ruby/ZOOM provides a Ruby binding to the Z39.50 Object-Orientation Model (ZOOM),
+an abstract object-oriented programming interface to a subset of the services
+specified by the Z39.50 standard, also known as the international standard
+ISO 23950.
+
+WWW: http://ruby-zoom.rubyforge.org/
diff --git a/devel/ruby-zoom/pkg-plist b/devel/ruby-zoom/pkg-plist
new file mode 100644
index 000000000000..b5b220a900a3
--- /dev/null
+++ b/devel/ruby-zoom/pkg-plist
@@ -0,0 +1,15 @@
+%%RUBY_SITEARCHLIBDIR%%/zoom.so
+%%RUBY_SITELIBDIR%%/marc.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api.xml
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch01.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch02.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch03.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch04.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/docbook.css
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/hello.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%
diff --git a/devel/rubygem-zoom/Makefile b/devel/rubygem-zoom/Makefile
new file mode 100644
index 000000000000..100cd39a5f91
--- /dev/null
+++ b/devel/rubygem-zoom/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: Ruby-zoom
+# Date created: 16 September 2005
+# Whom: Mitsuru YOSHIDA <mitsuru@riken.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= zoom
+PORTVERSION= 0.2.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://rubyforge.org/frs/download.php/5601/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ruby-${PORTNAME}-${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= mitsuru@riken.jp
+COMMENT= A Ruby binding to the Z39.50 Object-Orientation Model (ZOOM)
+
+LIB_DEPENDS= yaz.2:${PORTSDIR}/net/yaz
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+DOCS= ChangeLog README doc/ascii/api.txt doc/xhtml/*
+
+RUBY_REQUIRE= Ruby > 180
+
+.include <bsd.port.pre.mk>
+
+.if !defined(RUBY_PROVIDED)
+IGNORE= only works with Ruby 1.8.0 or later
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample/* ${RUBY_MODEXAMPLESDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/rubygem-zoom/distinfo b/devel/rubygem-zoom/distinfo
new file mode 100644
index 000000000000..7c356ed88624
--- /dev/null
+++ b/devel/rubygem-zoom/distinfo
@@ -0,0 +1,2 @@
+MD5 (ruby/ruby-zoom-0.2.0.tar.gz) = ef85f8aa8a78666fdd46c95d91a23e7c
+SIZE (ruby/ruby-zoom-0.2.0.tar.gz) = 24168
diff --git a/devel/rubygem-zoom/files/patch-extconf.rb b/devel/rubygem-zoom/files/patch-extconf.rb
new file mode 100644
index 000000000000..9f06853a3e5c
--- /dev/null
+++ b/devel/rubygem-zoom/files/patch-extconf.rb
@@ -0,0 +1,10 @@
+--- extconf.rb.org Fri Sep 2 20:18:20 2005
++++ extconf.rb Fri Sep 2 20:38:41 2005
+@@ -9,6 +9,6 @@
+ err "Yaz ZOOM header not available" unless have_header("yaz/zoom.h")
+
+ $CFLAGS << " #{`yaz-config --cflags`} "
+-$LDFLAGS << " #{`yaz-config --libs`} "
++$LDFLAGS << " #{`yaz-config --libs`}".chomp
+
+ create_makefile("zoom", "src")
diff --git a/devel/rubygem-zoom/pkg-descr b/devel/rubygem-zoom/pkg-descr
new file mode 100644
index 000000000000..f842f5d84c06
--- /dev/null
+++ b/devel/rubygem-zoom/pkg-descr
@@ -0,0 +1,6 @@
+Ruby/ZOOM provides a Ruby binding to the Z39.50 Object-Orientation Model (ZOOM),
+an abstract object-oriented programming interface to a subset of the services
+specified by the Z39.50 standard, also known as the international standard
+ISO 23950.
+
+WWW: http://ruby-zoom.rubyforge.org/
diff --git a/devel/rubygem-zoom/pkg-plist b/devel/rubygem-zoom/pkg-plist
new file mode 100644
index 000000000000..b5b220a900a3
--- /dev/null
+++ b/devel/rubygem-zoom/pkg-plist
@@ -0,0 +1,15 @@
+%%RUBY_SITEARCHLIBDIR%%/zoom.so
+%%RUBY_SITELIBDIR%%/marc.rb
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ChangeLog
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/README
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api.txt
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/api.xml
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch01.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch02.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch03.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/ch04.html
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/docbook.css
+%%PORTDOCS%%%%RUBY_MODDOCDIR%%/index.html
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/hello.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%