aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2009-11-09 03:46:46 +0800
committerpgj <pgj@FreeBSD.org>2009-11-09 03:46:46 +0800
commit38e716f1e3b7d28ee8dae6ec1fc58174df7a3d40 (patch)
treedb723df61888cd58baa5aca055e989ae3f7809d7 /devel
parent5a7ec836c849cb22e17608c50c0d6b84b2f1a30a (diff)
downloadfreebsd-ports-gnome-38e716f1e3b7d28ee8dae6ec1fc58174df7a3d40.tar.gz
freebsd-ports-gnome-38e716f1e3b7d28ee8dae6ec1fc58174df7a3d40.tar.zst
freebsd-ports-gnome-38e716f1e3b7d28ee8dae6ec1fc58174df7a3d40.zip
- Unbreak build.
Diffstat (limited to 'devel')
-rw-r--r--devel/lhs2TeX/Makefile2
-rw-r--r--devel/lhs2TeX/files/patch-FileNameUtils.lhs40
2 files changed, 40 insertions, 2 deletions
diff --git a/devel/lhs2TeX/Makefile b/devel/lhs2TeX/Makefile
index a7a569363d4d..5742dbaeae70 100644
--- a/devel/lhs2TeX/Makefile
+++ b/devel/lhs2TeX/Makefile
@@ -31,8 +31,6 @@ PORTDOCS= *
DATADIR=${PREFIX}/share/${PORTNAME}-${PORTVERSION}
PORTDATA= *
-BROKEN= Does not compile with GHC 6.10
-
.include <bsd.port.pre.mk>
INSTALL_TARGET= install
diff --git a/devel/lhs2TeX/files/patch-FileNameUtils.lhs b/devel/lhs2TeX/files/patch-FileNameUtils.lhs
new file mode 100644
index 000000000000..a910c6b10ae9
--- /dev/null
+++ b/devel/lhs2TeX/files/patch-FileNameUtils.lhs
@@ -0,0 +1,40 @@
+--- ./FileNameUtils.lhs.orig 2008-10-24 10:50:41.000000000 +0200
++++ ./FileNameUtils.lhs 2009-11-08 01:19:19.000000000 +0100
+@@ -13,7 +13,7 @@
+ > import System.Environment
+ > import Data.List
+ > import Control.Monad (filterM)
+-> import Control.Exception ( try, catch )
++> import Control.Exception ( try, catch, IOException )
+ > import System.FilePath
+ > import System.Info
+
+@@ -86,7 +86,7 @@
+ > d''' <- mapM descendFrom d''
+ > return (s : concat d''')
+ > )
+-> (const $ return [s])
++> ((const $ return [s])::(IOError -> IO [String]))
+
+ > expandEnvironment :: String -> IO [String]
+ > expandEnvironment s = case break (=='{') s of
+@@ -95,7 +95,7 @@
+ > (e,"") -> return [s]
+ > (e,'}':r') -> findEnvironment e s' r'
+ > where findEnvironment :: String -> String -> String -> IO [String]
+-> findEnvironment e a o = do er <- try (getEnv e)
++> findEnvironment e a o = do er <- (try (getEnv e))::(IO (Either IOException String))
+ > return $ either (const [])
+ > (map (\x -> a ++ x ++ o) . splitOn isSearchPathSeparator)
+ > er
+@@ -116,8 +116,8 @@
+ > = cs
+ > | otherwise = addTrailingPathSeparator cs
+ > t f = catch (readFile f >>= \x -> return (x,f))
+-> (\_ -> ioError $ userError $ "File `" ++ fn ++ "' not found.\n")
++> ((\_ -> ioError $ userError $ "File `" ++ fn ++ "' not found.\n")::(IOError -> IO (String,FilePath)))
+ > s [] = ioError
+ > $ userError $ "File `" ++ fn ++ "' not found in search path:\n" ++ showpath
+-> s (x:xs) = catch x (\_ -> s xs)
++> s (x:xs) = catch x ((\_ -> s xs)::(IOError -> IO (String,FilePath)))
+ > showpath = concatMap (\x -> " " ++ x ++ "\n") p