aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorvg <vg@FreeBSD.org>2015-06-20 00:35:04 +0800
committervg <vg@FreeBSD.org>2015-06-20 00:35:04 +0800
commit3a3c62135118fd73c8129a5bc7274d76e18da4cc (patch)
tree7b23dc2b4e18300937543d42cd521033bd3eebfa /devel
parent16d19f2de12fe5f1835b1bce7129ef71be850f17 (diff)
downloadfreebsd-ports-gnome-3a3c62135118fd73c8129a5bc7274d76e18da4cc.tar.gz
freebsd-ports-gnome-3a3c62135118fd73c8129a5bc7274d76e18da4cc.tar.zst
freebsd-ports-gnome-3a3c62135118fd73c8129a5bc7274d76e18da4cc.zip
New port: devel/msgpuck
MsgPuck is a simple and efficient MsgPack binary serialization library in a self-contained header file. * Can be easily incorporated into your project * Is very easy to use (see examples below) * Is fully tested and documented * Has clean and readable C source code * Is published under the very liberal license (BSD-2)
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/msgpuck/Makefile18
-rw-r--r--devel/msgpuck/distinfo2
-rw-r--r--devel/msgpuck/files/patch-CMakeLists.txt13
-rw-r--r--devel/msgpuck/pkg-descr11
-rw-r--r--devel/msgpuck/pkg-plist4
6 files changed, 49 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 92626beb50b6..aacd9d7cc0ba 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1376,6 +1376,7 @@
SUBDIR += mph
SUBDIR += mq4cpp
SUBDIR += msgpack
+ SUBDIR += msgpuck
SUBDIR += msp430-binutils
SUBDIR += msp430-gcc
SUBDIR += msp430-gdb
diff --git a/devel/msgpuck/Makefile b/devel/msgpuck/Makefile
new file mode 100644
index 000000000000..cb06200af0f0
--- /dev/null
+++ b/devel/msgpuck/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= msgpuck
+PORTVERSION= 1.0.0
+CATEGORIES= devel
+
+MAINTAINER= vg@FreeBSD.org
+COMMENT= MsgPack binary serialization library in a self-contained header
+
+LICENSE= BSD2CLAUSE
+
+USE_GITHUB= yes
+GH_PROJECT= msgpuck
+GH_ACCOUNT= tarantool
+
+USES= cmake
+
+.include <bsd.port.mk>
diff --git a/devel/msgpuck/distinfo b/devel/msgpuck/distinfo
new file mode 100644
index 000000000000..9635cdca22db
--- /dev/null
+++ b/devel/msgpuck/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tarantool-msgpuck-1.0.0_GH0.tar.gz) = f9caff62f6deb2909b7294223231556ed9332dfbc57061750f652d397f5df9ed
+SIZE (tarantool-msgpuck-1.0.0_GH0.tar.gz) = 41350
diff --git a/devel/msgpuck/files/patch-CMakeLists.txt b/devel/msgpuck/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..4c3c81815224
--- /dev/null
+++ b/devel/msgpuck/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+--- CMakeLists.txt.orig 2015-06-19 08:57:12 UTC
++++ CMakeLists.txt
+@@ -1,6 +1,10 @@
+ project(msgpuck)
+ cmake_minimum_required(VERSION 2.6)
+
++if(POLICY CMP0037)
++ cmake_policy(SET CMP0037 OLD)
++endif(POLICY CMP0037)
++
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=c99")
+ set(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O0 -pg -Wall -Wextra")
+
diff --git a/devel/msgpuck/pkg-descr b/devel/msgpuck/pkg-descr
new file mode 100644
index 000000000000..c38e051d64cd
--- /dev/null
+++ b/devel/msgpuck/pkg-descr
@@ -0,0 +1,11 @@
+MsgPuck is a simple and efficient MsgPack binary serialization library in
+a self-contained header file.
+
+* Can be easily incorporated into your project
+* Is very easy to use (see examples below)
+* Is fully tested and documented
+* Has clean and readable C source code
+* Is published under the very liberal license (BSD-2)
+
+
+WWW: https://github.com/tarantool/msgpuck
diff --git a/devel/msgpuck/pkg-plist b/devel/msgpuck/pkg-plist
new file mode 100644
index 000000000000..71115aac164b
--- /dev/null
+++ b/devel/msgpuck/pkg-plist
@@ -0,0 +1,4 @@
+include/msgpuck.h
+lib/libmsgpuck.so
+lib/libmsgpuck.so.0
+lib/libmsgpuck.so.0.1