aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorgrog <grog@FreeBSD.org>2013-02-11 13:30:00 +0800
committergrog <grog@FreeBSD.org>2013-02-11 13:30:00 +0800
commit3b80219850bf3aa06b3f23811606baaaf3fa3bc0 (patch)
tree3d9001428e92f745feee79e89385b66ef9ca08d5 /devel
parente163a70529d79a7290789433489021b7a3ac30dd (diff)
downloadfreebsd-ports-gnome-3b80219850bf3aa06b3f23811606baaaf3fa3bc0.tar.gz
freebsd-ports-gnome-3b80219850bf3aa06b3f23811606baaaf3fa3bc0.tar.zst
freebsd-ports-gnome-3b80219850bf3aa06b3f23811606baaaf3fa3bc0.zip
New port, a 6000 line replacement for getopt(3).
This is a dependency of graphics/hugin. Approved by: edwin@
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/tclap/Makefile14
-rw-r--r--devel/tclap/distinfo2
-rw-r--r--devel/tclap/pkg-descr9
-rw-r--r--devel/tclap/pkg-plist265
5 files changed, 291 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 36951b52cfe4..af2f3362f87f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4247,6 +4247,7 @@
SUBDIR += tcl-mmap
SUBDIR += tcl-signal
SUBDIR += tcl-trf
+ SUBDIR += tclap
SUBDIR += tclcheck
SUBDIR += tclcl
SUBDIR += tclgetopts
diff --git a/devel/tclap/Makefile b/devel/tclap/Makefile
new file mode 100644
index 000000000000..0d0b06ac20da
--- /dev/null
+++ b/devel/tclap/Makefile
@@ -0,0 +1,14 @@
+# $FreeBSD$
+
+PORTNAME= tclap
+PORTVERSION= 1.2.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME:L}#
+
+MAINTAINER= grog@FreeBSD.org
+COMMENT= Verbose replacement for getopt
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/tclap/distinfo b/devel/tclap/distinfo
new file mode 100644
index 000000000000..1728fb236e22
--- /dev/null
+++ b/devel/tclap/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tclap-1.2.1.tar.gz) = 9f9f0fe3719e8a89d79b6ca30cf2d16620fba3db5b9610f9b51dd2cd033deebb
+SIZE (tclap-1.2.1.tar.gz) = 442387
diff --git a/devel/tclap/pkg-descr b/devel/tclap/pkg-descr
new file mode 100644
index 000000000000..21ec65b6fb74
--- /dev/null
+++ b/devel/tclap/pkg-descr
@@ -0,0 +1,9 @@
+To quote the description:
+
+ TCLAP is a small, flexible library that provides a simple interface
+ for defining and accessing command line arguments.
+
+It seems to do everything that getopt(3) can do. It is needed here as
+a dependency for graphics/hugin.
+
+WWW: http://tclap.sourceforge.net/
diff --git a/devel/tclap/pkg-plist b/devel/tclap/pkg-plist
new file mode 100644
index 000000000000..e93aa8c62cc2
--- /dev/null
+++ b/devel/tclap/pkg-plist
@@ -0,0 +1,265 @@
+include/tclap/CmdLineInterface.h
+include/tclap/ArgException.h
+include/tclap/CmdLine.h
+include/tclap/XorHandler.h
+include/tclap/MultiArg.h
+include/tclap/UnlabeledMultiArg.h
+include/tclap/ValueArg.h
+include/tclap/UnlabeledValueArg.h
+include/tclap/Visitor.h
+include/tclap/Arg.h
+include/tclap/HelpVisitor.h
+include/tclap/SwitchArg.h
+include/tclap/MultiSwitchArg.h
+include/tclap/VersionVisitor.h
+include/tclap/IgnoreRestVisitor.h
+include/tclap/CmdLineOutput.h
+include/tclap/StdOutput.h
+include/tclap/DocBookOutput.h
+include/tclap/ZshCompletionOutput.h
+include/tclap/Constraint.h
+include/tclap/OptionalUnlabeledTracker.h
+include/tclap/ValuesConstraint.h
+include/tclap/ArgTraits.h
+include/tclap/StandardTraits.h
+lib/pkgconfig/tclap.pc
+share/doc/tclap/html/CVS/Entries
+share/doc/tclap/html/CVS/Repository
+share/doc/tclap/html/CVS/Root
+share/doc/tclap/html/Arg_8h.html
+share/doc/tclap/html/Arg_8h_source.html
+share/doc/tclap/html/ArgException_8h.html
+share/doc/tclap/html/ArgException_8h_source.html
+share/doc/tclap/html/ArgTraits_8h.html
+share/doc/tclap/html/ArgTraits_8h_source.html
+share/doc/tclap/html/classes.html
+share/doc/tclap/html/classTCLAP_1_1Arg-members.html
+share/doc/tclap/html/classTCLAP_1_1Arg.gif
+share/doc/tclap/html/classTCLAP_1_1Arg.html
+share/doc/tclap/html/classTCLAP_1_1ArgException-members.html
+share/doc/tclap/html/classTCLAP_1_1ArgException.gif
+share/doc/tclap/html/classTCLAP_1_1ArgException.html
+share/doc/tclap/html/Constraint_8h.html
+share/doc/tclap/html/classTCLAP_1_1ArgParseException-members.html
+share/doc/tclap/html/classTCLAP_1_1ArgParseException.gif
+share/doc/tclap/html/classTCLAP_1_1ArgParseException.html
+share/doc/tclap/html/classTCLAP_1_1CmdLine-members.html
+share/doc/tclap/html/classTCLAP_1_1CmdLine.gif
+share/doc/tclap/html/classTCLAP_1_1CmdLine.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineInterface-members.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineInterface.gif
+share/doc/tclap/html/classTCLAP_1_1CmdLineInterface.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineOutput-members.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineOutput.gif
+share/doc/tclap/html/classTCLAP_1_1CmdLineOutput.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineParseException-members.html
+share/doc/tclap/html/classTCLAP_1_1CmdLineParseException.gif
+share/doc/tclap/html/classTCLAP_1_1CmdLineParseException.html
+share/doc/tclap/html/classTCLAP_1_1Constraint-members.html
+share/doc/tclap/html/classTCLAP_1_1Constraint.gif
+share/doc/tclap/html/classTCLAP_1_1Constraint.html
+share/doc/tclap/html/classTCLAP_1_1DocBookOutput-members.html
+share/doc/tclap/html/classTCLAP_1_1DocBookOutput.gif
+share/doc/tclap/html/classTCLAP_1_1DocBookOutput.html
+share/doc/tclap/html/classTCLAP_1_1ExitException.html
+share/doc/tclap/html/classTCLAP_1_1ExitException-members.html
+share/doc/tclap/html/classTCLAP_1_1HelpVisitor-members.html
+share/doc/tclap/html/classTCLAP_1_1HelpVisitor.gif
+share/doc/tclap/html/classTCLAP_1_1HelpVisitor.html
+share/doc/tclap/html/classTCLAP_1_1IgnoreRestVisitor-members.html
+share/doc/tclap/html/classTCLAP_1_1IgnoreRestVisitor.gif
+share/doc/tclap/html/classTCLAP_1_1IgnoreRestVisitor.html
+share/doc/tclap/html/classTCLAP_1_1MultiArg-members.html
+share/doc/tclap/html/classTCLAP_1_1MultiArg.gif
+share/doc/tclap/html/classTCLAP_1_1MultiArg.html
+share/doc/tclap/html/classTCLAP_1_1MultiSwitchArg-members.html
+share/doc/tclap/html/classTCLAP_1_1MultiSwitchArg.gif
+share/doc/tclap/html/classTCLAP_1_1MultiSwitchArg.html
+share/doc/tclap/html/classTCLAP_1_1OptionalUnlabeledTracker-members.html
+share/doc/tclap/html/classTCLAP_1_1OptionalUnlabeledTracker.html
+share/doc/tclap/html/classTCLAP_1_1SpecificationException-members.html
+share/doc/tclap/html/classTCLAP_1_1SpecificationException.gif
+share/doc/tclap/html/classTCLAP_1_1SpecificationException.html
+share/doc/tclap/html/classTCLAP_1_1StdOutput-members.html
+share/doc/tclap/html/classTCLAP_1_1StdOutput.gif
+share/doc/tclap/html/classTCLAP_1_1StdOutput.html
+share/doc/tclap/html/CmdLine_8h.html
+share/doc/tclap/html/classTCLAP_1_1SwitchArg-members.html
+share/doc/tclap/html/classTCLAP_1_1SwitchArg.gif
+share/doc/tclap/html/classTCLAP_1_1SwitchArg.html
+share/doc/tclap/html/classTCLAP_1_1UnlabeledMultiArg-members.html
+share/doc/tclap/html/classTCLAP_1_1UnlabeledMultiArg.gif
+share/doc/tclap/html/classTCLAP_1_1UnlabeledMultiArg.html
+share/doc/tclap/html/classTCLAP_1_1UnlabeledValueArg-members.html
+share/doc/tclap/html/classTCLAP_1_1UnlabeledValueArg.gif
+share/doc/tclap/html/classTCLAP_1_1UnlabeledValueArg.html
+share/doc/tclap/html/classTCLAP_1_1ValueArg-members.html
+share/doc/tclap/html/classTCLAP_1_1ValueArg.gif
+share/doc/tclap/html/classTCLAP_1_1ValueArg.html
+share/doc/tclap/html/classTCLAP_1_1ValuesConstraint-members.html
+share/doc/tclap/html/classTCLAP_1_1ValuesConstraint.gif
+share/doc/tclap/html/classTCLAP_1_1ValuesConstraint.html
+share/doc/tclap/html/classTCLAP_1_1VersionVisitor-members.html
+share/doc/tclap/html/classTCLAP_1_1VersionVisitor.gif
+share/doc/tclap/html/classTCLAP_1_1VersionVisitor.html
+share/doc/tclap/html/classTCLAP_1_1Visitor-members.html
+share/doc/tclap/html/classTCLAP_1_1Visitor.gif
+share/doc/tclap/html/classTCLAP_1_1Visitor.html
+share/doc/tclap/html/classTCLAP_1_1XorHandler-members.html
+share/doc/tclap/html/CmdLine_8h_source.html
+share/doc/tclap/html/classTCLAP_1_1XorHandler.html
+share/doc/tclap/html/classTCLAP_1_1ZshCompletionOutput-members.html
+share/doc/tclap/html/classTCLAP_1_1ZshCompletionOutput.gif
+share/doc/tclap/html/classTCLAP_1_1ZshCompletionOutput.html
+share/doc/tclap/html/CmdLineInterface_8h.html
+share/doc/tclap/html/CmdLineInterface_8h_source.html
+share/doc/tclap/html/CmdLineOutput_8h.html
+share/doc/tclap/html/CmdLineOutput_8h_source.html
+share/doc/tclap/html/Constraint_8h_source.html
+share/doc/tclap/html/DocBookOutput_8h.html
+share/doc/tclap/html/DocBookOutput_8h_source.html
+share/doc/tclap/html/doxygen.css
+share/doc/tclap/html/doxygen.png
+share/doc/tclap/html/files.html
+share/doc/tclap/html/functions.html
+share/doc/tclap/html/functions_0x61.html
+share/doc/tclap/html/functions_0x62.html
+share/doc/tclap/html/functions_0x63.html
+share/doc/tclap/html/functions_0x64.html
+share/doc/tclap/html/functions_0x65.html
+share/doc/tclap/html/functions_0x66.html
+share/doc/tclap/html/functions_0x67.html
+share/doc/tclap/html/functions_0x68.html
+share/doc/tclap/html/functions_0x69.html
+share/doc/tclap/html/functions_0x6c.html
+share/doc/tclap/html/functions_0x6d.html
+share/doc/tclap/html/functions_0x6e.html
+share/doc/tclap/html/functions_0x6f.html
+share/doc/tclap/html/functions_0x70.html
+share/doc/tclap/html/functions_0x71.html
+share/doc/tclap/html/functions_0x72.html
+share/doc/tclap/html/functions_0x73.html
+share/doc/tclap/html/functions_0x74.html
+share/doc/tclap/html/functions_0x75.html
+share/doc/tclap/html/functions_0x76.html
+share/doc/tclap/html/functions_0x77.html
+share/doc/tclap/html/functions_0x78.html
+share/doc/tclap/html/functions_0x7a.html
+share/doc/tclap/html/functions_0x7e.html
+share/doc/tclap/html/functions_func.html
+share/doc/tclap/html/functions_func_0x61.html
+share/doc/tclap/html/functions_func_0x62.html
+share/doc/tclap/html/functions_func_0x63.html
+share/doc/tclap/html/functions_func_0x64.html
+share/doc/tclap/html/functions_func_0x65.html
+share/doc/tclap/html/functions_func_0x66.html
+share/doc/tclap/html/functions_func_0x67.html
+share/doc/tclap/html/functions_func_0x68.html
+share/doc/tclap/html/functions_func_0x69.html
+share/doc/tclap/html/functions_func_0x6c.html
+share/doc/tclap/html/functions_func_0x6d.html
+share/doc/tclap/html/functions_func_0x6e.html
+share/doc/tclap/html/functions_func_0x6f.html
+share/doc/tclap/html/functions_func_0x70.html
+share/doc/tclap/html/functions_func_0x71.html
+share/doc/tclap/html/functions_func_0x72.html
+share/doc/tclap/html/functions_func_0x73.html
+share/doc/tclap/html/functions_func_0x74.html
+share/doc/tclap/html/functions_func_0x75.html
+share/doc/tclap/html/functions_func_0x76.html
+share/doc/tclap/html/functions_func_0x77.html
+share/doc/tclap/html/functions_func_0x78.html
+share/doc/tclap/html/functions_func_0x7a.html
+share/doc/tclap/html/functions_func_0x7e.html
+share/doc/tclap/html/functions_type.html
+share/doc/tclap/html/functions_vars.html
+share/doc/tclap/html/globals.html
+share/doc/tclap/html/globals_defs.html
+share/doc/tclap/html/globals_type.html
+share/doc/tclap/html/HelpVisitor_8h.html
+share/doc/tclap/html/HelpVisitor_8h_source.html
+share/doc/tclap/html/hierarchy.html
+share/doc/tclap/html/IgnoreRestVisitor_8h.html
+share/doc/tclap/html/IgnoreRestVisitor_8h_source.html
+share/doc/tclap/html/index.html
+share/doc/tclap/html/MultiArg_8h.html
+share/doc/tclap/html/MultiArg_8h_source.html
+share/doc/tclap/html/MultiSwitchArg_8h.html
+share/doc/tclap/html/namespaces.html
+share/doc/tclap/html/MultiSwitchArg_8h_source.html
+share/doc/tclap/html/namespacemembers.html
+share/doc/tclap/html/namespacemembers_func.html
+share/doc/tclap/html/namespacemembers_type.html
+share/doc/tclap/html/namespaceTCLAP.html
+share/doc/tclap/html/OptionalUnlabeledTracker_8h.html
+share/doc/tclap/html/OptionalUnlabeledTracker_8h_source.html
+share/doc/tclap/html/StandardTraits_8h.html
+share/doc/tclap/html/StandardTraits_8h_source.html
+share/doc/tclap/html/StdOutput_8h.html
+share/doc/tclap/html/StdOutput_8h_source.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits.html
+share/doc/tclap/html/tab_b.gif
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01bool_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01bool_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01char_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01char_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01double_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01double_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01float_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01float_01_4.html
+share/doc/tclap/html/structTCLAP_1_1StringLike-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01int_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01int_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01long_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01long_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01short_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01short_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01std_1_1string_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01std_1_1string_01_4.html
+share/doc/tclap/html/SwitchArg_8h.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01char_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01char_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01int_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01int_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01long_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01long_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01short_01_4-members.html
+share/doc/tclap/html/tab_l.gif
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01unsigned_01short_01_4.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01wchar__t_01_4-members.html
+share/doc/tclap/html/structTCLAP_1_1ArgTraits_3_01wchar__t_01_4.html
+share/doc/tclap/html/structTCLAP_1_1StringLike.html
+share/doc/tclap/html/structTCLAP_1_1StringLikeTrait-members.html
+share/doc/tclap/html/structTCLAP_1_1StringLikeTrait.html
+share/doc/tclap/html/structTCLAP_1_1ValueLike-members.html
+share/doc/tclap/html/structTCLAP_1_1ValueLike.html
+share/doc/tclap/html/structTCLAP_1_1ValueLikeTrait-members.html
+share/doc/tclap/html/structTCLAP_1_1ValueLikeTrait.html
+share/doc/tclap/html/SwitchArg_8h_source.html
+share/doc/tclap/html/tab_r.gif
+share/doc/tclap/html/tabs.css
+share/doc/tclap/html/UnlabeledMultiArg_8h.html
+share/doc/tclap/html/UnlabeledMultiArg_8h_source.html
+share/doc/tclap/html/UnlabeledValueArg_8h.html
+share/doc/tclap/html/UnlabeledValueArg_8h_source.html
+share/doc/tclap/html/ValueArg_8h.html
+share/doc/tclap/html/ValueArg_8h_source.html
+share/doc/tclap/html/ValuesConstraint_8h.html
+share/doc/tclap/html/ValuesConstraint_8h_source.html
+share/doc/tclap/html/VersionVisitor_8h.html
+share/doc/tclap/html/VersionVisitor_8h_source.html
+share/doc/tclap/html/Visitor_8h.html
+share/doc/tclap/html/Visitor_8h_source.html
+share/doc/tclap/html/XorHandler_8h.html
+share/doc/tclap/html/XorHandler_8h_source.html
+share/doc/tclap/html/ZshCompletionOutput_8h.html
+share/doc/tclap/html/annotated.html
+share/doc/tclap/html/ZshCompletionOutput_8h_source.html
+share/doc/tclap/index.html
+share/doc/tclap/manual.html
+share/doc/tclap/style.css
+@dirrm include/tclap
+@dirrm share/doc/tclap/html/CVS
+@dirrm share/doc/tclap/html
+@dirrm share/doc/tclap