aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwg <wg@FreeBSD.org>2014-07-29 06:53:10 +0800
committerwg <wg@FreeBSD.org>2014-07-29 06:53:10 +0800
commit3c85bd315df366206e3fdba9fc70031df2c426f8 (patch)
treeedce43e97893751ea43b1904b335cea7991698a6 /devel
parentfc838ff81629b39ed33356ea0651923dff7941c6 (diff)
downloadfreebsd-ports-gnome-3c85bd315df366206e3fdba9fc70031df2c426f8.tar.gz
freebsd-ports-gnome-3c85bd315df366206e3fdba9fc70031df2c426f8.tar.zst
freebsd-ports-gnome-3c85bd315df366206e3fdba9fc70031df2c426f8.zip
devel/libserialport
The sigrok project aims at creating a portable, cross-platform, Free/Libre/Open-Source signal analysis software suite that supports various device types, such as logic analyzers, MSOs, oscilloscopes, multimeters, LCR meters, sound level meters, thermometers, hygrometers, anemometers, light meters, DAQs, dataloggers, function generators, spectrum analyzers, power supplies, GPIB interfaces, and more. WWW: http://sigrok.org/ PR: 192151 Submitted by: uffe uffe org
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libserialport/Makefile21
-rw-r--r--devel/libserialport/distinfo2
-rw-r--r--devel/libserialport/pkg-descr9
-rw-r--r--devel/libserialport/pkg-plist6
5 files changed, 39 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a13f91b6ae8f..aed107461497 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1106,6 +1106,7 @@
SUBDIR += librest
SUBDIR += libruin
SUBDIR += libs11n
+ SUBDIR += libserialport
SUBDIR += libserver
SUBDIR += libshbuf
SUBDIR += libshhmsg
diff --git a/devel/libserialport/Makefile b/devel/libserialport/Makefile
new file mode 100644
index 000000000000..db7b9dac7dca
--- /dev/null
+++ b/devel/libserialport/Makefile
@@ -0,0 +1,21 @@
+# Created by: Uffe Jakobsen <uffe@uffe.org>
+# $FreeBSD$
+
+PORTNAME= libserialport
+PORTVERSION= 0.1.0
+CATEGORIES= devel
+MASTER_SITES= http://sigrok.org/download/source/libserialport/
+
+MAINTAINER= uffe@uffe.org
+COMMENT= Framework for hardware logic analyzers, serial port support library
+
+LICENSE= LGPL3
+
+USE_LDCONFIG= yes
+USES= gmake libtool pathfix pkgconfig
+
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
+MAKE_JOBS_UNSAFE= yes
+
+.include <bsd.port.mk>
diff --git a/devel/libserialport/distinfo b/devel/libserialport/distinfo
new file mode 100644
index 000000000000..07b5cca27d38
--- /dev/null
+++ b/devel/libserialport/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libserialport-0.1.0.tar.gz) = ec905bd64bd8b82234b68a5eded5fd79b67704fe0cd73bf092666b9679a319af
+SIZE (libserialport-0.1.0.tar.gz) = 382395
diff --git a/devel/libserialport/pkg-descr b/devel/libserialport/pkg-descr
new file mode 100644
index 000000000000..9c36a395dda8
--- /dev/null
+++ b/devel/libserialport/pkg-descr
@@ -0,0 +1,9 @@
+The sigrok project aims at creating a portable, cross-platform,
+Free/Libre/Open-Source signal analysis software suite that supports
+various device types, such as logic analyzers, MSOs, oscilloscopes,
+multimeters, LCR meters, sound level meters, thermometers,
+hygrometers, anemometers, light meters, DAQs, dataloggers,
+function generators, spectrum analyzers, power supplies,
+GPIB interfaces, and more.
+
+WWW: http://sigrok.org/
diff --git a/devel/libserialport/pkg-plist b/devel/libserialport/pkg-plist
new file mode 100644
index 000000000000..6d29591b3905
--- /dev/null
+++ b/devel/libserialport/pkg-plist
@@ -0,0 +1,6 @@
+include/libserialport.h
+lib/libserialport.a
+lib/libserialport.so
+lib/libserialport.so.0
+lib/libserialport.so.0.0.0
+libdata/pkgconfig/libserialport.pc