aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2001-12-09 04:48:11 +0800
committerijliao <ijliao@FreeBSD.org>2001-12-09 04:48:11 +0800
commit3d292ecfd10352bb761e7ded28c382e8066b5299 (patch)
tree39a3e8edc70634a4a50b41d15b23f0d7df52d2d4 /devel
parente4a66a7592848afdc5823994b61109ef9b18cde2 (diff)
downloadfreebsd-ports-gnome-3d292ecfd10352bb761e7ded28c382e8066b5299.tar.gz
freebsd-ports-gnome-3d292ecfd10352bb761e7ded28c382e8066b5299.tar.zst
freebsd-ports-gnome-3d292ecfd10352bb761e7ded28c382e8066b5299.zip
upgrade to 5.2.12
PR: 32610 Submitted by: Ports Fury
Diffstat (limited to 'devel')
-rw-r--r--devel/autogen/Makefile15
-rw-r--r--devel/autogen/distinfo2
-rw-r--r--devel/autogen/files/patch-config:ltmain.sh25
-rw-r--r--devel/autogen/files/patch-snprintfv:config:ltmain.sh25
-rw-r--r--devel/autogen/pkg-plist3
5 files changed, 58 insertions, 12 deletions
diff --git a/devel/autogen/Makefile b/devel/autogen/Makefile
index f2dd6e72d813..8b62ee3760a1 100644
--- a/devel/autogen/Makefile
+++ b/devel/autogen/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= autogen
-PORTVERSION= 5.2.11
+PORTVERSION= 5.2.12
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -18,18 +18,17 @@ BUILD_DEPENDS= guile:${PORTSDIR}/lang/guile
LIB_DEPENDS= guile.9:${PORTSDIR}/lang/guile
USE_GMAKE= yes
-USE_LIBTOOL= yes
-LIBTOOLFILES= configure snprintfv/configure
-CONFIGURE_TARGET= # none
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
INSTALLS_SHLIB= yes
MAN1= autogen.1 columns.1 getdefs.1
pre-patch:
+ @${PERL} -pi -e 's|regcomp=no|regcomp=yes|g' ${WRKSRC}/configure
@${PERL} -pi -e 's|values.h ||g' ${WRKSRC}/snprintfv/configure
-
-pre-build:
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}/libtool
- @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}/snprintfv/libtool
+ @${PERL} -pi -e 's|#include "proto.h"||g' ${WRKSRC}/getdefs/getdefs.h
.include <bsd.port.mk>
diff --git a/devel/autogen/distinfo b/devel/autogen/distinfo
index 6a821df56e92..bab2ec554c33 100644
--- a/devel/autogen/distinfo
+++ b/devel/autogen/distinfo
@@ -1 +1 @@
-MD5 (autogen-5.2.11.tar.gz) = 42b2c62182dff09b207f2ece92c9be05
+MD5 (autogen-5.2.12.tar.gz) = 980d1b028bf2e21f017688f48dff9aed
diff --git a/devel/autogen/files/patch-config:ltmain.sh b/devel/autogen/files/patch-config:ltmain.sh
new file mode 100644
index 000000000000..f6c41c518fa4
--- /dev/null
+++ b/devel/autogen/files/patch-config:ltmain.sh
@@ -0,0 +1,25 @@
+--- config/ltmain.sh.orig Mon Sep 3 18:24:41 2001
++++ config/ltmain.sh Thu Dec 6 03:24:42 2001
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/autogen/files/patch-snprintfv:config:ltmain.sh b/devel/autogen/files/patch-snprintfv:config:ltmain.sh
new file mode 100644
index 000000000000..fcecce56e3a5
--- /dev/null
+++ b/devel/autogen/files/patch-snprintfv:config:ltmain.sh
@@ -0,0 +1,25 @@
+--- snprintfv/config/ltmain.sh.orig Mon Sep 3 18:24:41 2001
++++ snprintfv/config/ltmain.sh Thu Dec 6 03:25:35 2001
+@@ -2408,6 +2408,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test $build_libtool_need_lc = "yes"; then
+@@ -4175,10 +4178,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/autogen/pkg-plist b/devel/autogen/pkg-plist
index df2e1a6fdb88..e264fe0cd1b8 100644
--- a/devel/autogen/pkg-plist
+++ b/devel/autogen/pkg-plist
@@ -10,15 +10,12 @@ info/snprintfv.info
@exec install-info %D/info/autogen.info %D/info/dir
@exec install-info %D/info/snprintfv.info %D/info/dir
lib/libguileopts.a
-lib/libguileopts.la
lib/libguileopts.so
lib/libguileopts.so.0
lib/libopts.a
-lib/libopts.la
lib/libopts.so
lib/libopts.so.11
lib/libsnprintfv.a
-lib/libsnprintfv.la
lib/libsnprintfv.so
lib/libsnprintfv.so.1
share/aclocal/autoopts.m4