aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2008-10-14 03:49:50 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2008-10-14 03:49:50 +0800
commit3d3b2bc6c23410be2c41912db3a1d083894fca73 (patch)
tree16acae2850ae9986bc2ff630e196fefefd7f53c8 /devel
parent133b7380fdf66841bb345ee183ef54f5907758f8 (diff)
downloadfreebsd-ports-gnome-3d3b2bc6c23410be2c41912db3a1d083894fca73.tar.gz
freebsd-ports-gnome-3d3b2bc6c23410be2c41912db3a1d083894fca73.tar.zst
freebsd-ports-gnome-3d3b2bc6c23410be2c41912db3a1d083894fca73.zip
The Portable Coroutine Library (PCL) implements the low level
functionality for coroutines. For a definition of the term coroutine see The Art of Computer Programming by Donald E. Knuth. Coroutines are a very simple cooperative multitasking environment where the switch from one task to another is done explicitly by a function call. WWW: http://www.xmailserver.org/libpcl.html PR: 128066 Submitted by: Manuel Giraud <manuel dot giraud at gmail dot com>
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pcl/Makefile25
-rw-r--r--devel/pcl/distinfo3
-rw-r--r--devel/pcl/pkg-descr8
-rw-r--r--devel/pcl/pkg-plist5
5 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index b45fa225d589..1276ab89ad26 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1882,6 +1882,7 @@
SUBDIR += pas2dox
SUBDIR += patch
SUBDIR += pccts
+ SUBDIR += pcl
SUBDIR += pcre
SUBDIR += pcre++
SUBDIR += pcsc-lite
diff --git a/devel/pcl/Makefile b/devel/pcl/Makefile
new file mode 100644
index 000000000000..1036cee81972
--- /dev/null
+++ b/devel/pcl/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: pcl
+# Date Created: 13 Oct 2008
+# Whom: Manuel Giraud <manuel.giraud@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pcl
+PORTVERSION= 1.6
+CATEGORIES= devel
+MASTER_SITES= http://www.xmailserver.org/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= manuel.giraud@gmail.com
+COMMENT= Portable Coroutine Library
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+
+MAN3= pcl.3
+
+WRKSRC= ${WRKDIR}/lib${PORTNAME}-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/pcl/distinfo b/devel/pcl/distinfo
new file mode 100644
index 000000000000..51a2a6745753
--- /dev/null
+++ b/devel/pcl/distinfo
@@ -0,0 +1,3 @@
+MD5 (pcl-1.6.tar.gz) = 67f63b02e94ab1775f26bc5463817f09
+SHA256 (pcl-1.6.tar.gz) = 556834057845ad4413e9e2b629d559b431001ded40d64f607fdeaf4a7b570602
+SIZE (pcl-1.6.tar.gz) = 335028
diff --git a/devel/pcl/pkg-descr b/devel/pcl/pkg-descr
new file mode 100644
index 000000000000..9e222cf93b4d
--- /dev/null
+++ b/devel/pcl/pkg-descr
@@ -0,0 +1,8 @@
+The Portable Coroutine Library (PCL) implements the low level
+functionality for coroutines. For a definition of the term coroutine
+see The Art of Computer Programming by Donald E. Knuth. Coroutines
+are a very simple cooperative multitasking environment where the
+switch from one task to another is done explicitly by a function
+call.
+
+WWW: http://www.xmailserver.org/libpcl.html
diff --git a/devel/pcl/pkg-plist b/devel/pcl/pkg-plist
new file mode 100644
index 000000000000..03dbbad791b0
--- /dev/null
+++ b/devel/pcl/pkg-plist
@@ -0,0 +1,5 @@
+include/pcl.h
+lib/libpcl.a
+lib/libpcl.la
+lib/libpcl.so
+lib/libpcl.so.1