aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-05-06 07:08:40 +0800
committerkwm <kwm@FreeBSD.org>2013-05-06 07:08:40 +0800
commit3e4a8fdb5782c5c44d3ff7a909095a69ceb79004 (patch)
tree7c95287efb0f66f8b1f7ab7d82acfd95dc814df4 /devel
parent7d866449ab60b14b460d03dda69c44d3439a22e2 (diff)
downloadfreebsd-ports-gnome-3e4a8fdb5782c5c44d3ff7a909095a69ceb79004.tar.gz
freebsd-ports-gnome-3e4a8fdb5782c5c44d3ff7a909095a69ceb79004.tar.zst
freebsd-ports-gnome-3e4a8fdb5782c5c44d3ff7a909095a69ceb79004.zip
Update header.
Use USES=pathfix and add pkgconfig. Convert to OptionsNG. Add patch to fix the build with glib 2.36.x Obtained by: GNOME stage repo
Diffstat (limited to 'devel')
-rw-r--r--devel/goffice/Makefile22
-rw-r--r--devel/goffice/files/patch-configure11
2 files changed, 23 insertions, 10 deletions
diff --git a/devel/goffice/Makefile b/devel/goffice/Makefile
index 74feefa1719f..ce8f213b8a04 100644
--- a/devel/goffice/Makefile
+++ b/devel/goffice/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: goffice
-# Date created: 07 June 2005
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports-stable/devel/goffice/Makefile,v 1.3 2010/06/29 10:56:38 kwm Exp $
+# $MCom: ports/trunk/devel/goffice/Makefile 17268 2013-04-01 05:13:11Z marcus $
#
# !!! When updating goffice, don't forget to update pkg-plist in:
-# math/gnumeric science/gchemutils
+# science/gchemutils
PORTNAME= goffice
PORTVERSION= 0.8.17
@@ -20,12 +17,12 @@ COMMENT= GLib/GTK+ set of document centric objects and utilities
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= pcre.3:${PORTSDIR}/devel/pcre
+LIB_DEPENDS= pcre:${PORTSDIR}/devel/pcre
USE_XZ= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack intlhack gtk20 libgsf ltverhack
-USES= gettext
+USE_GNOME= gnomeprefix intlhack gtk20 libgsf ltverhack
+USES= gettext pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
@@ -35,7 +32,12 @@ PLIST_SUB= VERSION=${PORTVERSION} \
MAKE_JOBS_SAFE= yes
-.if !defined(WITHOUT_GCONF)
+OPTIONS_DEFINE= GCONF
+OPTIONS_DEAFULT=GCONF
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGCONF}
USE_GNOME+= gconf2
.else
CONFIGURE_ARGS+=--with-config-backend=keyfile
diff --git a/devel/goffice/files/patch-configure b/devel/goffice/files/patch-configure
new file mode 100644
index 000000000000..353df3a8c29f
--- /dev/null
+++ b/devel/goffice/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2012-06-04 20:59:55.000000000 +0200
++++ configure 2012-06-04 21:00:30.000000000 +0200
+@@ -15161,7 +15161,7 @@
+ $as_echo_n "checking for G_REGEX_ERROR_STRAY_BACKSLASH... " >&6; }
+ cat confdefs.h - <<_ACEOF >conftest.$ac_ext
+ /* end confdefs.h. */
+-#include <glib/gregex.h>
++#include <glib.h>
+ int
+ main ()
+ {