aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-11-30 14:13:34 +0800
committerlinimon <linimon@FreeBSD.org>2017-11-30 14:13:34 +0800
commit3e6feb882b8ecd82ccb42e65f86b0f20c69688cc (patch)
tree10dd7508accfa6a3ffc8e631ba63a22cc2fdeb6b /devel
parent2c3118177acad05f016f169cb3102633c558c602 (diff)
downloadfreebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.tar.gz
freebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.tar.zst
freebsd-ports-gnome-3e6feb882b8ecd82ccb42e65f86b0f20c69688cc.zip
For ports that are marked BROKEN on armv6, and also fail to build on
armv7, mark them so. This is part two of a multipart commit to bring armv7 ports to parity with armv6. Approved by: portmgr (tier-2 blanket) Obtained from: lonesome.com -exp run
Diffstat (limited to 'devel')
-rw-r--r--devel/amd64-gcc/Makefile1
-rw-r--r--devel/arm-none-eabi-gcc492/Makefile1
-rw-r--r--devel/avro-c/Makefile1
-rw-r--r--devel/aws-sdk-cpp/Makefile1
-rw-r--r--devel/bazel/Makefile1
-rw-r--r--devel/charva/Makefile1
-rw-r--r--devel/directfb/Makefile5
-rw-r--r--devel/dmucs/Makefile1
-rw-r--r--devel/dyncall/Makefile1
-rw-r--r--devel/elfutils/Makefile1
-rw-r--r--devel/flexdock/Makefile1
-rw-r--r--devel/guile-lib/Makefile1
-rw-r--r--devel/jakarta-commons-daemon/Makefile1
-rw-r--r--devel/jna/Makefile1
-rw-r--r--devel/k8048/Makefile1
-rw-r--r--devel/kyra/Makefile1
-rw-r--r--devel/libbfd/Makefile1
-rw-r--r--devel/lpc21isp/Makefile1
-rw-r--r--devel/obby/Makefile1
-rw-r--r--devel/php-uprofiler/Makefile1
-rw-r--r--devel/py-jcc/Makefile1
-rw-r--r--devel/smv/Makefile1
-rw-r--r--devel/statcvs/Makefile1
-rw-r--r--devel/tesla/Makefile1
24 files changed, 26 insertions, 2 deletions
diff --git a/devel/amd64-gcc/Makefile b/devel/amd64-gcc/Makefile
index d3785a82d057..ab37c3d2c867 100644
--- a/devel/amd64-gcc/Makefile
+++ b/devel/amd64-gcc/Makefile
@@ -10,6 +10,7 @@ FREEBSD_EXTENSION= yes
BROKEN_aarch64= error: invalid output constraint '=a' in asm
BROKEN_armv6= fails to package
+BROKEN_armv7= fails to package
BROKEN_mips= configure: error: cannot compute suffix of object files: cannot compile
BROKEN_mips64= configure: error: cannot compute suffix of object files: cannot compile
BROKEN_powerpc64= error: invalid output constraint in asm
diff --git a/devel/arm-none-eabi-gcc492/Makefile b/devel/arm-none-eabi-gcc492/Makefile
index 636584e19302..91632ac891b3 100644
--- a/devel/arm-none-eabi-gcc492/Makefile
+++ b/devel/arm-none-eabi-gcc492/Makefile
@@ -70,6 +70,7 @@ MAKE_ARGS+= CXXFLAGS=-fbracket-depth=512
BROKEN_aarch64= fails to package
BROKEN_armv6= error: no member named 'fancy_abort' in namespace 'std::__1'; did you mean simply 'fancy_abort'?
+BROKEN_armv7= error: no member named 'fancy_abort' in namespace 'std::__1'; did you mean simply 'fancy_abort'?
BROKEN_mips= configure: error: cannot compute suffix of object files: cannot compile
BROKEN_mips64= configure: error: cannot compute suffix of object files: cannot compile
diff --git a/devel/avro-c/Makefile b/devel/avro-c/Makefile
index 913ef99b3539..446c56eaf1b0 100644
--- a/devel/avro-c/Makefile
+++ b/devel/avro-c/Makefile
@@ -17,6 +17,7 @@ LIB_DEPENDS= libjansson.so:devel/jansson \
BROKEN_aarch64= Fails to build: error: No atomic implementation
BROKEN_armv6= Fails to build: error: No atomic implementation
+BROKEN_armv7= Fails to build: error: No atomic implementation
BROKEN_mips= Fails to build: error: No atomic implementation
BROKEN_mips64= Fails to build: error: No atomic implementation
BROKEN_sparc64= Fails to build
diff --git a/devel/aws-sdk-cpp/Makefile b/devel/aws-sdk-cpp/Makefile
index 725407a5a3f2..b80f3e2baf97 100644
--- a/devel/aws-sdk-cpp/Makefile
+++ b/devel/aws-sdk-cpp/Makefile
@@ -14,6 +14,7 @@ LIB_DEPENDS= libcurl.so:ftp/curl
BROKEN_aarch64= fails to build: runaway process
BROKEN_armv6= fails to build: runaway process
+BROKEN_armv7= fails to build: runaway process
BROKEN_powerpc64= fails to build: runaway process
USE_GITHUB= yes
diff --git a/devel/bazel/Makefile b/devel/bazel/Makefile
index 6535c36ee7ee..dcc9f2e9a42f 100644
--- a/devel/bazel/Makefile
+++ b/devel/bazel/Makefile
@@ -14,6 +14,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_armv6= fails to package: cp: bazel: No such file or directory
+BROKEN_armv7= fails to package: cp: bazel: No such file or directory
BUILD_DEPENDS= bash:shells/bash \
zip:archivers/zip
diff --git a/devel/charva/Makefile b/devel/charva/Makefile
index 8a2b998408e5..6d78ddf0adef 100644
--- a/devel/charva/Makefile
+++ b/devel/charva/Makefile
@@ -15,6 +15,7 @@ BUILD_DEPENDS= gmake:devel/gmake
RUN_DEPENDS= ${JAVALIBDIR}/commons-logging.jar:java/jakarta-commons-logging
BROKEN_armv6= fails to compile: build.xml: compilation failed
+BROKEN_armv7= fails to compile: build.xml: compilation failed
OPTIONS_DEFINE= DOCS
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index c5c85ed54bd1..b2ff55db713a 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -30,6 +30,7 @@ PORTDOCS= *
BROKEN_aarch64= fails to install: armasm_memcpy.h:No such file or directory
BROKEN_armv6= fails to compile: invokes x86 assembler
+BROKEN_armv7= fails to compile: invokes x86 assembler
DIRECTFB_SHLIB= 6.0.11 # LT_BINARY.LT_AGE.LT_REVISION
DIRECTFB_BIN= ${DIRECTFB_SHLIB:R:R} # LT_BINARY
@@ -61,13 +62,13 @@ TEST_CONFIGURE_WITH= tests
.include <bsd.port.options.mk>
-.if ${ARCH} == "armv6" || ${ARCH} == "aarch64"
+.if ${ARCH} == aarch64 || ${ARCH} == armv6 || ${ARCH} == armv7
PLIST_SUB+= ARCH_ARM=""
.else
PLIST_SUB+= ARCH_ARM="@comment "
.endif
-.if ${ARCH} == "powerpc" || ${ARCH} == "powerpc64"
+.if ${ARCH} == powerpc || ${ARCH} == powerpc64
PLIST_SUB+= ARCH_POWERPC=""
.else
PLIST_SUB+= ARCH_POWERPC="@comment "
diff --git a/devel/dmucs/Makefile b/devel/dmucs/Makefile
index 79d786868919..e5ac9e05c791 100644
--- a/devel/dmucs/Makefile
+++ b/devel/dmucs/Makefile
@@ -11,6 +11,7 @@ MAINTAINER= fjoe@FreeBSD.org
COMMENT= Distributed Multi-User Compilation System (for use with distcc)
BROKEN_armv6= fails to compile: passing char * to parameter of incompatible type __builtin_va_list
+BROKEN_armv7= fails to compile: passing char * to parameter of incompatible type __builtin_va_list
BROKEN_aarch64= fails to compile: passing char * to parameter of incompatible type __builtin_va_list
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/dyncall/Makefile b/devel/dyncall/Makefile
index 9eee74044666..8b6d291ee1e7 100644
--- a/devel/dyncall/Makefile
+++ b/devel/dyncall/Makefile
@@ -14,6 +14,7 @@ COMMENT= Highly dynamic multi-platform foreign function call interface library
LICENSE= ISCL
BROKEN_armv6= fails to compile: unexpected token in operand
+BROKEN_armv7= fails to compile: unexpected token in operand
HAS_CONFIGURE= yes
diff --git a/devel/elfutils/Makefile b/devel/elfutils/Makefile
index 961256dfd485..da3427ca6c8b 100644
--- a/devel/elfutils/Makefile
+++ b/devel/elfutils/Makefile
@@ -17,6 +17,7 @@ LICENSE_FILE_LGPL3= ${WRKSRC}/COPYING-LGPLV3
BROKEN_aarch64= fails to build: fatal error: linux/uio.h: No such file or directory
BROKEN_armv6= fails to build: fails to compile i386_disasm.c
+BROKEN_armv7= fails to build: fails to compile i386_disasm.c
BROKEN_powerpc64= fails to build: error: field 'r' has incomplete type
BROKEN_sparc64= fails to build: fails to compile dwarf_begin_elf.c
diff --git a/devel/flexdock/Makefile b/devel/flexdock/Makefile
index cf491e9c6db6..5dd7d292ae69 100644
--- a/devel/flexdock/Makefile
+++ b/devel/flexdock/Makefile
@@ -10,6 +10,7 @@ MAINTAINER= makc@FreeBSD.org
COMMENT= Swing windowing and docking framework
BROKEN_armv6= fails to package: flexdock/api: No such file or directory
+BROKEN_armv7= fails to package: flexdock/api: No such file or directory
USE_ANT= yes
USE_JAVA= yes
diff --git a/devel/guile-lib/Makefile b/devel/guile-lib/Makefile
index fe260c982bc2..fc97e0056480 100644
--- a/devel/guile-lib/Makefile
+++ b/devel/guile-lib/Makefile
@@ -13,6 +13,7 @@ BUILD_DEPENDS= guile:lang/guile
RUN_DEPENDS= guile:lang/guile
BROKEN_armv6= fails to compile: stack overflow
+BROKEN_armv7= fails to compile: stack overflow
USES= gmake
GNU_CONFIGURE= yes
diff --git a/devel/jakarta-commons-daemon/Makefile b/devel/jakarta-commons-daemon/Makefile
index dcea60192c8c..1a9a5810a2ed 100644
--- a/devel/jakarta-commons-daemon/Makefile
+++ b/devel/jakarta-commons-daemon/Makefile
@@ -16,6 +16,7 @@ COMMENT= Wrapper code to start/stop a Java application as a daemon
LICENSE= APACHE20
BROKEN_armv6= fails to compile: 'jni_md.h' file not found
+BROKEN_armv7= fails to compile: 'jni_md.h' file not found
OPTIONS_DEFINE= DOCS
diff --git a/devel/jna/Makefile b/devel/jna/Makefile
index 9d40e19f883b..01512216fb7b 100644
--- a/devel/jna/Makefile
+++ b/devel/jna/Makefile
@@ -14,6 +14,7 @@ LICENSE_FILE_LGPL21+ = ${WRKSRC}/LICENSE.LGPL
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.AL
BROKEN_armv6= fails to compile: build.xml: compilation failed
+BROKEN_armv7= fails to compile: build.xml: compilation failed
USES= autoreconf:build gmake libtool
USE_ANT= yes
diff --git a/devel/k8048/Makefile b/devel/k8048/Makefile
index 687bb5d3761b..b37caa96c32e 100644
--- a/devel/k8048/Makefile
+++ b/devel/k8048/Makefile
@@ -17,6 +17,7 @@ USES= gmake
ALL_TARGET= build
BROKEN_armv6= fails to compile: invokes x86 asm
+BROKEN_armv7= fails to compile: invokes x86 asm
PLIST_FILES= bin/${PORTNAME} bin/kio ${BIN_SYMLINKS}
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index f3d49b35d8b4..a36b31c087c4 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -28,6 +28,7 @@ MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
BROKEN_aarch64= Fails to compile: error: invalid output constraint =A in asm
BROKEN_armv6= Fails to compile: error: invalid output constraint =A in asm
+BROKEN_armv7= Fails to compile: error: invalid output constraint =A in asm
do-install:
.for i in encoder spriteed
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
index 36e93ec1ed38..5b9340f28378 100644
--- a/devel/libbfd/Makefile
+++ b/devel/libbfd/Makefile
@@ -27,6 +27,7 @@ INFO= bfd
BROKEN_aarch64= Fails to configure: machine aarch64-portbld not recognized
BROKEN_armv6= Fails to configure: BFD does not support target armv6-portbld-freebsd12.0
+BROKEN_armv7= Fails to configure: BFD does not support target armv7-portbld-freebsd12.0
BROKEN_mips64= Fails to configure: BFD does not support target mips64-portbld-freebsd12.0
pre-configure:
diff --git a/devel/lpc21isp/Makefile b/devel/lpc21isp/Makefile
index 209756e19291..749b6502de13 100644
--- a/devel/lpc21isp/Makefile
+++ b/devel/lpc21isp/Makefile
@@ -13,6 +13,7 @@ COMMENT= ISP programmer tool for flashing NXP & Analog Devices ARM7 CPUs
LICENSE= LGPL3+
BROKEN_armv6= fails to compile: no member named 'nQuestionMarks' in 'ISP_ENVIRONMENT'
+BROKEN_armv7= fails to compile: no member named 'nQuestionMarks' in 'ISP_ENVIRONMENT'
USES= gmake
diff --git a/devel/obby/Makefile b/devel/obby/Makefile
index 0530b68d3483..7a2258ac6efd 100644
--- a/devel/obby/Makefile
+++ b/devel/obby/Makefile
@@ -16,6 +16,7 @@ LIB_DEPENDS= libsigc-2.0.so:devel/libsigc++20 \
libnet6.so:net/net6
BROKEN_armv6= fails to compile: no member named 'name' in 'serialise::type_name<long long>'
+BROKEN_armv7= fails to compile: no member named 'name' in 'serialise::type_name<long long>'
USES= pathfix pkgconfig libtool compiler:c++11-lang
USE_CXXSTD= c++11
diff --git a/devel/php-uprofiler/Makefile b/devel/php-uprofiler/Makefile
index 772099137d80..9da6e1dbb450 100644
--- a/devel/php-uprofiler/Makefile
+++ b/devel/php-uprofiler/Makefile
@@ -15,6 +15,7 @@ LICENSE_FILE= ${WRKSRC}/../LICENSE
BROKEN_aarch64= Does not build: invokes x86 asm
BROKEN_armv6= Does not build: invokes x86 asm
+BROKEN_armv7= Does not build: invokes x86 asm
BROKEN_mips64= Does not build: invokes x86 asm
BROKEN_powerpc64= Does not build: invokes x86 asm
BROKEN_sparc64= Does not build: invokes x86 asm
diff --git a/devel/py-jcc/Makefile b/devel/py-jcc/Makefile
index db6020a55c60..05e1c3b62d6d 100644
--- a/devel/py-jcc/Makefile
+++ b/devel/py-jcc/Makefile
@@ -15,6 +15,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
BROKEN_armv6= fails to link: /nxb-bin/usr/bin/ld: cannot find -ljava
+BROKEN_armv7= fails to link: /nxb-bin/usr/bin/ld: cannot find -ljava
USES= python
USE_PYTHON= distutils autoplist
diff --git a/devel/smv/Makefile b/devel/smv/Makefile
index 7d4eef1617cc..8f69ca19129e 100644
--- a/devel/smv/Makefile
+++ b/devel/smv/Makefile
@@ -13,6 +13,7 @@ COMMENT= Symbolic Model Verifier System for checking finite state systems
BROKEN_aarch64= fails to build: undefined reference to sbrk
BROKEN_armv6= fails to build: error: non-void function check_bdd should return a value
+BROKEN_armv7= fails to build: error: non-void function check_bdd should return a value
USE_GCC= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/statcvs/Makefile b/devel/statcvs/Makefile
index 03f28bb0db43..7a3e74ae9704 100644
--- a/devel/statcvs/Makefile
+++ b/devel/statcvs/Makefile
@@ -15,6 +15,7 @@ LICENSE= LGPL21+
LICENSE_FILE= ${WRKSRC}/etc/LICENSE
BROKEN_armv6= fails to compile: build.xml: compilation failed
+BROKEN_armv7= fails to compile: build.xml: compilation failed
USES= zip
USE_JAVA= yes
diff --git a/devel/tesla/Makefile b/devel/tesla/Makefile
index 7b1db02d772b..0174f1196091 100644
--- a/devel/tesla/Makefile
+++ b/devel/tesla/Makefile
@@ -13,6 +13,7 @@ RUN_DEPENDS= clang33:lang/clang33
LIB_DEPENDS= libprotobuf.so:devel/protobuf
BROKEN_armv6= fails to link: cmTC_8106f uses VFP register arguments, testCCompiler.c.o does not
+BROKEN_armv7= fails to link: cmTC_8106f uses VFP register arguments, testCCompiler.c.o does not
SHEBANG_FILES= scripts/highlight-transitions