aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2016-09-27 14:47:11 +0800
committerwen <wen@FreeBSD.org>2016-09-27 14:47:11 +0800
commit4318a2f29c6efff6d5eb2a8d88fbb5266afacdff (patch)
tree743734ac11b0b4caa212dedca24f013e004f4d11 /devel
parent1378fed6189428f0c6fcc3ef75b431147d2e4d70 (diff)
downloadfreebsd-ports-gnome-4318a2f29c6efff6d5eb2a8d88fbb5266afacdff.tar.gz
freebsd-ports-gnome-4318a2f29c6efff6d5eb2a8d88fbb5266afacdff.tar.zst
freebsd-ports-gnome-4318a2f29c6efff6d5eb2a8d88fbb5266afacdff.zip
Loading this plugin causes your tests to fail if there any
warnings while they run. Each warning generates a new failing test and the warning content is outputted via diag. This module uses $SIG{__WARN__}, so if the code you're testing sets this, then this module will stop working. WWW: http://search.cpan.org/dist/Test2-Plugin-NoWarnings/
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test2-Plugin-NoWarnings/Makefile19
-rw-r--r--devel/p5-Test2-Plugin-NoWarnings/distinfo3
-rw-r--r--devel/p5-Test2-Plugin-NoWarnings/pkg-descr8
-rw-r--r--devel/p5-Test2-Plugin-NoWarnings/pkg-plist4
5 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e7a77bef0e6f..c1bb5a487cf0 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3364,6 +3364,7 @@
SUBDIR += p5-Test-YAML-Meta
SUBDIR += p5-Test-YAML-Valid
SUBDIR += p5-Test-utf8
+ SUBDIR += p5-Test2-Plugin-NoWarnings
SUBDIR += p5-Test2-Suite
SUBDIR += p5-Text-Levenshtein
SUBDIR += p5-Text-Levenshtein-Damerau
diff --git a/devel/p5-Test2-Plugin-NoWarnings/Makefile b/devel/p5-Test2-Plugin-NoWarnings/Makefile
new file mode 100644
index 000000000000..ea41c1755751
--- /dev/null
+++ b/devel/p5-Test2-Plugin-NoWarnings/Makefile
@@ -0,0 +1,19 @@
+# $FreeBSD$
+
+PORTNAME= Test2-Plugin-NoWarnings
+PORTVERSION= 0.02
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:DROLSKY
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Fail if tests warn
+
+LICENSE= ART20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= perl5
+USE_PERL5= configure
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test2-Plugin-NoWarnings/distinfo b/devel/p5-Test2-Plugin-NoWarnings/distinfo
new file mode 100644
index 000000000000..198633898184
--- /dev/null
+++ b/devel/p5-Test2-Plugin-NoWarnings/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474958024
+SHA256 (Test2-Plugin-NoWarnings-0.02.tar.gz) = 38cf62b0c8bea7cb6cbf02543e35ac43c5fe5921ad541b2c55ba240e28731749
+SIZE (Test2-Plugin-NoWarnings-0.02.tar.gz) = 22379
diff --git a/devel/p5-Test2-Plugin-NoWarnings/pkg-descr b/devel/p5-Test2-Plugin-NoWarnings/pkg-descr
new file mode 100644
index 000000000000..2a0fa405d1df
--- /dev/null
+++ b/devel/p5-Test2-Plugin-NoWarnings/pkg-descr
@@ -0,0 +1,8 @@
+Loading this plugin causes your tests to fail if there any
+warnings while they run. Each warning generates a new failing
+test and the warning content is outputted via diag.
+
+This module uses $SIG{__WARN__}, so if the code you're testing
+sets this, then this module will stop working.
+
+WWW: http://search.cpan.org/dist/Test2-Plugin-NoWarnings/
diff --git a/devel/p5-Test2-Plugin-NoWarnings/pkg-plist b/devel/p5-Test2-Plugin-NoWarnings/pkg-plist
new file mode 100644
index 000000000000..bffcdde28cc1
--- /dev/null
+++ b/devel/p5-Test2-Plugin-NoWarnings/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/Test2/Event/Warning.pm
+%%SITE_PERL%%/Test2/Plugin/NoWarnings.pm
+%%PERL5_MAN3%%/Test2::Event::Warning.3.gz
+%%PERL5_MAN3%%/Test2::Plugin::NoWarnings.3.gz