aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-21 01:00:58 +0800
committerantoine <antoine@FreeBSD.org>2016-09-21 01:00:58 +0800
commit441475a94e8fdd88468f065ec5018830fe010095 (patch)
tree56171da8a073d7db47440a3eaf95f323c78b8bab /devel
parentb9328acb2154b7ac7f7489e02d5bc3344761f5b2 (diff)
downloadfreebsd-ports-gnome-441475a94e8fdd88468f065ec5018830fe010095.tar.gz
freebsd-ports-gnome-441475a94e8fdd88468f065ec5018830fe010095.tar.zst
freebsd-ports-gnome-441475a94e8fdd88468f065ec5018830fe010095.zip
New port: devel/libvslvm
libvslvm is a library to access the Linux Logical Volume Manager (LVM) volume system format. WWW: https://github.com/libyal/libvslvm
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libvslvm/Makefile32
-rw-r--r--devel/libvslvm/distinfo3
-rw-r--r--devel/libvslvm/pkg-descr4
-rw-r--r--devel/libvslvm/pkg-plist18
5 files changed, 58 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 6f0a9568c1df..c8bef18431c6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1407,6 +1407,7 @@
SUBDIR += libvmdk
SUBDIR += libvolume_id
SUBDIR += libvshadow
+ SUBDIR += libvslvm
SUBDIR += libvterm
SUBDIR += libwfut
SUBDIR += libx86
diff --git a/devel/libvslvm/Makefile b/devel/libvslvm/Makefile
new file mode 100644
index 000000000000..de011b371e51
--- /dev/null
+++ b/devel/libvslvm/Makefile
@@ -0,0 +1,32 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= libvslvm
+# If/When moving from experimental to alpha, switch to DISTVERSIONPREFIX to prevent PORTEPOCH
+DISTVERSION= experimental-20160110
+CATEGORIES= devel
+MASTER_SITES= https://github.com/libyal/libvslvm/releases/download/${PORTVERSION:E}/ \
+ LOCAL/antoine
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Library and tools to access the LVM volume system format
+
+LICENSE= LGPL3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --enable-python --with-libintl-prefix=${LOCALBASE}
+USES= fuse gettext libtool pathfix pkgconfig python
+USE_LDCONFIG= yes
+INSTALL_TARGET= install-strip
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:E}
+
+PORTDOCS= AUTHORS ChangeLog
+
+OPTIONS_DEFINE= DOCS
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/libvslvm/distinfo b/devel/libvslvm/distinfo
new file mode 100644
index 000000000000..0c89dd1a87d1
--- /dev/null
+++ b/devel/libvslvm/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474383022
+SHA256 (libvslvm-experimental-20160110.tar.gz) = dad4d88b03601c3d89de3a2b277b13fd4ccae6065b42e8c9fcec8b70d60afba5
+SIZE (libvslvm-experimental-20160110.tar.gz) = 1476222
diff --git a/devel/libvslvm/pkg-descr b/devel/libvslvm/pkg-descr
new file mode 100644
index 000000000000..50298f4ae204
--- /dev/null
+++ b/devel/libvslvm/pkg-descr
@@ -0,0 +1,4 @@
+libvslvm is a library to access the Linux Logical Volume Manager (LVM) volume
+system format.
+
+WWW: https://github.com/libyal/libvslvm
diff --git a/devel/libvslvm/pkg-plist b/devel/libvslvm/pkg-plist
new file mode 100644
index 000000000000..640829b19221
--- /dev/null
+++ b/devel/libvslvm/pkg-plist
@@ -0,0 +1,18 @@
+bin/vslvminfo
+bin/vslvmmount
+include/libvslvm.h
+include/libvslvm/codepage.h
+include/libvslvm/definitions.h
+include/libvslvm/error.h
+include/libvslvm/extern.h
+include/libvslvm/features.h
+include/libvslvm/types.h
+lib/libvslvm.a
+lib/libvslvm.so
+lib/libvslvm.so.1
+lib/libvslvm.so.1.0.0
+%%PYTHON_SITELIBDIR%%/pyvslvm.a
+%%PYTHON_SITELIBDIR%%/pyvslvm.so
+libdata/pkgconfig/libvslvm.pc
+man/man1/vslvminfo.1.gz
+man/man3/libvslvm.3.gz