aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authoryzlin <yzlin@FreeBSD.org>2010-10-27 23:50:32 +0800
committeryzlin <yzlin@FreeBSD.org>2010-10-27 23:50:32 +0800
commit442431572dcd36986bff9c9461579bbf834c1aaa (patch)
treef0dacca8c2e0bfe71a7fdc02103cd13969f54eaa /devel
parentd62eda4607230b6042f8dd3372b44987ee51694d (diff)
downloadfreebsd-ports-gnome-442431572dcd36986bff9c9461579bbf834c1aaa.tar.gz
freebsd-ports-gnome-442431572dcd36986bff9c9461579bbf834c1aaa.tar.zst
freebsd-ports-gnome-442431572dcd36986bff9c9461579bbf834c1aaa.zip
- Update to 0.9.2
PR: ports/151445 Submitted by: lwhsu
Diffstat (limited to 'devel')
-rw-r--r--devel/py-fabric/Makefile7
-rw-r--r--devel/py-fabric/distinfo6
-rw-r--r--devel/py-fabric/files/patch-setup.py15
3 files changed, 13 insertions, 15 deletions
diff --git a/devel/py-fabric/Makefile b/devel/py-fabric/Makefile
index 6eac7fcc34fd..668aa669af9f 100644
--- a/devel/py-fabric/Makefile
+++ b/devel/py-fabric/Makefile
@@ -6,18 +6,19 @@
#
PORTNAME= fabric
-PORTVERSION= 0.9.1
+PORTVERSION= 0.9.2
PORTEPOCH= 1
CATEGORIES= devel python
MASTER_SITES= http://code.fabfile.org/projects/fabric/files/ \
- http://distfiles.yzlin.org/
+ CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Fabric-${DISTVERSIONPREFIX}${DISTVERSION}${DISTVERSIONSUFFIX}
MAINTAINER= yzlin@FreeBSD.org
COMMENT= A simple pythonic remote deployment tool
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=1.9:${PORTSDIR}/security/py-pycrypto
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=1.9:${PORTSDIR}/security/py-pycrypto \
+ ${PYTHON_PKGNAMEPREFIX}pycrypto>=1.7.6:${PORTSDIR}/security/py-paramiko
USE_PYTHON= yes
USE_PYDISTUTILS= easy_install
diff --git a/devel/py-fabric/distinfo b/devel/py-fabric/distinfo
index eda1f3f67228..085f0baaf22f 100644
--- a/devel/py-fabric/distinfo
+++ b/devel/py-fabric/distinfo
@@ -1,3 +1,3 @@
-MD5 (Fabric-0.9.1.tar.gz) = 2c2dc002d0da6cc4041f1c12be51e762
-SHA256 (Fabric-0.9.1.tar.gz) = 0dcff15de90b903dd5ab9f0dc82a3a116e4f4ea0a8b1e29283d41a5130de3c5a
-SIZE (Fabric-0.9.1.tar.gz) = 184256
+MD5 (Fabric-0.9.2.tar.gz) = 5ba652d4d4525fb6b470edf55747ea45
+SHA256 (Fabric-0.9.2.tar.gz) = 6ebee5349dd52f27765561284ca1e8a0924feda5dc848ace0b44da5c21e76d4e
+SIZE (Fabric-0.9.2.tar.gz) = 90721
diff --git a/devel/py-fabric/files/patch-setup.py b/devel/py-fabric/files/patch-setup.py
index d98bd9f60f99..004b9d82c07d 100644
--- a/devel/py-fabric/files/patch-setup.py
+++ b/devel/py-fabric/files/patch-setup.py
@@ -1,13 +1,10 @@
-
-$FreeBSD$
-
---- setup.py.orig
-+++ setup.py
-@@ -16,7 +16,6 @@
- author_email='jeff@bitprophet.org',
- url='http://fabfile.org',
+--- setup.py.orig 2010-10-14 13:37:04.963787042 +0800
++++ setup.py 2010-10-14 13:37:11.377290180 +0800
+@@ -31,7 +31,6 @@
packages=find_packages(),
-- install_requires=['pycrypto >=1.9'],
+ test_suite='nose.collector',
+ tests_require=['nose', 'fudge'],
+- install_requires=['pycrypto <2.1', 'paramiko >=1.7.6'],
entry_points={
'console_scripts': [
'fab = fabric.main:main',