aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-01-03 15:11:37 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-01-03 15:11:37 +0800
commit4716b2cc53573a65f45afb6bc3b4d4fc40582f76 (patch)
treec46d367d93c2ba475339f0be09a12a98cf679f88 /devel
parent2f9efa4c5fa6addc80f0b1cabe4d7ce43a37004c (diff)
downloadfreebsd-ports-gnome-4716b2cc53573a65f45afb6bc3b4d4fc40582f76.tar.gz
freebsd-ports-gnome-4716b2cc53573a65f45afb6bc3b4d4fc40582f76.tar.zst
freebsd-ports-gnome-4716b2cc53573a65f45afb6bc3b4d4fc40582f76.zip
- Update to 0.70
- Remove outdated post-patch: - Sort PLIST Changes: http://search.cpan.org/dist/Inline-CPP/Changes
Diffstat (limited to 'devel')
-rw-r--r--devel/p5-Inline-CPP/Makefile10
-rw-r--r--devel/p5-Inline-CPP/distinfo4
-rw-r--r--devel/p5-Inline-CPP/files/patch-Makefile.PL22
-rw-r--r--devel/p5-Inline-CPP/pkg-plist8
4 files changed, 21 insertions, 23 deletions
diff --git a/devel/p5-Inline-CPP/Makefile b/devel/p5-Inline-CPP/Makefile
index 99c6d5006fc5..16e5bbe9274e 100644
--- a/devel/p5-Inline-CPP/Makefile
+++ b/devel/p5-Inline-CPP/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= Inline-CPP
-PORTVERSION= 0.49
-PORTREVISION= 1
+PORTVERSION= 0.70
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -13,14 +12,13 @@ COMMENT= Write Perl subroutines and classes in C++
LICENSE= ART10
-BUILD_DEPENDS= p5-Inline>=0.53:${PORTSDIR}/devel/p5-Inline \
+BUILD_DEPENDS= p5-Inline>=0.78:${PORTSDIR}/devel/p5-Inline \
+ p5-Inline-C>=0.67:${PORTSDIR}/devel/p5-Inline-C \
p5-Parse-RecDescent>=0:${PORTSDIR}/devel/p5-Parse-RecDescent
RUN_DEPENDS:= ${BUILD_DEPENDS}
+BUILD_DEPENDS+= p5-ExtUtils-CppGuess>=0.07:${PORTSDIR}/devel/p5-ExtUtils-CppGuess
USES= perl5
USE_PERL5= configure
-post-patch:
- @${REINPLACE_CMD} -e 's|g++|${CXX}|' ${WRKSRC}/Makefile.PL
-
.include <bsd.port.mk>
diff --git a/devel/p5-Inline-CPP/distinfo b/devel/p5-Inline-CPP/distinfo
index 3812cd41f214..6292d803fc0f 100644
--- a/devel/p5-Inline-CPP/distinfo
+++ b/devel/p5-Inline-CPP/distinfo
@@ -1,2 +1,2 @@
-SHA256 (Inline-CPP-0.49.tar.gz) = 16efc1b908d83379e5ac05fb70225a3f4c88dabe825eb54c7faaf45bd52b672d
-SIZE (Inline-CPP-0.49.tar.gz) = 52497
+SHA256 (Inline-CPP-0.70.tar.gz) = 1722914110462c36146972720e6985e9c5e13fd5f540ee041fa918e552575568
+SIZE (Inline-CPP-0.70.tar.gz) = 63930
diff --git a/devel/p5-Inline-CPP/files/patch-Makefile.PL b/devel/p5-Inline-CPP/files/patch-Makefile.PL
index 377fc652d0f2..99a5dd7bcda2 100644
--- a/devel/p5-Inline-CPP/files/patch-Makefile.PL
+++ b/devel/p5-Inline-CPP/files/patch-Makefile.PL
@@ -1,15 +1,15 @@
---- ./Makefile.PL.orig 2013-01-01 03:27:22.000000000 +0800
-+++ ./Makefile.PL 2013-01-01 03:30:52.000000000 +0800
-@@ -121,10 +121,9 @@
- print "This will configure and build Inline::C++.\n";
+--- Makefile.PL.orig 2014-12-26 05:17:26.000000000 +0800
++++ Makefile.PL 2015-01-01 04:23:51.734420696 +0800
+@@ -37,10 +37,10 @@
+ my( $cc_guess, $libs_guess ) = guess_compiler();
my $cpp_compiler
-- = prompt( "What default C++ compiler would you like to use?", $cc_guess );
-+ = $cc_guess;
+- = prompt( "What C++ compiler would you like to use?", $cc_guess );
++ = $cc_guess;
+
+ my $libs
+- = prompt( "What default libraries would you like to include?", $libs_guess );
++ = $libs_guess;
--my $libs = prompt( "What default libraries would you like to include?",
-- $libs_guess );
-+my $libs = $libs_guess;
+ configure_distribution( $test_cpp_filename, $cpp_compiler, $libs );
- #============================================================================
- # Test whether the compiler prefers <iostream> or <iostream.h>.
diff --git a/devel/p5-Inline-CPP/pkg-plist b/devel/p5-Inline-CPP/pkg-plist
index cd630b7539e2..4a966063c559 100644
--- a/devel/p5-Inline-CPP/pkg-plist
+++ b/devel/p5-Inline-CPP/pkg-plist
@@ -1,7 +1,7 @@
-%%PERL5_MAN3%%/Inline::CPP.3.gz
-%%PERL5_MAN3%%/Inline::CPP::Config.3.gz
-%%PERL5_MAN3%%/Inline::CPP::grammar.3.gz
%%SITE_PERL%%/Inline/CPP.pm
%%SITE_PERL%%/Inline/CPP.pod
%%SITE_PERL%%/Inline/CPP/Config.pm
-%%SITE_PERL%%/Inline/CPP/grammar.pm
+%%SITE_PERL%%/Inline/CPP/Parser/RecDescent.pm
+%%PERL5_MAN3%%/Inline::CPP.3.gz
+%%PERL5_MAN3%%/Inline::CPP::Config.3.gz
+%%PERL5_MAN3%%/Inline::CPP::Parser::RecDescent.3.gz