aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-11-30 01:50:36 +0800
committermva <mva@FreeBSD.org>2013-11-30 01:50:36 +0800
commit477978b3c0aba5de00b5d9eb848b1366cac8debb (patch)
treee7d99503e3d9e661026cd9273b1c0d21f1ca8800 /devel
parent485f2356d9102591704df7bc3f26de2ab841a414 (diff)
downloadfreebsd-ports-gnome-477978b3c0aba5de00b5d9eb848b1366cac8debb.tar.gz
freebsd-ports-gnome-477978b3c0aba5de00b5d9eb848b1366cac8debb.tar.zst
freebsd-ports-gnome-477978b3c0aba5de00b5d9eb848b1366cac8debb.zip
- Fix the usage of 'python' to get rid of the implicit lang/python
dependency Approved by: gnn@ (maintainer)
Diffstat (limited to 'devel')
-rw-r--r--devel/zookeeper/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/devel/zookeeper/Makefile b/devel/zookeeper/Makefile
index 4f2b40bf58b9..26142be22c8d 100644
--- a/devel/zookeeper/Makefile
+++ b/devel/zookeeper/Makefile
@@ -49,7 +49,7 @@ NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MPYTHON}
-USE_PYTHON= yes
+USE_PYTHON= -2.7
BUILD_DEPENDS+= ant:${PORTSDIR}/devel/apache-ant
PLIST_SUB+= WITH_PYTHON=""
.else
@@ -75,6 +75,10 @@ run-autotools:
${SETENV} ${AUTOTOOLS_ENV} ${AUTORECONF} -if
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|executable="python"|executable="${PYTHON_CMD}"|' \
+ ${PYTHON_BINDING_WRKSRC}/build.xml
+
do-build:
.if ${PORT_OPTIONS:MC}
cd ${CONFIGURE_WRKSRC} && \