aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorobrien <obrien@FreeBSD.org>2004-03-25 08:03:28 +0800
committerobrien <obrien@FreeBSD.org>2004-03-25 08:03:28 +0800
commit4826fff1a5e593991eb0f4144203049350525311 (patch)
tree5d71b7f1368dfc20cb7dcd15feaee66ec43bb363 /devel
parentdc56915f2eba7c1ed3c784d8c33215ebb4ed51c5 (diff)
downloadfreebsd-ports-gnome-4826fff1a5e593991eb0f4144203049350525311.tar.gz
freebsd-ports-gnome-4826fff1a5e593991eb0f4144203049350525311.tar.zst
freebsd-ports-gnome-4826fff1a5e593991eb0f4144203049350525311.zip
Link gdb6 to gdb on platforms w/o /usr/src gdb support.
Diffstat (limited to 'devel')
-rw-r--r--devel/gdb6/Makefile19
-rw-r--r--devel/gdb6/pkg-plist1
-rw-r--r--devel/gdb66/Makefile19
-rw-r--r--devel/gdb66/pkg-plist1
4 files changed, 30 insertions, 10 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index 4a182f499c64..b5275c1ae4f7 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -27,6 +27,19 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+PLIST_SUB+= NO_NATIVE_GDB=""
+post-install:
+ cd ${PREFIX}/bin ; ${LN} -sf gdb${PORTVERSION} gdb
+.else
+PLIST_SUB+= NO_NATIVE_GDB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/$$/ [FreeBSD]/' ${WRKSRC}/gdb/version.in
@@ -45,8 +58,4 @@ cklatest:
ftp://sources.redhat.com/pub/${MASTER_SITE_SUBDIR}/ \
| ${GREP} gdb+dejagnu-weekly
-.include <bsd.port.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.endif
+.include <bsd.port.post.mk>
diff --git a/devel/gdb6/pkg-plist b/devel/gdb6/pkg-plist
index 18c85983f58d..6118ca15f1e0 100644
--- a/devel/gdb6/pkg-plist
+++ b/devel/gdb6/pkg-plist
@@ -1,2 +1,3 @@
@comment $FreeBSD$
bin/gdb6
+%%NO_NATIVE_GDB%%bin/gdb
diff --git a/devel/gdb66/Makefile b/devel/gdb66/Makefile
index 4a182f499c64..b5275c1ae4f7 100644
--- a/devel/gdb66/Makefile
+++ b/devel/gdb66/Makefile
@@ -27,6 +27,19 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-suffix=6
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "amd64"
+CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
+.endif
+.if ${ARCH} == "amd64" || ${ARCH} == "sparc64" || ${ARCH} == "ia64"
+PLIST_SUB+= NO_NATIVE_GDB=""
+post-install:
+ cd ${PREFIX}/bin ; ${LN} -sf gdb${PORTVERSION} gdb
+.else
+PLIST_SUB+= NO_NATIVE_GDB="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's/$$/ [FreeBSD]/' ${WRKSRC}/gdb/version.in
@@ -45,8 +58,4 @@ cklatest:
ftp://sources.redhat.com/pub/${MASTER_SITE_SUBDIR}/ \
| ${GREP} gdb+dejagnu-weekly
-.include <bsd.port.mk>
-
-.if ${ARCH} == "amd64"
-CONFIGURE_TARGET= x86_64-portbld-freebsd${OSREL}
-.endif
+.include <bsd.port.post.mk>
diff --git a/devel/gdb66/pkg-plist b/devel/gdb66/pkg-plist
index 18c85983f58d..6118ca15f1e0 100644
--- a/devel/gdb66/pkg-plist
+++ b/devel/gdb66/pkg-plist
@@ -1,2 +1,3 @@
@comment $FreeBSD$
bin/gdb6
+%%NO_NATIVE_GDB%%bin/gdb