aboutsummaryrefslogtreecommitdiffstats
path: root/devel
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2014-07-30 00:42:11 +0800
committerbf <bf@FreeBSD.org>2014-07-30 00:42:11 +0800
commit4a771feb45316e19aed54c16561071a5d23cf52b (patch)
tree622d54fa4a7f3c7bbf11ee48c86ccefa4102a6ff /devel
parentdb97905ad5e4a965daa6ed8094626e7651c138f4 (diff)
downloadfreebsd-ports-gnome-4a771feb45316e19aed54c16561071a5d23cf52b.tar.gz
freebsd-ports-gnome-4a771feb45316e19aed54c16561071a5d23cf52b.tar.zst
freebsd-ports-gnome-4a771feb45316e19aed54c16561071a5d23cf52b.zip
Convert the pcretest command-line editing support into non-default options
Submitted by: peter, zi
Diffstat (limited to 'devel')
-rw-r--r--devel/pcre/Makefile14
1 files changed, 9 insertions, 5 deletions
diff --git a/devel/pcre/Makefile b/devel/pcre/Makefile
index 0f8fce9a5773..c3154cb1990f 100644
--- a/devel/pcre/Makefile
+++ b/devel/pcre/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pcre
PORTVERSION= 8.34
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION} \
ftp://ftp.csx.cam.ac.uk/pub/software/programming/%SUBDIR%/ \
@@ -18,18 +18,22 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENCE
GNU_CONFIGURE= yes
-USES= libtool:oldver pathfix readline tar:bzip2
+USES= libtool:oldver pathfix tar:bzip2
USE_LDCONFIG= yes
CONFIGURE_ARGS= --enable-utf --enable-unicode-properties \
- --enable-pcre8 --enable-pcre16 --enable-pcre32 \
- --enable-pcretest-libedit
+ --enable-pcre8 --enable-pcre16 --enable-pcre32
INSTALL_TARGET= install-strip
-OPTIONS_DEFINE= STACK_RECURSION DOCS
+OPTIONS_DEFINE= DOCS LIBEDIT READLINE STACK_RECURSION
OPTIONS_DEFAULT= STACK_RECURSION
STACK_RECURSION_DESC= Use the stack for recursion during matching
+LIBEDIT_CONFIGURE_ENABLE= pcretest-libedit
+
+READLINE_USES= readline
+READLINE_CONFIGURE_ENABLE= pcretest-libreadline
+
.include <bsd.port.options.mk>
.if ${ARCH} != "sparc64" && ${ARCH} != "ia64" && ${ARCH:Mmips64*} == ""